Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 257839 - media-video/mplayer-1.0_rc2_p28450: QA Notice: Package has poor programming practices
Summary: media-video/mplayer-1.0_rc2_p28450: QA Notice: Package has poor programming p...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High QA (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-05 23:28 UTC by Matteo Modesti
Modified: 2009-08-03 20:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
QA Notices printed out (QANotice.txt,2.07 KB, text/plain)
2009-02-05 23:31 UTC, Matteo Modesti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matteo Modesti 2009-02-05 23:28:35 UTC
Hi.
I just compiled media-video/mplayer-1.0_rc2_p28450 and it printed out some QA Notices, that I'll attach with the next comment.

Reproducible: Always

Steps to Reproduce:
Compile mplayer-1.0_rc2_p28450



# emerge --info
Portage 2.2_rc23 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r1, 2.6.28-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r1-x86_64-AMD_Phenom-tm-_9850_Quad-Core_Processor-with-glibc2.2.5
Timestamp of tree: Thu, 05 Feb 2009 21:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/"
LANG="it_IT.UTF-8"
LC_ALL="it_IT.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="it en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/mattemod/mio-portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 3ds 64bit 7zip X Xaw3d a52 aac ace acl acpi additions aio akode alsa amd64 ao apache2 audacious audiofile autoreplace bash-completion berkdb branding bzip2 cairo cal3d caps ccache cdda cddb cdio cdparanoia cdr chardet chroot cli cpudetection cracklib crypt css cups curl dbus dga dirac directfb divx dmi double-precision dri dts dv dvb dvd dvdr dvdread ecc emovix enca encode exif expat fam fame fbcon fbdev ffmpeg fftw firefox flac flash fontconfig fortran fpx ftp gcj gd gdbm ggi gif gimp glib glitz glut gmedia gmp gnutls gpm graphviz gs gtk gtkhtml guile gzip hal hdri history iconv id3 id3tag idea imagemagick imlib isdnlog jabber java5 java6 javascript jbig jingle jpeg jpeg2k justify kde kdrive ladspa lame lcms libcaca libffi libnotify libsamplerate lm_sensors loop-aes lzo mad matroska md5sum messenger midi mikmod mime mjpeg mmap mmx mmxext mng modplug mono motif mozdom mp2 mp3 mp4 mpeg mpeg2 mplayer msn mudflap multilib musepack musicbrainz mysql ncurses networking nls nokia6600 nptl nptlonly nsplugin ntlm nuv oav objc objc++ objc-gc offensive ogg openal openexr opengl openmp openssl pam paste64 pch pcre pdf perl physfs plasma png ppds pppd pth python qt3 qt3support qt4 quicktime radio rar readline realmedia reflection replytolist rtc rtsp samba schroedinger scrobbler sdl sdl-image sdl-sound sdlaudio sensord session shout slang slp smp sms sndfile sockets speex spell spl sql srp srt sse sse2 sse3 ssl statistics stream svg sysfs syslog szip t1lib tcpd tetex tga theora threads tidy tiff toolbar truetype tta type1 unicode unzip usb utempter v4l v4l2 vcd vdr vorbis wav wavpack wifi winbind wma wmf wmp x264 xanim xforms xine xml xorg xpm xprint xsl xulrunner xv xvid xvmc zip zlib" ALSA_CARDS="ca0106" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif speling status unique_id userdir usertrack vhost_alias" DVB_CARDS="usb-dib0700" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it en" USERLAND="GNU" VIDEO_CARDS="fglrx radeon radeonhd vesa vga fbdev"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Matteo Modesti 2009-02-05 23:31:35 UTC
Created attachment 181102 [details]
QA Notices printed out

QA Notices printed out after installation
Comment 2 Martin Walch 2009-02-16 23:38:17 UTC
Portage asks for reporting upstream, but this is difficult, because there are no more official releases, but daily snapshots. Often it won't even build. And it is hard to compare the Gentoo snapshot and the daily snapshot with hundreds of options and patches etc.
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2009-08-03 20:41:35 UTC
That's why you use -9999 ebuild and report issues to mplayer mailinglist.