Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 257761 - sys-auth/consolekit needs to create /var/run/console/<USER> files
Summary: sys-auth/consolekit needs to create /var/run/console/<USER> files
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-05 09:53 UTC by Tiziano Müller (RETIRED)
Modified: 2016-01-11 07:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tiziano Müller (RETIRED) gentoo-dev 2009-02-05 09:53:02 UTC
With pam_console gone, nothing creates the /var/run/console/<USER> tag files which breaks at least bluez which needs at_console-support in dbus to allow the local user to pair devices using gnome-bluetooth.

Until dbus is fixed to use consolekit directly or any other solution gets realized, I'd say we do it like the ubuntu/debian guys and add the pam-foregruond-compat.ck script to /usr/lib/ConseleKit/run-session.d together with the cleanup-patch (for example from http://archive.ubuntu.com/ubuntu/pool/main/c/consolekit/consolekit_0.3-0ubuntu3.diff.gz) to have the tag files generated/cleaned-up automatically.
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-02-05 10:14:25 UTC
I'd rather fix the packages still relying on pam_console. pam_console has been removed from the tree months ago because it was just a big hack for what consolekit now does.

Also, could you find a reference for this patch on upstream bugzilla ?
Comment 2 Tiziano Müller (RETIRED) gentoo-dev 2009-02-05 10:52:46 UTC
The problem is that dbus itself relies on pam_console for the at_console selection for permissions.

Here's the upstream bug for this:
http://bugs.freedesktop.org/show_bug.cgi?id=14053

The problem I see here is the same mentioned in the bug: dbus issueing a dbus-call for getting the info whether a user is local is a no go. Adding a seperate group for packages using at_console in a dbus-rule to work around at_console sucks as well.

We might have to ask upstream (dbus-maintainers) for their plans.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-02-15 22:35:09 UTC
patch and script added to 0.2.10-r1. Thanks for reporting.
Comment 4 Javier 2016-01-11 00:54:44 UTC
This bug seems to be back in sys-auth/consolekit-1. I've reported the new symptoms in bug #571524 .
Comment 5 Gilles Dartiguelongue gentoo-dev 2016-01-11 07:16:09 UTC
It has been 7 years, please file a new bug with a link to this one.
Comment 6 Gilles Dartiguelongue gentoo-dev 2016-01-11 07:17:07 UTC
ah, already done.