Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 257536 - fatal server error with x11-drivers/ati-drivers-8.573 and x11-drivers/ati-drivers-8.561
Summary: fatal server error with x11-drivers/ati-drivers-8.573 and x11-drivers/ati-dri...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Luca Barbato
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-03 22:21 UTC by Loop
Modified: 2010-11-23 23:48 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The Xorg log when i loaded 8.573 (Xorg.0.log.old,36.16 KB, text/plain)
2009-02-03 22:24 UTC, Loop
Details
xorg.conf I'm using (xorg.conf,2.64 KB, text/plain)
2009-02-03 22:24 UTC, Loop
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Loop 2009-02-03 22:21:37 UTC
After emerging ati-drivers-8.573 or ati-drivers-8.561 X crashes. Visually it seems kdm is starting (can see the gray window of kdm greeter for a moment) but then it reverts back to terminal prompt. It retries starting few times in the same way and then halts. All ok with 8.552-r2 and older versions.
I have a radeon 9600 256MB card, running 2.6.27-r8 kernel. 
Will post Xorg.0.log and xorg.conf asap.

Thanks

Reproducible: Always

Steps to Reproduce:
1. emerge ati-drivers-8.573 (or ati-drivers-8.561)
2. restart
Comment 1 Loop 2009-02-03 22:24:17 UTC
Created attachment 180855 [details]
The Xorg log when i loaded 8.573

Mainly this part:

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x812887b]
1: /usr/bin/X(xf86SigHandler+0x51) [0x80c8c71]
2: [0xb7fa9400]
3: /usr/lib/xorg/modules//libxaa.so(XAAComposite+0x16e) [0xb74c1f4e]
4: /usr/lib/xorg/modules//libxaa.so [0xb74de0ef]
5: /usr/bin/X [0x816ca09]
6: /usr/bin/X(CompositePicture+0x168) [0x8153628]
7: /usr/bin/X [0x8159416]
8: /usr/bin/X [0x81561c5]
9: /usr/bin/X(Dispatch+0x33f) [0x8088f1f]
10: /usr/bin/X(main+0x465) [0x806fa85]
11: /lib/libc.so.6(__libc_start_main+0xdc) [0xb7b36fdc]
12: /usr/bin/X(FontFileCompleteXLFD+0x1f9) [0x806eea1]

Fatal server error:
Caught signal 8.  Server aborting
Comment 2 Loop 2009-02-03 22:24:45 UTC
Created attachment 180856 [details]
xorg.conf I'm using
Comment 3 Loop 2009-02-06 16:27:58 UTC
I found out that the options causing the crash are:

in /etc/X11/xorg.conf

Section "Device"

...

        Option "Textured2D" "on"
        Option "TexturedXRender" "on"

...

EndSection

Those two, if set together, cause the crash.

I don't know what should i do now with the bug, consider it fixed or leave as new?
Comment 4 Enrico Tagliavini 2010-10-03 16:50:42 UTC
A note about this in the gentoo ati faq might me worth.

Anyway it is a good policy to leave the driver settings as default, if they are not enabled by default there is a reason :)
Comment 5 Enrico Tagliavini 2010-11-23 23:48:56 UTC
I think this can be marked as fixed since one of the 2 option is no more used by fglrx (at least if you are using the new d2d engine)

(WW) fglrx(0): Option "Textured2D" is not used