Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 257337 - www-client/epiphany-extensions-2.24.3 - fails to build with libtool-1
Summary: www-client/epiphany-extensions-2.24.3 - fails to build with libtool-1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on: 257399
Blocks: 260063
  Show dependency tree
 
Reported: 2009-02-02 06:44 UTC by Jeroen Roovers (RETIRED)
Modified: 2009-02-27 14:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
www-client:epiphany-extensions-2.24.3:20090202-062324.log [hppa,fail] (20090202-062324.log,43.76 KB, text/plain)
2009-02-02 06:44 UTC, Jeroen Roovers (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers (RETIRED) gentoo-dev 2009-02-02 06:44:17 UTC
Looks like a sys-devel/libtool-2.2 problem to me.

Mon Feb  2 07:43:35 CET 2009
Portage 2.1.6.7 (default/linux/hppa/2008.0, gcc-4.2.4, glibc-2.7-r2, 2.6.29-rc3-JeR parisc)
=================================================================
System uname: Linux-2.6.29-rc3-JeR-parisc-PA8700_-PCX-W2-with-glibc2.2
Timestamp of tree: Mon, 02 Feb 2009 05:15:02 +0000
distcc 3.0 hppa2.0-unknown-linux-gnu [enabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p48
dev-lang/python:     2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.2
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="hppa"
CBUILD="hppa2.0-unknown-linux-gnu"
CFLAGS="-O2 -pipe -mschedule=8000 -march=2.0 -g -ggdb -Wall"
CHOST="hppa2.0-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/fax /usr/share/config /var/bind /var/spool/fax/etc /var/www/localhost/htdocs/wordpress/wp-config.php"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -mschedule=8000 -march=2.0 -g -ggdb -Wall"
DISTDIR="/keeps/gentoo/distfiles"
FEATURES="autoaddcvs buildpkg cvs distcc distlocks fixpackages notitles parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS=" http://gentoo.tiscali.nl/ http://mirror.muntinternet.net/pub/gentoo/ http://mirror.cambrium.nl/pub/os/linux/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo/ "
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en nl he"
MAKEOPTS="-j5"
PKGDIR="/keeps/gentoo/packages/elmer"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/mnt/alt/portage-tmp"
PORTDIR="/keeps/gentoo/portage"
PORTDIR_OVERLAY="/keeps/gentoo/local"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip X Xaw3d a52 aac aalib accessibility ads agg alsa amr amrnb amrwb ao aoss apache2 ares arts asf async asyncns audiofile audit automount avfs bash-completion berkdb bidi bittorrent bl bluetooth bzip2 c++ cairo caps catalogs cblas cdb cddb cdparanoia cdr chardet cjk clarens cli cracklib crypt cups curl custom-cflags cxx dbi dbtool dbus device-mapper dga dia dirac djbfft domainkeys dri drm dts dv dvd dvdr dvdread dxr3 edl elf emacs enca encode esd examples exif expat fame fastbuild fastcgi fbcon ffmpeg filter flac fontconfig foomaticdb fortran ftp gadu galago gcrypt gd gdbm geant4 geoip ggi gif gimp gimpprint glep glib glut gmp gnome gnutls gphoto2 gpm gs gsl gsm gtk gtk2 gtkhtml hal hepmc hesiod hppa ical icecast iconv icu idea idn imagemagick imlib immqt-bc inquisitio ipv6 isc isdnlog ithreads jack javascript jbig jingle jpeg jpeg2k judy kde kerberos kpathsea lapack latex lcms ldap leim libass libcaca libnotify libsamplerate libwww live lm_sensors logrotate logwatch lua lzo mad manhole matroska mbrola memcache metis mhash midi mikmod mmap mng modplug motif mozbranding mp3 mplayer mssql mudflap musepack mysql nas ncurses netpbm network-cron nfconntrack nfs nls nntp nptl nptlonly nsplugin ntlm offensive ogg openal openexr opengl openmp oss ots overlays pam pango pbs pcre pdf pdo-external perl php plotutils plugins png portage portaudio postgres povray ppds pppd pulseaudio python pyzord qdbm qt3 qt3support qt4 quotas raw readline recode reflection rle rpc rrdtool rtc ruby samba sasl scanner schroedinger scim sdl seamonkey server session sid slang slp sms sndfile snmp soundex speex spell spl sqlite srt ssh ssl startup-notification subtitles subversion suhosin supernodal svg swat sysfs syslog talkfilters tcl tcpd test tftp tga theora threads thunar-vfs tidy tiff timidity tk tools truetype twolame udev unicode unzip urandom usb userlocales utempter utf v4l v4l2 vanim vcd vidix vim-syntax vorbis wavpack webdav webinstall winbind wlan wma wmf xanim xchattext xcomposite xface xml xml2 xmp xmpi xorg xpm xrandr xscreensaver xsettings xulrunner xv xvid xvmc zip zip-external zlib" ALSA_CARDS="ad1889 usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_ftp proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en nl he" USERLAND="GNU" VIDEO_CARDS="stifb fbdev matrox"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2009-02-02 06:44:52 UTC
Created attachment 180661 [details]
www-client:epiphany-extensions-2.24.3:20090202-062324.log [hppa,fail]
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-02-02 07:45:06 UTC
indeed, and I hate you for that :p
also that's not a libtool breakage in the sense that the problem is you having libtool-1 on your system and epiphany using libtool-2 and doing eautoreconf.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2009-02-02 16:37:43 UTC
How isn't this a "libtool 2.2 breakage" problem? Compare bug #212718, update to subversion 1.5 if you have libtool 2.2, There is no libtool stabilisation tracker, so the only way right now to track libtool 2.2 bugs is to handle both types of dependencies on the same bug.
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-02-02 16:46:36 UTC
its not a libtool failure because it's my failure, please also see bug #255542.

It would work just fine if you had libtool-2 on your machine.
Comment 5 Gilles Dartiguelongue gentoo-dev 2009-02-02 17:09:28 UTC
I'll repeat myself since preceeding comment didn't reach its target the first time.

This is not a failure of libtool-2, it's a failure of users using libtool-1 with ~arch packages expecting libtool-2. If you have libtool-2 on your system, then you'll have no problem merging these packages, hence the tracker bug DO NOT want to relate to these bugs.
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2009-02-02 17:17:34 UTC
(In reply to comment #5)
> I'll repeat myself since preceeding comment didn't reach its target the first
> time.

How do you expect mail to work, really?
Comment 7 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-02-27 14:46:38 UTC
Fixed.