Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 257019 - media-video/avidemux-2.4.3 USE="-qt4 -gtk" - complains of missing dependency on x11-libs/libX11
Summary: media-video/avidemux-2.4.3 USE="-qt4 -gtk" - complains of missing dependency ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Ben de Groot (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-30 23:27 UTC by Florian Knodt
Modified: 2009-06-05 01:04 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (vanilla_build_x11dep.log,2.72 KB, text/plain)
2009-01-30 23:28 UTC, Florian Knodt
Details
CMakeLists.txt: Ignore X11-dependency if NO_X11 is set (avidemux-2.4.3-nox11.patch,839 bytes, patch)
2009-01-30 23:34 UTC, Florian Knodt
Details | Diff
this ebuild sets NO_X11 when USE="-gtk -qt4" (avidemux-2.4.3-r1.ebuild,4.01 KB, text/plain)
2009-01-30 23:35 UTC, Florian Knodt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Knodt 2009-01-30 23:27:59 UTC
Even if avidemux-2.4.3 is build with USE="-qt4 -gtk" (=no GUI, just CLI) the CMake-Script requires X11 but in this case libX11 is not listed as a dependency.

Reproducible: Always

Steps to Reproduce:
1. USE="-gtk -qt4" emerge =media-video/avidemux-2.4.3 on a PC without libX11
Actual Results:  
[...]
-- <Checking for X11>
-- <******************************>
CMake Error: Could not find X11
-- Configuring done
[...]

Expected Results:  
Build CLI without checking for X11 or depend on libX11

I installed libX11 and could compile succesfully. After the package was merged i removed libX11 and its dependencys - avidemux2_cli seems to run without it so i think it would be possible to change the CMake-script to ignore the X11-check in this case.

--

ldd `which avidemux2_cli`
	linux-vdso.so.1 =>  (0x000064e623fac000)
	libpng12.so.0 => /usr/lib/libpng12.so.0 (0x000064e623b67000)
	libxml2.so.2 => /usr/lib/libxml2.so.2 (0x000064e6238f4000)
	libSDL-1.2.so.0 => /usr/lib/libSDL-1.2.so.0 (0x000064e6236a5000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x000064e62348a000)
	libamrnb.so.3 => /usr/lib/libamrnb.so.3 (0x000064e62324a000)
	libmp3lame.so.0 => /usr/lib/libmp3lame.so.0 (0x000064e622fcb000)
	libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x000064e622d9c000)
	libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0x000064e6229c3000)
	libfaac.so.0 => /usr/lib/libfaac.so.0 (0x000064e6227b0000)
	libfaad.so.1 => /usr/lib/libfaad.so.1 (0x000064e622567000)
	libxvidcore.so.4 => /usr/lib/libxvidcore.so.4 (0x000064e62226e000)
	libx264.so.65 => /usr/lib/libx264.so.65 (0x000064e621fde000)
	libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x000064e621cec000)
	libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.6/libstdc++.so.6 (0x000064e621991000)
	libm.so.6 => /lib/libm.so.6 (0x000064e62170a000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x000064e6214fe000)
	libc.so.6 => /lib/libc.so.6 (0x000064e6211ba000)
	libz.so.1 => /lib/libz.so.1 (0x000064e620fa4000)
	libdl.so.2 => /lib/libdl.so.2 (0x000064e620da0000)
	/lib64/ld-linux-x86-64.so.2 (0x000064e623d93000)
	libogg.so.0 => /usr/lib/libogg.so.0 (0x000064e620b99000)

--

Portage 2.1.6.4 (hardened/linux/amd64/2008.0, gcc-3.4.6-vanilla, glibc-2.6.1-r0, 2.6.27-hardened-r7-yw x86_64)
=================================================================
System uname: Linux-2.6.27-hardened-r7-yw-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-glibc2.3.2
Timestamp of tree: Fri, 30 Jan 2009 08:15:02 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.63
sys-devel/automake:  1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -fforce-addr -mno-tls-direct-seg-refs"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -fforce-addr -mno-tls-direct-seg-refs"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.yw.int/ ftp://distfiles.yw.int/"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://portage.yw.int/gentoo-portage"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cups dri gdbm gnutls gpm hardened iconv isdnlog justify logrotate midi mmx mudflap multilib ncurses netboot nptl nptlonly nptonly openmp pam pcre perl pic pppd python readline reflection session spl sse sse2 ssl sysfs tcpd urandom xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Florian Knodt 2009-01-30 23:28:29 UTC
Created attachment 180328 [details]
build.log
Comment 2 Florian Knodt 2009-01-30 23:34:36 UTC
Created attachment 180333 [details, diff]
CMakeLists.txt: Ignore X11-dependency if NO_X11 is set
Comment 3 Florian Knodt 2009-01-30 23:35:06 UTC
Created attachment 180335 [details]
this ebuild sets NO_X11 when USE="-gtk -qt4"

Since i have currently no test-pc with x11 here this is only tested with USE="-gtk -qt4"
Comment 4 Ben de Groot (RETIRED) gentoo-dev 2009-06-05 01:04:42 UTC
Fixed in 2.4.4-r2