Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 256976 - dev-libs/soprano-2.2 fails to emerge due to JAVA_INCLUDE_PATH2
Summary: dev-libs/soprano-2.2 fails to emerge due to JAVA_INCLUDE_PATH2
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-30 19:40 UTC by David Ripton
Modified: 2010-06-11 16:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Ripton 2009-01-30 19:40:00 UTC
"emerge soprano" fails.  The error is from cmake, complaining about a lack of JAVA_INCLUDE_PATH2.  This is on ~x86.  emerge command and emerge --info follow.

Thanks.


$ sudo emerge -1 soprano
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-libs/soprano-2.2
 * soprano-2.2.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                      [ ok ]
 * checking ebuild checksums ;-) ...                                                                        [ ok ]
 * checking auxfile checksums ;-) ...                                                                       [ ok ]
 * checking miscfile checksums ;-) ...                                                                      [ ok ]
 * Using: sun-jdk-1.6
>>> Unpacking source...
>>> Unpacking soprano-2.2.tar.bz2 to /var/tmp/portage/dev-libs/soprano-2.2/work
>>> Source unpacked in /var/tmp/portage/dev-libs/soprano-2.2/work
>>> Configuring source in /var/tmp/portage/dev-libs/soprano-2.2/work/soprano-2.2 ...
 * Disabled building of soprano tests.
loading initial cache file /var/tmp/portage/dev-libs/soprano-2.2/temp/gentoo_common_config.cmake
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/i686-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/i686-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/i686-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/i686-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.4.2
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Found CLucene library: /usr/lib/libclucene.so
-- Found CLucene include dir: /usr/include
-- Found CLucene library dir: /usr/lib
-- Found CLucene: /usr/lib/libclucene.so
-- Found Java JNI >= 1.4: /usr/include, /opt/sun-jdk-1.6.0.11/jre/lib/i386/client/libjvm.so
-- Performing Test __SOPRANO_HAVE_GCC_VISIBILITY
-- Performing Test __SOPRANO_HAVE_GCC_VISIBILITY - Success
---------------------------------------------------------------------------------------
-- Soprano Components that will be built:
   * Sesame2 storage backend (java-based)
   * The CLucene-based full-text search index library

-- Soprano Components that will NOT be built:
   * Redland storage backend
   * Raptor RDF parser
   * Raptor RDF serializer
---------------------------------------------------------------------------------------
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
JAVA_INCLUDE_PATH2 (ADVANCED)
   used as include directory in directory /var/tmp/portage/dev-libs/soprano-2.2/work/soprano-2.2/backends/sesame2

-- Configuring incomplete, errors occurred!
 *
 * ERROR: dev-libs/soprano-2.2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_configure
 *             environment, line 4254:  Called cmake-utils_src_configure
 *             environment, line  746:  Called cmake-utils_src_configureout
 *             environment, line  765:  Called die
 * The specific snippet of code:
 *       cmake -C "${TMPDIR}/gentoo_common_config.cmake" ${cmakeargs} "${S}" || die "Cmake failed";
 *  The die message:
 *   Cmake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/dev-libs:soprano-2.2:20090130-193537.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/soprano-2.2/temp/environment'.
 *
!!! When you file a bug report, please include the following information:
GENTOO_VM=sun-jdk-1.6  CLASSPATH="" JAVA_HOME="/opt/sun-jdk-1.6.0.11"
JAVACFLAGS="-source 1.6 -target 1.6" COMPILER=""
and of course, the output of emerge --info

>>> Failed to emerge dev-libs/soprano-2.2

$ emerge --info
Portage 2.1.6.7 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.9_p20081201-r1, 2.6.28-gentoo-r1 i686)
=================================================================
System uname: Linux-2.6.28-gentoo-r1-i686-AMD_Phenom-tm-_9950_Quad-Core_Processor-with-gentoo-2.0.0
Timestamp of tree: Fri, 30 Jan 2009 08:00:01 +0000
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2, 2.6.1
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.2
sys-apps/sandbox:    1.3.3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon64 -O3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://gentoo.oregonstate.edu/ http://gentoo.mirrors.pair.com/ http://mirror.datapipe.net/gentoo http://128.213.5.34/gentoo/ http://mirror.datapipe.net/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X aac acl acpi alsa apache2 avahi bash-completion bluetooth branding bzip2 cairo cdr cli cracklib crypt cups d dbus dri dvd dvdr dvdread eds emboss encode esd evo fam firefox fortran gdbm gif glitz gnome gpm gstreamer gtk gtk2 hal iconv imap ipv6 isdnlog java jpeg junit kde kde4 kdeprefix ldap libnotify mad maildir midi mikmod mmx mozdevelop mozilla mozsvg mp3 mpeg mudflap ncurses nls nptl nptlonly ogg oggvorbis opengl openmp oss pam pcre pdf perl png ppds pppd python qt qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sse ssl startup-notification svg sysfs tcpd theora tiff truetype unicode usb vorbis win32codecs x86 xinerama xml xorg xulrunner xv zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 David Ripton 2009-02-02 14:11:11 UTC
More info:

I can't reproduce this on my other Gentoo box, but it's still happening on the first machine.

I uninstalled and reinstalled sun-jdk and reran java-config, to no avail.

A workaround was to add "dev-libs/soprano -sesame2 redland" to /etc/portage/package.use, to make it use the non-Java redland backend instead of the Java sesame2 backend.  Not a great workaround because media-sound/amarok wants sesame2.

I can make it build by hand with "cmake --prefix=/usr -DJAVA_INCLUDE_PATH=/usr/lib/jvm/sun-jdk-1.6/include -DJAVA_INCLUDE_PATH2=/usr/lib/jvm/sun-jdk-1.6/include/linux", but I haven't tried merging that into the ebuild, since it really should be picked up automatically.
Comment 2 Timo Gurr (RETIRED) gentoo-dev 2009-02-02 15:29:28 UTC
If your first machine has been running Gentoo for a while then there could be some left-over java related files in /etc/env.d causing some trouble. Try cleaning them out, reinstall sun-jdk-1.6, follow the java installation guide:
http://www.gentoo.org/doc/en/java.xml and set your active system-vm, run env-update && source /etc/profile and try to emerge soprano afterwards.
Comment 3 David Ripton 2009-02-02 15:55:51 UTC
Thanks Timo.  There WAS junk from old Java versions in my /etc/env.d.  But your suggestion didn't let soprano build.  So I suspect I have more Java cruft elsewhere.  Will keep hunting.
Comment 4 Maciej Mrozowski gentoo-dev 2009-06-04 16:27:34 UTC
Any progress on this? Is this still reproducible with latest soprano from portage?
Comment 5 David Ripton 2009-06-04 17:05:00 UTC
No change.  Still fails to emerge, unless I put the workaround I mentioned into /etc/portage/package.use
Comment 6 Tomáš Chvátal (RETIRED) gentoo-dev 2009-06-04 17:12:47 UTC
@Java:
You have any ideas how to solve the issue?
Comment 7 Serkan Kaba (RETIRED) gentoo-dev 2009-06-04 17:26:09 UTC
actually sesame should be unbundled, see bug #97892
Comment 8 Alistair Bush (RETIRED) gentoo-dev 2009-06-04 20:19:54 UTC
> -- Found Java JNI >= 1.4: /usr/include,
> /opt/sun-jdk-1.6.0.11/jre/lib/i386/client/libjvm.so

Can we find out why yours have /usr/include while mine has:-

-- Found Java JNI >= 1.4: /opt/sun-jdk-1.6.0.14/include, /opt/sun-jdk-1.6.0.14/jre/lib/amd64/server/libjvm.so

do you have gcj enabled?  is there some java related directory within /usr/include/?  ( something like /usr/include/jvm ).  whats the output of java-config-2 -L


Yes sesame should be unbundled. Should I hold my breathe?
Comment 9 David Ripton 2009-06-05 01:58:17 UTC
dripton@al ~ $ gcj
bash: gcj: command not found

dripton@al ~ $ ls /usr/include/java    
applet  awt  beans  io  lang  math  net  nio  rmi  security  sql  text  util
dripton@al ~ $ ls /usr/include/javax/
accessibility  naming  sql  swing  transaction

dripton@al ~ $ equery b /usr/include/java
 * Searching for /usr/include/java ... 
dripton@al ~ $ equery b /usr/include/javax
 * Searching for /usr/include/javax ... 

dripton@al ~ $ java-config-2 -L
The following VMs are available for generation-2:
1)	IcedTea6-bin 1.4.1 [icedtea6-bin]
2)	Sun JDK 1.5.0.18 [sun-jdk-1.5]
*)	Sun JDK 1.6.0.14 [sun-jdk-1.6]

Because no package owned /usr/include/java and /usr/include/javax, I removed them.  Unfortunately, it didn't help.  soprano still fails to emerge, unless I use the workaround in package.use
Comment 10 Andreas K. Hüttel gentoo-dev 2010-06-11 16:32:24 UTC
Not in tree anymore