Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 256876 - sys-libs/glibc-2.9_p20081201-r1 / amd64 multilib/ABI=x86 - checking size of long double... configure: error: cannot compute sizeof (long double)
Summary: sys-libs/glibc-2.9_p20081201-r1 / amd64 multilib/ABI=x86 - checking size of l...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
Depends on:
Reported: 2009-01-30 03:17 UTC by palxex
Modified: 2009-02-01 10:31 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,14.46 KB, text/plain)
2009-01-30 03:23 UTC, palxex
environment (environment,139.73 KB, text/plain)
2009-01-30 03:24 UTC, palxex
build.log with debug (build.log,543.92 KB, text/plain)
2009-01-30 03:27 UTC, palxex
config.log (config.log,41.64 KB, text/plain)
2009-01-30 03:28 UTC, palxex

Note You need to log in before you can comment on or make changes to this bug.
Description palxex 2009-01-30 03:17:03 UTC
This problem occurs when I changing gcc from 4.1.2 to 4.3.2(compiled), follows gentoo gcc upgrading manual, during "emerge -e system".
The same issue had occured to sandbox, though that can be workaround by remove /usr/bin/x86_64-pc-linux-gnu-gcc, but this trick does not works this time.And till now, even none of the previous reported scenario MATCHES mine. 
emerge --info:
Portage (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r1, 2.6.28-gentoo-r1 x86_64)
System uname: Linux-2.6.28-gentoo-r1-x86_64-Intel-R-_Celeron-R-_D_CPU_220_@_1.20GHz-with-glibc2.2.5
Timestamp of tree: Fri, 30 Jan 2009 01:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r13, 2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.2
sys-apps/sandbox:    1.3.3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-mtune=nocona -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-mtune=nocona -O2 -pipe -fomit-frame-pointer"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv"
LINGUAS="zh_CN en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage/layman/gentoo-china /usr/local/portage/layman/sunrise /usr/local/portage/layman/lxde /usr/local/portage/layman/berkano /home/palxex/build/myoverlay"
USE="X acl acpi alsa amd64 avahi berkdb bluetooth branding bzip2 cairo cdr cleartype cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo fam firefox gdbm gif gnome gpm gstreamer gtk hal iconv isdnlog jpeg ldap libnotify mad midi mikmod mmx mp3 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support quicktime readline reflection sdl session spell spl sse sse2 ssl startup-notification subversion svg sysfs tcpd tiff truetype unicode usb vorbis xcb xml xorg xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="zh_CN en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Comment 1 palxex 2009-01-30 03:23:29 UTC
Created attachment 180195 [details]

build.log without debug
Comment 2 palxex 2009-01-30 03:24:35 UTC
Created attachment 180197 [details]
Comment 3 palxex 2009-01-30 03:27:28 UTC
Created attachment 180198 [details]
build.log with debug
Comment 4 palxex 2009-01-30 03:28:44 UTC
Created attachment 180204 [details]
Comment 5 SpanKY gentoo-dev 2009-01-30 20:29:03 UTC
umm, i dont know what "trick" you're talking about, but you should never go removing random files in /usr/bin/.  if you do, your system is now broken and not supported and not our problem.

run `gcc-config -f 4.3.2` to make sure your system isnt screwed up before doing anything else.  then re-run the emerge and post the relevant build/config log files as attachments.

if it still fails, make sure your gcc is sane by doing:
$ echo 'int main() { puts("HI"); }' > test.c
$ gcc test.c
$ ./a.out
$ gcc -m32 test.c
$ ./a.out
Comment 6 palxex 2009-01-31 11:14:02 UTC
Thanks for your reply. I don't know why, but only when I do that, sandbox can be compiled. After sandbox has been merged, I've moved all those back.

>run `gcc-config -f 4.3.2`
Yes, I've tried this several times; I open this issue after that.

In the 'gcc -m32 test.c' failed; gcc reports 
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/../../../ when searching for -lc
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/../../../libc.a when searching for -lc
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/ when searching for -lc
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libc.a when searching for -lc
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lc
collect2: ld returned 1 exit status
I don't know why, I think I'd solved this problem by open kernel's IA32 emulation option when sandbox reports the same issue, but it occurs again.
Comment 7 SpanKY gentoo-dev 2009-01-31 15:11:11 UTC
looks like your multilib is broken.  verify you have proper /lib32/ and /usr/lib32/ dirs and have 32bit glibc libraries.  if you were using a no-multilib profile before, switching on the fly isnt supported.
Comment 8 palxex 2009-02-01 10:31:03 UTC
(In reply to comment #7)
> looks like your multilib is broken.  verify you have proper /lib32/ and
> /usr/lib32/ dirs and have 32bit glibc libraries.  if you were using a
> no-multilib profile before, switching on the fly isnt supported.

Thanks. I've verified this, they looks well, and I can run some 32bit program such as binkplayer. Only when I compiling gcc the problem occurs. I've decide to build whole system again.