Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 256660 - sys-libs/glibc-2.9_p20081201-r1 failed with gcc-4.3.3 due to fortify code
Summary: sys-libs/glibc-2.9_p20081201-r1 failed with gcc-4.3.3 due to fortify code
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
: 256605 256622 256647 (view as bug list)
Depends on:
Blocks: fortify-source
  Show dependency tree
 
Reported: 2009-01-28 18:06 UTC by Alexey Shvetsov
Modified: 2009-02-17 23:59 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/sys-libs/glibc-2.9_p20081201-r1/temp/environment (environment,142.02 KB, text/plain)
2009-01-28 18:07 UTC, Alexey Shvetsov
Details
build.log (build.log.gz,84.19 KB, application/octet-stream)
2009-01-28 18:18 UTC, Alexey Shvetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Shvetsov gentoo-dev 2009-01-28 18:06:25 UTC
Portage 2.2_rc23 (default/linux/amd64/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r1, 2.6.28-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E7200_@_2.53GHz-with-gentoo-2.0.0
Timestamp of tree: Wed, 28 Jan 2009 16:10:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.6.1
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.2
sys-apps/sandbox:    1.3.3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -pipe -march=native -mtune=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O3 -pipe -march=native -mtune=native"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages gpg parallel-fetch prelink preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
FFLAGS="-O3 -pipe -march=native -mtune=native"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1,--hash-style=gnu,--sort-common,--as-needed"
LINGUAS="ru en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/java-overlay /usr/local/portage/layman/kde-testing /usr/local/portage/layman/vmware /usr/local/portage/layman/mozilla /usr/local/portage/layman/science /usr/local/overlays/portage /usr/local/overlays/cross"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi addressbook akonadi alsa amd64 amr amrnb amrr amrwb analogtv avahi bash-completion berkdb bittorrent blas branding bzip2 cairo cdaudio cdinstall cdr cli consolekit context cracklib crypt cups cvs cyrillic daap dbus detex dga dhcp djvu dri dts dv dvb dvbplayer dvbsetup dvd dvdnav dvdr dvdread embedded emboss enca encode evo exif extra fam fbcondecor ffmpeg fftw flac fontconfig foomaticdb fortran ftp gdbm gif gimp git glitz gmp google-gadgets gpg gphoto2 gpm grace graphics graphviz gs gsl gstreamer gtk hal humanities iconv idn ieee1394 imagemagick inotify ipv6 isdnlog ithreads jadetex java javascript jpeg jpeg2k kde kdehiddenvisibility kipi kpathsea ladspa lapack latex lcms ldap libffi libnotify live lm_sensors lzo mad marble md5sum mdnsresponder-compat midi mikmod mktemp mmx mmxext mng mp2 mp3 mp4 mpeg mpi mpi-threads mplayer mudflap multilib music mysql ncurses nemesi nepomuk network-cron nls nptl nptlonly nsplugin ogg omega openal openexr opengl openmp pam pch pcntl pcre pdf perl phonon plasma png pnm ppds pppd ps pstricks publishers python qt3support qt4 quicktime rar readline reflection resolvconf rtc sandbox schroedinger science sdl semantic-desktop sensord session setup slang smp speex spell spl srt sse sse2 ssl ssse3 startup-notification subversion svg symlink sysfs tcpd tetex tex tex4ht themes theora threads tiff truetype umfpack unicode urandom usb utempter vde vhook vim vim-syntax visualization vorbis webdav webkit wmf x264 x86emu xattr xcb xcomposite xetex xml xorg xpm xscreensaver xulrunner xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alexey Shvetsov gentoo-dev 2009-01-28 18:07:43 UTC
Created attachment 179988 [details]
/var/tmp/portage/sys-libs/glibc-2.9_p20081201-r1/temp/environment

env
Comment 2 SpanKY gentoo-dev 2009-01-28 18:11:35 UTC
your report includes no real information, so i'm going to assume it's failing because i forgot to commit the fortify change to glibc

http://sources.gentoo.org/sys-libs/glibc/files/eblits/common.eblit?r1=1.8&r2=1.9
Comment 3 Alexey Shvetsov gentoo-dev 2009-01-28 18:18:55 UTC
Created attachment 179990 [details]
build.log

sorry its too big to attach it in plain text
Comment 4 Alexey Shvetsov gentoo-dev 2009-01-28 18:19:20 UTC
build log attached. reopening
Comment 5 SpanKY gentoo-dev 2009-01-29 20:30:21 UTC
*** Bug 256622 has been marked as a duplicate of this bug. ***
Comment 6 SpanKY gentoo-dev 2009-01-29 20:30:31 UTC
*** Bug 256605 has been marked as a duplicate of this bug. ***
Comment 7 Jeroen Roovers gentoo-dev 2009-01-30 00:26:05 UTC
*** Bug 256647 has been marked as a duplicate of this bug. ***