Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 256608 - sys-devel/gcc-4.3.2-r2 is missing gcc man page
Summary: sys-devel/gcc-4.3.2-r2 is missing gcc man page
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High minor with 1 vote (vote)
Assignee: Gentoo Toolchain Maintainers
URL: http://gcc.gnu.org/PR40010
Whiteboard:
Keywords: Inclusion
: 281464 289991 292219 293627 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-28 10:44 UTC by cazzantonio
Modified: 2010-10-17 09:08 UTC (History)
24 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (sys-devel:gcc-4.3.3:20090129-123632.log.lzma,150.69 KB, application/octet-stream)
2009-02-11 20:01 UTC, Alexis Ballier
Details
emerge --info (emerge_info.txt,4.25 KB, text/plain)
2009-04-14 04:29 UTC, Denilson Sá Maia
Details
build log (20090411-151305.log.lzma,224.67 KB, application/octet-stream)
2009-04-14 04:34 UTC, Denilson Sá Maia
Details
build log (single core) (20090414-004643.log.lzma,197.80 KB, application/octet-stream)
2009-04-14 06:46 UTC, Denilson Sá Maia
Details
[PATCH] gcc/Makefile.in (gcc.pod): Add dependency on gcc-vers.texi (fix-bug-256608.patch,379 bytes, patch)
2009-04-26 20:53 UTC, 6vvetjsrt26xsrzlh1z0zn4d2grdah
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description cazzantonio 2009-01-28 10:44:59 UTC
The latest version of ~ gcc is missing the gcc man page.
See here for details:
https://forums.gentoo.org/posting.php?mode=editpost&p=5422739

The missing man pages are gcc and g++ ones.

The files /usr/share/gcc-data/x86_64-pc-linux-gnu/4.3.2/man/man1/g++.1.bz and /usr/share/gcc-data/x86_64-pc-linux-gnu/4.3.2/man/man1/gcc.1.bz2 are present but contains only the basic structure of a man page and no text.

Reproducible: Always
Comment 1 SpanKY gentoo-dev 2009-01-29 20:40:12 UTC
you need to post all relevant information in the bug report ... linking to external places (like the forums) is not ok

attach full build logs and your emerge info
Comment 2 cazzantonio 2009-01-30 07:47:30 UTC
When I have time to rebuild it I'll post other info too.

Portage 2.1.6.4 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.7-r2, 2.6.28-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-glibc2.2.5
Timestamp of tree: Thu, 29 Jan 2009 08:45:01 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r7
sys-apps/baselayout: 2.0.0  
sys-apps/openrc:     0.4.2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -msse4.1 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -msse4.1 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources/ http://trumpetti.atm.tut.fi/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/"
LANG="it_IT.UTF-8"
LC_ALL="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="it"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/exclude_sync"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo caps cdr cli cracklib crypt cups dbus dga dri dv dvd dvdr dvdread eds emboss encode evo exif fam fbcon firefox flac fortran gdbm gif gnutls gpm gtk hal iconv idn ieee1394 imap ipv6 isdnlog jpeg kdeenablefinal kdehiddenvisibility latex lcms libnotify libsamplerate mad midi mikmod mmx mp3 mpeg mudflap multilib ncurses nls nntp nptl nptlonly offensive ogg opengl openmp pam pch pcre pdf perl png ppds pppd python quicktime readline reflection session smp speex spell spl sse sse2 ssl startup-notification svg sysfs tcpd tetex threads tiff truetype unicode usb vim-syntax vorbis wifi x264 xcomposite xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="intel vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 3 cazzantonio 2009-01-30 12:19:00 UTC
"man gcc" shows the following output:
GCC(1)                               GNU                               GCC(1)



gcc-4.3.2                         2009-01-26                           GCC(1) 

The file /usr/share/gcc-data/x86_64-pc-linux-gnu/4.3.2/man/man1/gcc.1.bz2 has the following content:
.\" Automatically generated by Pod::Man v1.37, Pod::Parser v1.35
.\"
.\" Standard preamble:
.\" ========================================================================
.de Sh \" Subsection heading
.br
.if t .Sp
.ne 5
.PP
\fB\\$1\fR
.PP
..
.de Sp \" Vertical space (when we can't use .PP)
.if t .sp .5v
.if n .sp
..
.de Vb \" Begin verbatim text
.ft CW
.nf
.ne \\$1
..
.de Ve \" End verbatim text
.ft R
.fi
..
.\" Set up some character translations and predefined strings.  \*(-- will
.\" give an unbreakable dash, \*(PI will give pi, \*(L" will give a left
.\" double quote, and \*(R" will give a right double quote.  | will give a
.\" real vertical bar.  \*(C+ will give a nicer C++.  Capital omega is used to
.\" do unbreakable dashes and therefore won't be available.  \*(C` and \*(C'
.\" expand to `' in nroff, nothing in troff, for use with C<>.
.tr \(*W-|\(bv\*(Tr
.ds C+ C\v'-.1v'\h'-1p'\s-2+\h'-1p'+\s0\v'.1v'\h'-1p'
.ie n \{\
.    ds -- \(*W-
.    ds PI pi
.    if (\n(.H=4u)&(1m=24u) .ds -- \(*W\h'-12u'\(*W\h'-12u'-\" diablo 10 pitch
.    if (\n(.H=4u)&(1m=20u) .ds -- \(*W\h'-12u'\(*W\h'-8u'-\"  diablo 12 pitch
.    ds L" ""
.    ds R" ""
.    ds C` ""
.    ds C' ""
'br\}
.el\{\
.    ds -- \|\(em\|
.    ds PI \(*p
.    ds L" ``
.    ds R" ''
'br\}
.\"
.\" If the F register is turned on, we'll generate index entries on stderr for
.\" titles (.TH), headers (.SH), subsections (.Sh), items (.Ip), and index
.\" entries marked with X<> in POD.  Of course, you'll have to process the
.\" output yourself in some meaningful fashion.
.if \nF \{\
.    de IX
.    tm Index:\\$1\t\\n%\t"\\$2"
..
.    nr % 0
.    rr F
.\}
.\"
.\" For nroff, turn off justification.  Always turn off hyphenation; it makes
.\" way too many mistakes in technical documents.
.hy 0
.if n .na
.\"
.\" Accent mark definitions (@(#)ms.acc 1.5 88/02/08 SMI; from UCB 4.2).
.\" Fear.  Run.  Save yourself.  No user-serviceable parts.
.    \" fudge factors for nroff and troff
.if n \{\
.    ds #H 0
.    ds #V .8m
.    ds #F .3m
.    ds #[ \f1
.    ds #] \fP
.\}
.if t \{\
.    ds #H ((1u-(\\\\n(.fu%2u))*.13m)
.    ds #V .6m
.    ds #F 0
.    ds #[ \&
.    ds #] \&
.\}
.    \" simple accents for nroff and troff
.if n \{\
.    ds ' \&
.    ds ` \&
.    ds ^ \&
.    ds , \&
.    ds ~ ~
.    ds /
.\}
.if t \{\
.    ds ' \\k:\h'-(\\n(.wu*8/10-\*(#H)'\'\h"|\\n:u"
.    ds ` \\k:\h'-(\\n(.wu*8/10-\*(#H)'\`\h'|\\n:u'
.    ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'^\h'|\\n:u'
.    ds , \\k:\h'-(\\n(.wu*8/10)',\h'|\\n:u'
.    ds ~ \\k:\h'-(\\n(.wu-\*(#H-.1m)'~\h'|\\n:u'
.    ds / \\k:\h'-(\\n(.wu*8/10-\*(#H)'\z\(sl\h'|\\n:u'
.\}
.    \" troff and (daisy-wheel) nroff accents
.ds : \\k:\h'-(\\n(.wu*8/10-\*(#H+.1m+\*(#F)'\v'-\*(#V'\z.\h'.2m+\*(#F'.\h'|\\n:u'\v'\*(#V'
.ds 8 \h'\*(#H'\(*b\h'-\*(#H'
.ds o \\k:\h'-(\\n(.wu+\w'\(de'u-\*(#H)/2u'\v'-.3n'\*(#[\z\(de\v'.3n'\h'|\\n:u'\*(#]
.ds d- \h'\*(#H'\(pd\h'-\w'~'u'\v'-.25m'\f2\(hy\fP\v'.25m'\h'-\*(#H'
.ds D- D\\k:\h'-\w'D'u'\v'-.11m'\z\(hy\v'.11m'\h'|\\n:u'
.ds th \*(#[\v'.3m'\s+1I\s-1\v'-.3m'\h'-(\w'I'u*2/3)'\s-1o\s+1\*(#]
.ds Th \*(#[\s+2I\s-2\h'-\w'I'u*3/5'\v'-.3m'o\v'.3m'\*(#]
.ds ae a\h'-(\w'a'u*4/10)'e
.ds Ae A\h'-(\w'A'u*4/10)'E
.    \" corrections for vroff
.if v .ds ~ \\k:\h'-(\\n(.wu*9/10-\*(#H)'\s-2\u~\d\s+2\h'|\\n:u'
.if v .ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'\v'-.4m'^\v'.4m'\h'|\\n:u'
.    \" for low resolution devices (crt and lpr)
.if \n(.H>23 .if \n(.V>19 \
\{\
.    ds : e
.    ds 8 ss
.    ds o a
.    ds d- d\h'-1'\(ga
.    ds D- D\h'-1'\(hy
.    ds th \o'bp'
.    ds Th \o'LP'
.    ds ae ae
.    ds Ae AE
.\}
.rm #[ #] #H #V #F C
.\" ========================================================================
.\"
.IX Title "GCC 1"
.TH GCC 1 "2009-01-26" "gcc-4.3.2" "GNU"

Do you need other infos?
Comment 4 cazzantonio 2009-01-31 17:43:48 UTC
Adding USE="doc" to gcc seems to solve the problem. Previous gcc versions installed the manpage even without that use flag, is it stil a bug or a choice of upstream developers or gentoo mantainers?
Comment 5 Alexis Ballier gentoo-dev 2009-02-11 20:01:03 UTC
Created attachment 181697 [details]
build log

same here; attaching lzma compressed build log as it's too big otherwise

and i have use doc enabled:
[ebuild   R   ] sys-devel/gcc-4.3.3  USE="doc fortran gtk mudflap (multilib) nls openmp test (-altivec) -bootstrap -build (-fixed-point) -gcj (-hardened) -ip28 -ip32r10k -libffi -multislot (-n32) (-n64) -nocxx -nopie -objc -objc++ -objc-gc -vanilla" 0 kB
Comment 6 SpanKY gentoo-dev 2009-02-22 02:17:11 UTC
i dont think it's a USE=doc issue.  looks more like parallel build issue with the pod files.
Comment 7 Constantin Baranov 2009-03-22 22:43:25 UTC
The same with gcc-4.3.3-r1 no matter whether USE=doc is enabled or not.
MAKEOPTS="-j2"
Comment 8 Nikolay S. Rybaloff 2009-03-30 09:24:06 UTC
The problem is pod2man.pl does not generate pod file from texinfo source:

/var/tmp/portage/sys-devel/gcc-4.3.3-r2/work/gcc-4.3.3/contrib/texi2pod.pl /var/tmp/portage/sys-devel/gcc-4.3.3-r2/work/gcc-4.3.3/gcc/doc/invoke.texi 
cannot find gcc-vers.texi at /var/tmp/portage/sys-devel/gcc-4.3.3-r2/work/gcc-4.3.3/contrib/texi2pod.pl line 251, <GEN0> line 9.
Comment 9 Nikolay S. Rybaloff 2009-03-30 09:29:48 UTC
(In reply to comment #8)
> The problem is pod2man.pl does not generate pod file from texinfo source:
> 
> /var/tmp/portage/sys-devel/gcc-4.3.3-r2/work/gcc-4.3.3/contrib/texi2pod.pl
> /var/tmp/portage/sys-devel/gcc-4.3.3-r2/work/gcc-4.3.3/gcc/doc/invoke.texi 
> cannot find gcc-vers.texi at
> /var/tmp/portage/sys-devel/gcc-4.3.3-r2/work/gcc-4.3.3/contrib/texi2pod.pl line
> 251, <GEN0> line 9.
> 

Ah, my bad... That's not the case
Comment 10 Denilson Sá Maia 2009-04-14 04:29:51 UTC
Created attachment 188284 [details]
emerge --info

I'm also experiencing this bug with gcc-4.3.2-r3 (which is now stable), exactly the same way as described by Cazzantonio (alpiturchi).

My system is stable amd64, on core2duo, with MAKEOPTS="-j2" and doc useflag disabled.

I haven't tried to re-emerge gcc.
Comment 11 Denilson Sá Maia 2009-04-14 04:34:47 UTC
Created attachment 188286 [details]
build log

Just in case it might be helpful, I'm attaching my build log.
Comment 12 Denilson Sá Maia 2009-04-14 06:46:12 UTC
Created attachment 188288 [details]
build log (single core)

I've emerged gcc-4.3.2-r3 on a single-core amd64 machine. The gentoo on that machine is almost equal to the one on the machine that triggers this bug. The only difference is the single-core processor, and, thus, the lack of MAKEOPTS="-j2".

I'm attaching the build log.
Comment 13 Dennis Schridde 2009-04-21 16:43:51 UTC
Same here with sys-devel/gcc-4.3.3-r2. The issue was gone a month or two ago, so I thought it was fixed, but has returned now. (I cannot tell exact dates, as I do not regularly use the gcc manpage.)
Comment 14 Dennis Schridde 2009-04-21 16:47:13 UTC
INFO of a machine where the issue occurs:

Portage 2.2_rc30 (default/linux/amd64/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.29-gentoo-r1 x86_64)
=================================================================                                                
System uname: Linux-2.6.29-gentoo-r1-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5000+-with-gentoo-2.0.0     
Timestamp of tree: Sun, 19 Apr 2009 09:45:02 +0000                                                               
app-shells/bash:     4.0_p17-r1                                                                                  
dev-java/java-config: 2.1.7                                                                                      
dev-lang/python:     2.6.2                                                                                       
dev-python/pycrypto: 2.0.1-r8                                                                                    
dev-util/cmake:      2.6.3-r1                                                                                    
sys-apps/baselayout: 2.0.0                                                                                       
sys-apps/openrc:     0.4.3-r2                                                                                    
sys-apps/sandbox:    1.9                                                                                         
sys-devel/autoconf:  2.13, 2.63-r1                                                                               
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2                                                             
sys-devel/binutils:  2.19.1-r1                                                                                   
sys-devel/gcc-config: 1.4.1                                                                                      
sys-devel/libtool:   2.2.6a                                                                                      
virtual/os-headers:  2.6.28-r1                                                                                   
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                                   
CBUILD="x86_64-pc-linux-gnu"                                                                                     
CFLAGS="-pipe -O2 -march=athlon64-sse3 -fstack-protector -ftree-vectorize"                                       
CHOST="x86_64-pc-linux-gnu"                                                                                      
CONFIG_PROTECT="/etc /usr/inferno/keydb /usr/inferno/lib /usr/inferno/services /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-pipe -O2 -march=athlon64-sse3 -fstack-protector -ftree-vectorize"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox usersync"
GENTOO_MIRRORS="ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/var/cache/portage/packages"
PORTAGE_COMPRESS="lzma"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/gentoo"
PORTDIR_OVERLAY="/var/cache/portage/layman/pcsx2 /var/cache/portage/layman/x11 /var/cache/portage/layman/kde-testing /var/cache/portage/layman/oss-overlay /var/cache/portage/layman/dev-zero /var/cache/portage/layman/sunrise /var/cache/portage/layman/java-overlay /var/cache/portage/local"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 apache2 bash-completion berkdb bluetooth branding bzip2 cairo caps cdr cjk cli cracklib crypt cups dbus dri dvb dvd dvdr dvdread eds emboss encode evo fam ffmpeg firefox flac fortran gdbm gif gimp gpm gtk hal iconv ipv6 isdnlog jpeg jpeg2k kde kdehiddenvisibility latex ldap libnotify mad midi mikmod mmx mp3 mp4 mpeg mplayer mudflap multilib mysql ncurses nls nptl nptlonly ogg openal openexr opengl openmp oss pam pch pcre pdf perl php png ppds pppd python qt3 qt3support qt4 quicktime readline reflection ruby samba sasl sdl session speex spell spl sse sse2 ssl startup-notification subversion svg sysfs tcpd theora threads tiff truetype unicode usb vorbis xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" ELIBC="glibc" INPUT_DEVICES="evdev joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" LIRC_DEVICES="devinput" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



INFO of a machine where the issue does NOT occur:

Portage 2.2_rc28 (hardened/linux/ia64/2008.0/server, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.28-hardened-r7 ia64)
=================================================================                                               
System uname: Linux-2.6.28-hardened-r7-ia64-31-with-gentoo-2.0.0                                                
Timestamp of tree: Sun, 19 Apr 2009 09:45:02 +0000                                                              
app-shells/bash:     3.2_p39                                                                                    
dev-lang/python:     2.5.2-r7, 2.6.2                                                                            
dev-python/pycrypto: 2.0.1-r8                                                                                   
dev-util/cmake:      2.6.2-r1                                                                                   
sys-apps/baselayout: 2.0.0                                                                                      
sys-apps/openrc:     0.4.3-r2                                                                                   
sys-apps/sandbox:    1.2.18.1-r2                                                                                
sys-devel/autoconf:  2.63                                                                                       
sys-devel/automake:  1.7.9-r1, 1.10.2                                                                           
sys-devel/binutils:  2.19.1-r1                                                                                  
sys-devel/gcc-config: 1.4.0-r4                                                                                  
sys-devel/libtool:   1.5.26                                                                                     
virtual/os-headers:  2.6.27-r2                                                                                  
ACCEPT_KEYWORDS="ia64"                                                                                          
CBUILD="ia64-unknown-linux-gnu"                                                                                 
CFLAGS="-pipe -mtune=mckinley -O2 -ftree-vectorize"                                                             
CHOST="ia64-unknown-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-pipe -mtune=mckinley -O2 -ftree-vectorize"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox usersync"
GENTOO_MIRRORS="http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/var/cache/portage/packages"
PORTAGE_COMPRESS="lzma"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--include='/x11-libs/' --include='/x11-libs/qt*/' --exclude='/x11-libs/*/' --exclude='/games*/' --exclude='/gnome*/' --exclude='/gnustep*/' --exclude='/gpe*/' --exclude='/kde*/' --exclude='/rox*/' --exclude='/sci*/' --exclude='/x11*/' --exclude='/xfce*/'"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/gentoo"
PORTDIR_OVERLAY="/var/cache/portage/local"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl apache2 berkdb bzip2 caps cli cracklib crypt cups dri gdbm gpm ia64 iconv ipv6 isdnlog ldap mailwrapper midi mudflap mysql ncurses nptl nptlonly pam pcre perl pic pppd python readline reflection sessionsnmp spl ssl sysfs tcpd truetype unicode urandom vhosts xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_iduserdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint mach64 mga nv r128 radeon savage tdfx vesa vga voodoo"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS_FLAGS
Comment 15 6vvetjsrt26xsrzlh1z0zn4d2grdah 2009-04-26 20:53:15 UTC
Created attachment 189560 [details, diff]
[PATCH] gcc/Makefile.in (gcc.pod): Add dependency on gcc-vers.texi

(In reply to comment #8)
>
> /var/tmp/portage/sys-devel/gcc-4.3.3-r2/work/gcc-4.3.3/contrib/texi2pod.pl
> /var/tmp/portage/sys-devel/gcc-4.3.3-r2/work/gcc-4.3.3/gcc/doc/invoke.texi 
> cannot find gcc-vers.texi at
> /var/tmp/portage/sys-devel/gcc-4.3.3-r2/work/gcc-4.3.3/contrib/texi2pod.pl line
> 251, <GEN0> line 9.
> 

The problem here is that "-$(TEXI2POD) $< > $@" generates an empty file if the .texi source doesn't exist yet.
Comment 16 Mark Loeser (RETIRED) gentoo-dev 2009-05-03 17:44:26 UTC
Reported upstream.  I'll add it to our patchsets as well (after I'm sure they'll accept it and we don't have to work around it in another way)
Comment 17 Alexey Shvetsov gentoo-dev 2009-05-08 10:33:33 UTC
still valid for gcc-4.4.0
Comment 18 Samuli Suominen gentoo-dev 2009-08-14 12:46:33 UTC
*** Bug 281464 has been marked as a duplicate of this bug. ***
Comment 19 Peter Fox 2009-10-04 20:47:46 UTC
I can confirm comment #6:
I had this problem building gcc-4.3.4 on a dual-core machine with -j3.
It built fine with -j2 (which was also fine on all my single core machines).
Comment 20 Henning Schild 2009-10-20 07:58:54 UTC
How come such a bug is known for so long and still hits users of a stable compiler? Even a fix seems to be available but was not applied, why did the recent gcc become stable than?
If you are a programmer the manual is a pretty important part of the compiler. Imho rating the severity as "minor" is simply wrong. If you dont want to patch enforce -j1 or whatever. But please dont let such things get into the stable branch.
Comment 21 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-21 13:43:37 UTC
*** Bug 289991 has been marked as a duplicate of this bug. ***
Comment 22 Peter Alfredsen (RETIRED) gentoo-dev 2009-10-27 15:14:54 UTC
Fixed upstream.
Comment 23 Mark Loeser (RETIRED) gentoo-dev 2009-10-31 17:46:38 UTC
This is fixed in ~arch and the next candidate for stable will be one of the versions that has this fixed.
Comment 24 Patrick Lauer gentoo-dev 2009-11-07 20:57:39 UTC
*** Bug 292219 has been marked as a duplicate of this bug. ***
Comment 25 Kai Krakow 2009-11-19 20:35:34 UTC
*** Bug 293627 has been marked as a duplicate of this bug. ***
Comment 26 pavel sanda 2010-05-01 23:47:57 UTC
still there
Comment 27 Bart Kus 2010-09-21 20:20:54 UTC
I'm seeing the bug with latest stable gcc still.  Had to edit make.conf, set -j1, and remerge.  Have the man pages now.  Can the fix be expedited to stable?


Portage 2.1.8.3 (default/linux/amd64/10.0, gcc-4.4.3, glibc-2.11.2-r0, 2.6.34-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.34-gentoo-r1-x86_64-Intel-R-_Core-TM-2_Quad_CPU_@_2.40GHz-with-gentoo-1.12.13
Timestamp of tree: Sun, 19 Sep 2010 02:45:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.mirrors.tera-byte.com/ http://gentoo.arcticnetwork.ca/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X X509 acl acpi aliaschain amd64 apache2 async automount bash-completion berkdb bgpclassless bindist bzip2 cairo cgi clamav cli cnamefix cpudetection crypt cups curl cxx daemon dbus diskio djvu dri elf event-callback examples exif extras fat ffmpeg fix-connected-rt fortran gcj gd gdbm git gnutls gpm gtk hpn iconv imap inotify iproute2 ipv6 javascript jpeg jpeg2k kde kerberos libextractor lm_sensors loop-aes milter mmap mmx mng modules mp3 mudflap multidata multilib multipath multipleip mysql ncurses network nfs nfsv3 nfsv4 nls nptl nptlonly offensive opencore-amr opengl openmp pam parcheck pcre perl pkcs11 png pop pop3d pppd profile python qt3support qt4 raw readline realms reflection roundrobin rtc samba semanticfix sensord server session sieve smtp snmp sockets sql sse sse2 ssl svg sysfs syslog taglib tcpd threads tiff tokenizer truetype unicode user-homedirs vim-syntax vorbis webinterface webkit x264 xml xmlrpc xorg xulrunner xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 28 Kai Krakow 2010-09-21 20:45:51 UTC
If this is a parallel build bug, actually the make.conf should be fixed.
Comment 29 Dennis Schridde 2010-09-21 22:02:08 UTC
(In reply to comment #27)
> I'm seeing the bug with latest stable gcc still.  Had to edit make.conf, set
> -j1, and remerge.
You can use this:
MAKEOPTS=-j1 emerge <foo>
Comment 30 Bart Kus 2010-09-21 23:55:28 UTC
(In reply to comment #29)
> (In reply to comment #27)
> > I'm seeing the bug with latest stable gcc still.  Had to edit make.conf, set
> > -j1, and remerge.
> You can use this:
> MAKEOPTS=-j1 emerge <foo>

Good to know, but that can't be the real fix for this.  Folks expect to set -j5 globally and have emerge -e world succeed when running stable.  What's holding up the release?  Isn't it possible to force -j1 in the ebuild itself at least, if there is no upstream concurrent makefile?
Comment 31 Jaak Ristioja 2010-09-22 05:21:59 UTC
MAKEOPTS="-j1" is most probably not a good solution, especially because compiling gcc with MAKEOPTS="-j1" will take like... forever.
Comment 32 Dennis Schridde 2010-09-22 07:04:51 UTC
(In reply to comment #30)
> (In reply to comment #29)
> > (In reply to comment #27)
> > > I'm seeing the bug with latest stable gcc still.  Had to edit make.conf, set
> > > -j1, and remerge.
> > You can use this:
> > MAKEOPTS=-j1 emerge <foo>
> 
> Good to know, but that can't be the real fix for this.
Of course, I just wanted to save you the work of editing make.conf everytime you find such a problem.

> What's holding
> up the release?  Isn't it possible to force -j1 in the ebuild itself at least,
> if there is no upstream concurrent makefile?
I assume Toolchain tries to fix the buildsystem, in cooperation with upstream, which might be a bit tricky, because GCC is a complex piece of software, as is its buildsystem.
Comment 33 Faustus 2010-10-15 07:29:58 UTC
Bug still there in 4.3.4, which is the latest visible on hardened profile.
Comment 34 Ryan Hill (RETIRED) gentoo-dev 2010-10-16 07:42:23 UTC
Added to the 4.3.4 and 4.3.5 patchsets.  It'll get pushed out next time we do an update.  This is already fixed for current stable 4.4 and up.
Comment 35 Ryan Hill (RETIRED) gentoo-dev 2010-10-17 09:08:08 UTC
Released.