Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 256557 - upgrading to gnome-light-2.24 fails at gnome-settings-daemon-2.24.1.r1
Summary: upgrading to gnome-light-2.24 fails at gnome-settings-daemon-2.24.1.r1
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 258514 (view as bug list)
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2009-01-27 20:40 UTC by Grigorij Ivanow
Modified: 2009-10-21 23:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
complete build.log (build.log,235.92 KB, text/plain)
2009-01-27 20:41 UTC, Grigorij Ivanow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Grigorij Ivanow 2009-01-27 20:40:30 UTC
I've installed fresh gentoo 2007.0 without X. Emerged then gnome-light-2.22.2.1 (resolving few problems with python etc), installed Portato, and using Portato unmasked gnome-light-2.24.1-r1. 
Confilcts arised (gail and gnome-python) but with few unmasks and separate emerges, they have been solved.

Now, when only 7 ebuild left, emerge throws error durring compilation of gnome-settings-daemon-2.24.1-r1

Reproducible: Always

Steps to Reproduce:
1.emerge -av =gnome-base/gnome-settings-daemon-2.24.1-r1 [no USE flags set]

Actual Results:  
compilation crashes at compiling mouse module (propaby, if I understood error messages correctly)

Expected Results:  
gnome-settings-daemon upgrades to 2.24.1-r1 succesfully

localhost ivan # emerge --info
Portage 2.2_rc23 (default/linux/x86/2008.0, gcc-4.1.1, glibc-2.5-r0, 2.6.24-tuxonice-r9 i686)
=================================================================
System uname: Linux-2.6.24-tuxonice-r9-i686-Genuine_Intel-R-_CPU___________T2080__@_1.73GHz-with-glibc2.0
Timestamp of tree: Tue, 27 Jan 2009 17:00:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.4.3-r4, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=i686 -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=i686 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.heanet.ie/pub/gentoo/"
LANG="C"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi berkdb bzip2 cli cracklib crypt cups dri fortran gdbm gnome gnome-keyring gpm hal iconv ipv6 isdnlog jpeg laptop midi mmx mudflap ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection session spl sse sse2 sse3 ssl sysfs tcpd unicode vim-syntax x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev intel i740 i128 vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Grigorij Ivanow 2009-01-27 20:41:36 UTC
Created attachment 179905 [details]
complete build.log
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-01-29 21:30:11 UTC
do you have esound installed ? if not, could you install it and try again to see if it fixes your issue ?
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-02-02 22:46:52 UTC
please get back to us.
Comment 4 Grigorij Ivanow 2009-02-03 08:34:43 UTC
I havent esound installed, but now I don't have any longer access to machine where it occured, so I cannont reproduce this error myself. Dead end ;)
Comment 5 Gilles Dartiguelongue gentoo-dev 2009-02-11 10:18:34 UTC
*** Bug 258514 has been marked as a duplicate of this bug. ***
Comment 6 Justin 2009-02-11 15:15:17 UTC
(In reply to comment #3)
> please get back to us.
> 

I am experiencing this same issue (on amd64). Esound was installed on my system. Latest version (0.2.41) emerged this morning. Same results. 
Comment 7 Justin 2009-02-11 15:46:25 UTC
(In reply to comment #3)
> please get back to us.
> 

I am experiencing this same issue (on amd64). Esound was installed on my system. Latest version (0.2.41) emerged this morning. Same results. 
Comment 8 Gilles Dartiguelongue gentoo-dev 2009-02-23 21:12:32 UTC
hum what versions of bonobo do you guys have (probably unrelated but who knows).
Comment 9 Justin 2009-02-24 18:14:00 UTC
(In reply to comment #8)
> hum what versions of bonobo do you guys have (probably unrelated but who
> knows).

libbonobo-python = 2.22.3
libbonobo = 2.24.0
Comment 10 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-02-26 19:24:18 UTC
DeviceEnabled is defined in /usr/include/X11/extensions/XI.h

Do you have it defined in that file?  Which version of inputproto do you have?
Comment 11 Justin 2009-03-02 23:15:34 UTC
(In reply to comment #10)
> DeviceEnabled is defined in /usr/include/X11/extensions/XI.h
> Do you have it defined in that file?  Which version of inputproto do you have?

x11-proto/inputproto = 1.4 (looks like 1.5 is latest for my arch, so I will update)
I do not have Device Enabled defined in that file
Comment 12 Justin 2009-03-02 23:38:40 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > DeviceEnabled is defined in /usr/include/X11/extensions/XI.h
> > Do you have it defined in that file?  Which version of inputproto do you have?
> x11-proto/inputproto = 1.4 (looks like 1.5 is latest for my arch, so I will
> update)
> I do not have Device Enabled defined in that file


After updating to the latest inputproto, the DeviceEnabled line in /usr/include/X11/XI.h was restored and I was able to emerge gnome-settings-daemon/ 
Comment 13 Gilles Dartiguelongue gentoo-dev 2009-03-04 21:55:33 UTC
could you retry the version you had previously installed ? I've gone through 1.4.2, 1.4.3 and 1.4.4 and this is defined in all of them.
Comment 14 Gilles Dartiguelongue gentoo-dev 2009-03-09 21:30:02 UTC
Please get back to us.
Comment 15 Justin 2009-03-12 19:32:29 UTC
(In reply to comment #14)
> Please get back

I cannot revert the machine at this time. 
Comment 16 Gilles Dartiguelongue gentoo-dev 2009-03-15 01:11:00 UTC
ok
Comment 17 Gilles Dartiguelongue gentoo-dev 2009-03-15 01:11:25 UTC
closing worksforme then. Thanks for getting back to us.
Comment 18 Bill Skellenger 2009-07-21 01:14:08 UTC
(In reply to comment #13)
> could you retry the version you had previously installed ? I've gone through
> 1.4.2, 1.4.3 and 1.4.4 and this is defined in all of them.
> 

I am running into this problem (arrived here from bug 258514) too.  I have inputproto-1.3.2 installed right now (which causes the same build errors) and I'm about to emerge inputproto-1.5.0 to hopefully get around this.

Looks like the deps for gnome-settings-daemon-2.24.1-r1 do not list a specific inputproto level:

DEPEND="${RDEPEND}
	!<gnome-base/gnome-control-center-2.22
	sys-devel/gettext
	>=dev-util/intltool-0.40
	>=dev-util/pkgconfig-0.19
	x11-proto/inputproto
	x11-proto/xproto"