Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 256345 - gnome-extra/gnome-utils-2.24.1: baobab crashes at startup without error messages
Summary: gnome-extra/gnome-utils-2.24.1: baobab crashes at startup without error messages
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2009-01-25 19:57 UTC by Luca Wehrstedt
Modified: 2009-10-21 23:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luca Wehrstedt 2009-01-25 19:57:59 UTC
When I try to start baobab (the GNOME disk usage analyzer, which is part of the gnome-utils package) I get no errors, but the program doesn't start.
I sometimes see for a moment a window, but it shortly disappears.

I've built gnome-utils with the hal USE flag only, and I'm using a ~amd64 system.

Reproducible: Always

Steps to Reproduce:
1. emerge gnome-utils
2. baobab
3.

Actual Results:  
luka@luka-desktop ~ $ baobab
luka@luka-desktop ~ $ 


Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r1, 2.6.28-gentoo-r1-luka2 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r1-luka2-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9450_@_2.66GHz-with-glibc2.2.5
Timestamp of tree: Sun, 25 Jan 2009 12:15:02 +0000
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r13, 2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.2
sys-apps/sandbox:    1.3.2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS=" ftp://ftp.unina.it/pub/linux/distributions/gentoo http://distfiles.gentoo.org/"
LANG="it_IT.UTF-8"
LC_ALL="it_IT.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="it"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync12.de.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa amd64 apache2 apm avahi bash-completion bzip2 cdr cli cracklib crypt css cups cvs cxx dbus dnd dri dvd dvdr encode examples exif ffmpeg firefox fortran ftp gcj gdbm geoip gif gimp gnome gnome-keyring gpm graphviz gstreamer gtk hal iconv id3tag ieee1394 imagemagick imap ipod isdnlog jabber jack java javascript jingle jpeg jpeg2k kvm lame libnotify libwww lm_sensors mad midi mime mmx mozilla mp3 mpeg msn mtp mudflap multilib mysql mysqli nautilus ncurses nforce2 nls nptl nptlonly nvidia ogg opengl openmp pam pango pcre pdf perl php pmu png posix pppd python qt4 readline reflection rss session simplexml spell spl sqlite sqlite3 sse sse2 sse3 sse4_1 ssl subversion svg sysfs tagwriting tcpd theora threads truetype unicode usb v4l v4l2 vcd vnc vorbis webkit wxwindows x264 xcomposite xinerama xml xorg xulrunner xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="nv nvidia v4l"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-01-25 20:05:33 UTC
could you try to provide a backtrace [1] of the problem ?

[1] http://www.gentoo.org/proj/en/qa/backtraces.xml
Comment 2 Luca Wehrstedt 2009-01-25 20:39:53 UTC
I've never done backtraces, but following the Italian version of the guide I think I've got something useful.

The debug is full of (no debugging symbols found), with the exception of:

- [Thread debugging using libthread_db enabled]
- [New Thread 0x7fa5584f1780 (LWP 13823)]
- Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fa5584f1780 (LWP 13823)]
0x00007fa553611beb in g_utf8_validate () from /usr/lib/libglib-2.0.so.0

I think the last is the problem, but I have no idea what it's related to
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-01-27 17:08:53 UTC
this is a far from complete backtrace. You need to rebuild more packages with debugging symbols.
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-02-22 18:13:34 UTC
Waiting for a good backtrace. Also, could you try to start it with another locale ?
Comment 5 lper.home 2009-03-28 07:14:55 UTC
(In reply to comment #4)
> Waiting for a good backtrace. Also, could you try to start it with another
> locale ?

I had the same problem. solution is simple, use the gconf-editor to reset the apps/baobab/properties/skip_scan_uri_list.
The problem occurs if you want to scan some disk but not the root mounted partition.
This set this property to file:/// which causes the crash (at the moment you start scanning or on next startup).

Very easy to reproduce by just setting the property....

Comment 6 Gilles Dartiguelongue gentoo-dev 2009-03-28 10:59:55 UTC
ok, reproduced and bug-buddy gave me a nice trace so I reported that upstream. Thanks for the instructions to help reproduce this issue.
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-10-21 23:51:36 UTC
closing fixed since this is most likely in 2.26 that is now stable. Thanks for reporting.