Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 255888 - media-video/kavi2svcd: automake called by maintainer-mode
Summary: media-video/kavi2svcd: automake called by maintainer-mode
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Alexander Mieland
URL: http://blog.flameeyes.eu/2008/06/13/m...
Whiteboard:
Keywords:
Depends on:
Blocks: bad-autotools
  Show dependency tree
 
Reported: 2009-01-22 00:51 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-12-23 20:53 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (kavi2svcd-0.8.7:20081121-044614.log,95.63 KB, text/plain)
2009-01-22 00:51 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-22 00:51:33 UTC
Hello,

You're receiving this canned (template-based) bug report because I found a problem with a package during my tinderbox run.

The package in question is running automake (and most likely other autotools) during compile phase by maintainer-mode. You can see in my blog post in the URL field why that's a problem, and how to address the issue, but in general, you don't want maintainer-mode rebuild during compile phase, especially since it can cause multiple run of econf.

The causes of maintainer-mode rebuild are various, but most likely it's because of a patch that changes Makefile.am or configure.ac/in and don't rebuild autotools properly. The way to fix this is almost always to inherit autotools eclass and run eautomake/eautoreconf (as needed; eautoconf should only be used when automake is not involved, which is not the case here) during src_unpack phase.

Thanks,
Diego
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-22 00:51:54 UTC
Created attachment 179260 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-12-23 20:53:51 UTC
Removed from tree.