Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 255882 - media-sound/soundkonverter: automake called by maintainer-mode
Summary: media-sound/soundkonverter: automake called by maintainer-mode
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Gentoo Sound Team
URL: http://blog.flameeyes.eu/2008/06/13/m...
Whiteboard:
Keywords:
Depends on:
Blocks: bad-autotools
  Show dependency tree
 
Reported: 2009-01-22 00:45 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-05-14 04:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (soundkonverter-0.3.8:20081121-013722.log,181.19 KB, text/plain)
2009-01-22 00:45 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-22 00:45:30 UTC
Hello,

You're receiving this canned (template-based) bug report because I found a problem with a package during my tinderbox run.

The package in question is running automake (and most likely other autotools) during compile phase by maintainer-mode. You can see in my blog post in the URL field why that's a problem, and how to address the issue, but in general, you don't want maintainer-mode rebuild during compile phase, especially since it can cause multiple run of econf.

The causes of maintainer-mode rebuild are various, but most likely it's because of a patch that changes Makefile.am or configure.ac/in and don't rebuild autotools properly. The way to fix this is almost always to inherit autotools eclass and run eautomake/eautoreconf (as needed; eautoconf should only be used when automake is not involved, which is not the case here) during src_unpack phase.

Thanks,
Diego
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-22 00:45:44 UTC
Created attachment 179258 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-05-13 18:46:41 UTC
Unfortunately it's not entirely maintainer-mode, but the Makefile's call a cvs.sh and others in admin/ directory this package ships, as do many others KDE 3.x pkgs. Just adding eautoreconf won't make this problem go away, the build system would require some rewriting.. :-(
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-05-13 18:54:39 UTC
If it's using the kde3 build cr^Wsystem you should just remove the configure file and let kde.eclass handle it.
Comment 4 Samuli Suominen gentoo-dev 2009-05-14 04:59:19 UTC
(In reply to comment #3)
> If it's using the kde3 build cr^Wsystem you should just remove the configure
> file and let kde.eclass handle it.
> 

Thanks, that helped. :-) Still ugly, but doesn't rerun the stuff anymore.