Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 255864 - kde-misc/knetworkmanager: automake called by maintainer-mode
Summary: kde-misc/knetworkmanager: automake called by maintainer-mode
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Robert Buchholz (RETIRED)
URL: http://blog.flameeyes.eu/2008/06/13/m...
Whiteboard:
Keywords:
Depends on: 253788
Blocks: bad-autotools
  Show dependency tree
 
Reported: 2009-01-22 00:35 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-11-12 13:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (knetworkmanager-0.2.2_p20080528:20081120-004006.log,159.56 KB, text/plain)
2009-01-22 00:35 UTC, Diego Elio Pettenò (RETIRED)
Details
knetworkmanager-0.2.2_p20080528.ebuild update to fix the issue reported by Diego (knetworkmanager-0.2.2_p20080528.ebuild.patch,1003 bytes, patch)
2009-01-31 21:00 UTC, Jorge Manuel B. S. Vicetto
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-22 00:35:00 UTC
Hello,

You're receiving this canned (template-based) bug report because I found a problem with a package during my tinderbox run.

The package in question is running automake (and most likely other autotools) during compile phase by maintainer-mode. You can see in my blog post in the URL field why that's a problem, and how to address the issue, but in general, you don't want maintainer-mode rebuild during compile phase, especially since it can cause multiple run of econf.

The causes of maintainer-mode rebuild are various, but most likely it's because of a patch that changes Makefile.am or configure.ac/in and don't rebuild autotools properly. The way to fix this is almost always to inherit autotools eclass and run eautomake/eautoreconf (as needed; eautoconf should only be used when automake is not involved, which is not the case here) during src_unpack phase.

Thanks,
Diego
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-22 00:35:17 UTC
Created attachment 179248 [details]
Build log
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-01-31 21:00:28 UTC
Created attachment 180470 [details, diff]
knetworkmanager-0.2.2_p20080528.ebuild update to fix the issue reported by Diego

The attached diff should fix the issue reported by Diego.
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-31 21:17:09 UTC
If knetworkmanager uses KDE's admin/ directory that's the wrong fix.

The correct fix would be rm -f "${S}/configure"
Comment 4 .:deadhead:. 2009-10-18 12:24:50 UTC
Now that networkmanagere-0.7 has been stabilized all the knetworkmanager [kde3] are going to have problems... Can you please review and integrate the fix?