Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 255795 - app-arch/karchiver: automake called by maintainer-mode
Summary: app-arch/karchiver: automake called by maintainer-mode
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Gentoo KDE team
URL: http://blog.flameeyes.eu/2008/06/13/m...
Whiteboard:
Keywords:
Depends on:
Blocks: bad-autotools
  Show dependency tree
 
Reported: 2009-01-21 21:58 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-06-09 13:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (karchiver-3.4.2-r4:20081114-183517.log,125.43 KB, text/plain)
2009-01-21 21:58 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-21 21:58:11 UTC
Hello,

You're receiving this canned (template-based) bug report because I found a problem with a package during my tinderbox run.

The package in question is running automake (and most likely other autotools) during compile phase by maintainer-mode. You can see in my blog post in the URL field why that's a problem, and how to address the issue, but in general, you don't want maintainer-mode rebuild during compile phase, especially since it can cause multiple run of econf.

The causes of maintainer-mode rebuild are various, but most likely it's because of a patch that changes Makefile.am or configure.ac/in and don't rebuild autotools properly. The way to fix this is almost always to inherit autotools eclass and run eautomake/eautoreconf (as needed; eautoconf should only be used when automake is not involved, which is not the case here) during src_unpack phase.

Thanks,
Diego
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-21 21:58:35 UTC
Created attachment 179211 [details]
Build log
Comment 2 Carsten Lohrke (RETIRED) gentoo-dev 2009-02-10 01:43:46 UTC
404, don't have a tarball and not sure if it's worth searching. It's more or less abandonware for quite some time now, I think and probably should be punted.
Comment 3 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-06-09 13:25:09 UTC
Masked for removal in 30 days, closing