Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 255790 - sys-apps/portage-2.1.6.4: block between qt-4.3 and qt-4.4 when running emerge -avuDN world
Summary: sys-apps/portage-2.1.6.4: block between qt-4.3 and qt-4.4 when running emerge...
Status: RESOLVED DUPLICATE of bug 161953
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-21 21:21 UTC by Pacho Ramos
Modified: 2009-01-22 21:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
debug output (port,1.03 MB, text/plain)
2009-01-21 21:21 UTC, Pacho Ramos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2009-01-21 21:21:14 UTC
I get:
# emerge -pvuDNt world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge      ] app-cdr/acetoneiso2-2.0.2  [1]
[nomerge      ]  x11-libs/qt-gui-4.4.2-r1  USE="accessibility cups dbus pch qt3support tiff -debug -glib -mng -nas -nis -xinerama" INPUT_DEVICES="-wacom"  [0]
[ebuild  N    ]   x11-libs/qt-qt3support-4.4.2  USE="accessibility pch -debug" 0 kB [0]
[ebuild  N    ]    x11-libs/qt-gui-4.4.2-r1  USE="accessibility cups dbus pch qt3support tiff -debug -glib -mng -nas -nis -xinerama" INPUT_DEVICES="-wacom" 0 kB [0]
[ebuild  N    ]    x11-libs/qt-sql-4.4.2  USE="pch qt3support sqlite -debug (-firebird) -mysql -odbc -postgres" 0 kB [0]
[ebuild  N    ]   x11-libs/qt-script-4.4.2  USE="pch -debug" 0 kB [0]
[ebuild  N    ]   x11-libs/qt-dbus-4.4.2  USE="pch -debug" 0 kB [0]
[ebuild   R   ] app-emulation/wine-1.1.13  USE="X alsa cups gecko jpeg lcms ldap ncurses opengl png%* ssl%* xml (-dbus) -esd (-gnutls) (-hal) -jack (-nas) -oss -samba (-scanner) -win64%" 0 kB [0]
[nomerge      ] media-gfx/gimp-2.4.7  USE="alsa dbus exif gnome hal lcms mmx pdf png python smp sse svg tiff wmf -aalib (-altivec) -curl -debug -doc -gtkhtml -mng"  [0]
[nomerge      ]  app-text/poppler-bindings-0.8.7  USE="cairo gtk qt3 qt4 -test"  [0]
[ebuild  NS   ]   x11-libs/qt-4.3.3 [3.3.8b-r1] USE="accessibility cups dbus gif jpeg opengl pch png qt3support ssl tiff zlib -debug -doc -examples (-firebird) -glib -mng -mysql -nas -nis -odbc -postgres -sqlite -sqlite3 -xinerama" INPUT_DEVICES="-wacom" 0 kB [0]
[ebuild     U ] sys-apps/man-pages-3.16 [3.15] USE="nls" LINGUAS="es -cs -da -de -fr -it -ja -nl -pl -ro -ru -zh_CN" 0 kB [0]
[blocks B     ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r1, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-sql-4.4.2, x11-libs/qt-core-4.4.2)
[blocks B     ] x11-libs/qt-core ("x11-libs/qt-core" is blocking x11-libs/qt-4.3.3)

Total: 8 packages (1 upgrade, 5 new, 1 in new slot, 1 reinstall), Size of downloads: 0 kB
Conflict: 2 blocks (2 unsatisfied)
Portage tree and overlays:

I attach the output with "--debug" added.

My emerge --info:
Portage 2.1.6.4 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.28-tuxonice-r1 x86_64)
=================================================================
System uname: Linux-2.6.28-tuxonice-r1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9300_@_2.50GHz-with-glibc2.2.5
Timestamp of tree: Wed, 21 Jan 2009 21:05:01 +0000
distcc 3.0 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=nocona -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=nocona -fomit-frame-pointer"
DISTDIR="/usr/distfiles"
FEATURES="autoaddcvs ccache collision-protect cvs distlocks fixpackages multilib-strict parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org"
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="es es_ES en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/java-overlay /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 amr avahi bash-completion berkdb bluetooth branding bzip2 cairo cdda cddb cdparanoia cdr cli consolekit cracklib crypt css cups daap dbus dell dirac divx djvu dts dvd dvdr dvdread dvi eds emboss emovix encode epiphany evo exif fam fbcondecor fbsplash ffmpeg flac fortran fuse galago gdbm gif glitz gmedia gnome gnome-keyring gpm gsm gstreamer gtk hal iconv ieee1394 ipv6 isdnlog java java6 jpeg jpeg2k kdeenablefinal kdehiddenvisibility kpathsea ladspa laptop latex lcms ldap libnotify lirc lzma mad midi mikmod mjpeg mmx mmxext mono moonlight mp3 mpeg mudflap multilib musepack musicbrainz nautilus ncurses network network-cron networkmanager nls nptl nptlonly ntp ogg opengl openmp pam pch pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline realmedia reflection scanner schroedinger sdl session smp sms speex spell spl sse sse2 sse3 ssl ssse3 startup-notification svg sysfs t1lib tcpd theora threads tiff totem truetype unicode usb v4l2 vcd vhook vorbis wmf wmp x264 xattr xcb xft xinetd xml xorg xulrunner xv xvid zeroconf zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always
Comment 1 Pacho Ramos gentoo-dev 2009-01-21 21:21:52 UTC
Created attachment 179198 [details]
debug output
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-01-21 22:04:18 UTC
This bug seems to be similar to bug #255527

Please mask qt-4 versions older than version 4.4 like this:

<x11-libs/qt-4.4:4
Comment 3 Zac Medico gentoo-dev 2009-01-21 22:26:47 UTC
This is the same issue as bug 161953 and the correct solution is to mask <x11-libs/qt-4.4:4 as mentioned in comment #1.

*** This bug has been marked as a duplicate of bug 161953 ***
Comment 4 Pacho Ramos gentoo-dev 2009-01-22 21:21:56 UTC
Thanks for the info, it's great learning a bit more every day ;-)