Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 254880 - x11-drivers/xf86-video-intel: Failed to initialize GEM. Falling back to classic.
Summary: x11-drivers/xf86-video-intel: Failed to initialize GEM. Falling back to clas...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-13 19:50 UTC by Sven
Modified: 2009-04-29 02:01 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven 2009-01-13 19:50:01 UTC
Runnign glxgears yields the following error:
Failed to initialize GEM.  Falling back to classic.

3D works, as long as it doesn't say
  Option Legacy3D "off"
in my xorg.conf.


I'm running the following versions of relevant components:
- kernel 2.6.28, dmesg says:
[drm] Initialized i915 1.6.0 20080730 on minor 0
- x11-drivers/xf86-video-intel-2.5.99.2
- x11-proto/dri2proto-1.99.3
- media-libs/mesa-7.3_rc1
- x11-base/xorg-server-1.5.3


What seems to be wrong? I was told, GEM is supposed to work.

Reproducible: Always

Steps to Reproduce:
Comment 1 Sven 2009-01-25 22:30:42 UTC
did an upstream bugreport:
https://bugs.freedesktop.org/show_bug.cgi?id=19739
Comment 2 Rémi Cardona gentoo-dev 2009-01-26 07:31:44 UTC
Thanks, let's see what upstream thinks.
Comment 3 Mark Knecht 2009-04-21 22:37:27 UTC
Any chance we could push this a little more from our end? Reading Sven's bug report upstream I didn't see that it was resolved, or didn't understand the resolution.

I've got a machine that fails to run any xv-based video (MythTV, xine, mplayer, etc.) It's Intel i915-based also. This machine has worked for years, never had a problem, until this recent xorg-server upgrade when it was broken.

I am not using PAE according to my kernel config. I don't see the out of tree messages that Sven saw. I see segfault messages from the Intel driver any time I attempt to do xv video, along with a message about being unable to pin an xv buffer.

Is this bug really resolved?
Comment 4 Sven 2009-04-22 05:22:55 UTC
(In reply to comment #3)
> Any chance we could push this a little more from our end? Reading Sven's bug
> report upstream I didn't see that it was resolved, or didn't understand the
> resolution.

I had to disable PAE. GEM doesn't work with PAE.
Comment 5 Mark Knecht 2009-04-22 13:08:49 UTC
OK. Glad you got yours working. 

My problem is the same error message about GEM not being enabled but I'm not using PAE. 
Comment 6 muhsin 2009-04-25 17:48:59 UTC
Same problem here...actually my kernel was working and I didnt change anything on it...i just emerged gnome-light and X startx now fails :)

Comment 7 muhsin 2009-04-25 22:09:05 UTC
(In reply to comment #6)
> Same problem here...actually my kernel was working and I didnt change anything
> on it...i just emerged gnome-light and X startx now fails :)
> 

my bad...i fogot to :

#echo "exec gnome-session" > ~/.xinitrc

-:)