Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 254510 - games-arcade/xevil: removal (was: make it work on amd64 systems)
Summary: games-arcade/xevil: removal (was: make it work on amd64 systems)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: AMD64 Linux
: Lowest enhancement with 1 vote (vote)
Assignee: Gentoo Games
Whiteboard: Pending removal: 2018-07-17
Keywords: PMASKED
Depends on:
Blocks: games.eclass
  Show dependency tree
Reported: 2009-01-11 03:22 UTC by Frank Bartunek
Modified: 2018-07-28 12:15 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

Adds knowledge of AMD64 systems to XEvil's build system (xevil-64bits.patch,607 bytes, patch)
2009-01-11 03:23 UTC, Frank Bartunek
Details | Diff
Add x86_64 tag to (xevil-2.02_p2-x86_64.patch,290 bytes, patch)
2010-11-13 05:08 UTC, Federico Moro
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Bartunek 2009-01-11 03:22:34 UTC
This incredibly simple patch leads to XEvil compiling and installing on AMD64 platforms, which the custom configuration system used to not do (as "x86_64" as a system identifier was not in its database).   

I will be testing to see if this leads to any bizarre behavior on the game's part.

Reproducible: Always

Steps to Reproduce:
1. epatch my patch into the ebuild
2. add "~amd64" to keywords
3. emerge xevil

Actual Results:  

Expected Results:  
Comment 1 Frank Bartunek 2009-01-11 03:23:16 UTC
Created attachment 178010 [details, diff]
Adds knowledge of AMD64 systems to XEvil's build system

Let me know if any issues arise because of this patch.
Comment 2 Jeremy Olexa (darkside) (RETIRED) archtester gentoo-dev Security 2009-01-11 16:52:52 UTC
Don't mark something resolved that isn't checked into the tree, please.
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2009-10-23 11:27:56 UTC
The patch is clearly bogus.

It's not build-system's job to add flags like -O2 -mtune=native -pipe.
Comment 4 Frank Bartunek 2009-10-26 04:40:39 UTC
The patch shouldn't be adding CFLAGS.  Let me see if I can fix that.
Comment 5 Federico Moro 2010-11-13 05:08:31 UTC
Created attachment 254173 [details, diff]
Add x86_64 tag to

Hello Frank, I tried to compile xevil and it fails, so I search here and found it.
I finally got it compiled adding a x86_64 tag on telling it have to do the same as on i386.
Comment 6 Federico Moro 2010-11-18 13:16:14 UTC
Excuse me about my english.
As I tried to say in the last comment, the patch I've submitted add a rule for x86_64 that call i386 rule, and doing it, xevil compiles and works fine on x86_64 machines (I'm playing it right now).
Please, test it if you can.
Comment 7 Federico Moro 2010-11-25 00:43:48 UTC
Hello? Anybody there?
Comment 8 Markos Chandras (RETIRED) gentoo-dev 2010-11-25 12:02:47 UTC
(In reply to comment #7)
> Hello? Anybody there?

Yes but we have other bugs to deal with as well.
Comment 9 Federico Moro 2010-11-25 16:44:00 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > Hello? Anybody there?
> > 
> Yes but we have other bugs to deal with as well.

I know you have lot of bugs and I'm really pleased with all of you for mantain this great distribution, but this could be solved and you'll have one less :P

Thanks you very much for your attention and your work.
Comment 10 Federico Moro 2011-01-05 15:35:59 UTC
Hi all, happy new year.
Does anybody test it?
Comment 11 SpanKY gentoo-dev 2011-01-05 16:04:09 UTC
Comment on attachment 254173 [details, diff]
Add x86_64 tag to

there shouldnt need to be any arch tags in any build files
Comment 12 Federico Moro 2011-01-05 18:35:05 UTC
Hello SpanKY, happy new year.

if use amd64; then
    make i386
should be added in the ebuild, but I don't know why you don't want to add it since there are lot of tags in the makefile.

These are the two ways to solve it, and it should be solve as this bugs is opened 2 years ago.
Comment 13 SpanKY gentoo-dev 2011-01-05 23:09:38 UTC
no ... there should not be any arch-specific targets at all in the ebuild or in the build system.  if there is, it needs to be fixed at the build system level, not by hacking things up further.  your change is a workaround/hack, not a fix.  i'm interested in a fix.

look at how Debian builds.  it simply sets FORCEHOSTTYPE first.
Comment 14 Agostino Sarubbo gentoo-dev 2011-12-15 17:13:21 UTC
Re-add amd64 when there is a correct patch.
Comment 15 Pacho Ramos gentoo-dev 2018-04-25 18:02:48 UTC
It seems all distributions already killed this, even Debian (that is ebuild is based on) removed it due to incompatibilities with gcc6
Comment 16 Denilson Sá Maia 2018-04-25 20:27:41 UTC
It seems someone applied some patches to make Xevil compile on 64-bit systems:
(which is linked from )

Notice: I haven't tried to compile it myself.
Comment 17 Larry the Git Cow gentoo-dev 2018-07-28 12:15:47 UTC
The bug has been closed via the following commit(s):

commit fc9559077a12195996a8fa8879a15618a492f804
Author:     Michał Górny <>
AuthorDate: 2018-07-28 12:14:38 +0000
Commit:     Michał Górny <>
CommitDate: 2018-07-28 12:15:42 +0000

    games-arcade/xevil: Remove last-rited pkg

 games-arcade/xevil/Manifest                        |  2 -
 .../xevil/files/xevil-2.02_p2-glibc-2.10.patch     | 20 ----------
 games-arcade/xevil/metadata.xml                    |  8 ----
 games-arcade/xevil/xevil-2.02_p2-r1.ebuild         | 43 ----------------------
 profiles/package.mask                              |  5 ---
 5 files changed, 78 deletions(-)