Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 254444 - x11-libs/libXft: ClearType support for x11-libs/libXft
Summary: x11-libs/libXft: ClearType support for x11-libs/libXft
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo X packagers
URL: http://aur.archlinux.org/packages.php...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-10 17:53 UTC by Aron
Modified: 2009-03-27 07:51 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
updated ebuld with 'cleartype' patch (libXft-2.1.13.ebuild,968 bytes, text/plain)
2009-01-10 17:55 UTC, Aron
Details
cleartype patch from ArchLinux (libXft-2.1.10-lcd-cleartype.diff,22.33 KB, text/plain)
2009-01-10 17:55 UTC, Aron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron 2009-01-10 17:53:43 UTC
ClearType patches from ArchLinux were recently added to x11-libs/cairo.  x11-libs/libXft needs a similar patch applied to round out ClearType support for all applications.  The attached ebuild applies the ClearType patch from ArchLinux in the same manner as x11-libs/cairo.

Reproducible: Always
Comment 1 Aron 2009-01-10 17:55:08 UTC
Created attachment 177981 [details]
updated ebuld with 'cleartype' patch
Comment 2 Aron 2009-01-10 17:55:29 UTC
Created attachment 177983 [details]
cleartype patch from ArchLinux
Comment 3 Rémi Cardona gentoo-dev 2009-02-03 17:02:21 UTC
libXft while still officially supported is now deprecated. As such, I'm really not comfortable applying such a big patch without upstream ACKing the patch one way or another.

Please get upstream to approve the patch. Sorry.

Thanks for understanding.
Comment 4 Nikos Chantziaras 2009-03-26 21:45:13 UTC
(In reply to comment #3)
> libXft while still officially supported is now deprecated. As such, I'm really
> not comfortable applying such a big patch without upstream ACKing the patch one
> way or another.
> 
> Please get upstream to approve the patch. Sorry.
> 
> Thanks for understanding.

Well, actually we're not "understanding" :P

If Arch Linux does it, then why not us too? The ClearType patch is in Cairo in Portage. Have you tried enabling the cleartype USE flag? :P Even if this patch would never, ever be accepted by upstream (M$/Apple patent issues?), your users will thank you because it makes Linux suck less compared to Windows and OS X font rendering.
Comment 5 Rémi Cardona gentoo-dev 2009-03-26 23:25:53 UTC
(In reply to comment #4)
> Well, actually we're not "understanding" :P
> 
> If Arch Linux does it, then why not us too?

Debian was patching openssl, look where that got everyone...

> The ClearType patch is in Cairo in Portage.

And I'm not cairo's maintainer.

> Have you tried enabling the cleartype USE flag? :P Even if this patch
> would never, ever be accepted by upstream (M$/Apple patent issues?), your users
> will thank you because it makes Linux suck less compared to Windows and OS X
> font rendering.

"My" users would much rather I spent time trying to fix the X server and its drivers instead of spending time on patching a library that is clearly _deprecated_.

libXt is almost dead. Packages which use it should either die or use 
cairo(/pango).

As for fonts looking better on Mac OS or Windows, that very subjective and I happen to disagree.

Thanks
Comment 6 Nikos Chantziaras 2009-03-27 00:17:36 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Well, actually we're not "understanding" :P
> > 
> > If Arch Linux does it, then why not us too?
> 
> Debian was patching openssl, look where that got everyone...

Shall I start counting the packages Gentoo is patching in Portage?

No?

Didn't think so. :P


> > The ClearType patch is in Cairo in Portage.
> 
> And I'm not cairo's maintainer.

Obviously. He has better understanding of what it takes to provide good packages.


> "My" users would much rather I spent time trying to fix the X server and its
> drivers instead of spending time on patching a library that is clearly
> _deprecated_.

Should I patch it for you?


> libXt is almost dead. Packages which use it should either die or use 
> cairo(/pango).

This is the real world, not some imaginary, perfect utopia.


> As for fonts looking better on Mac OS or Windows, that very subjective and I
> happen to disagree.

People also disagree about GUIs being helpful.  If Gentoo would drop all X11 software from Portage because "the devs" prefer the CLI would you object? Because you're doing something similar here :P
Comment 7 Pacho Ramos gentoo-dev 2009-03-27 07:13:55 UTC
Even when I am a really happy cleartype cairo user ;-), I also understand remi point of view on this: Gentoo X packagers herd has a lot of other work to do that is more important that trying to apply, update and maintain this patch across releases.

Maybe you could try to become a gentoo dev for trying to MAINTAIN libXft 
> > libXt is almost dead. Packages which use it should either die or use 
> > cairo(/pango).
> 
> This is the real world, not some imaginary, perfect utopia.
> 

Well, at least on my system, these are the packages still depending on libXft:
$ equery d libXft
[ Searching for packages depending on libXft... ]
app-editors/gvim-7.2 (!aqua & gtk? x11-libs/libXft)
app-office/abiword-2.6.8 (x11-libs/libXft)
app-office/abiword-plugins-2.6.8 (x11-libs/libXft)
dev-lang/tk-8.5.6 (truetype? x11-libs/libXft)
gnome-base/gnome-control-center-2.24.0.1 (x11-libs/libXft)
media-gfx/inkscape-0.46-r5 (x11-libs/libXft)
media-video/cinelerra-20090210 (x11-libs/libXft)
media-video/xine-ui-0.99.5-r2 (X? x11-libs/libXft)
www-client/opera-9.64 (x11-libs/libXft)
x11-apps/xclock-1.0.3 (x11-libs/libXft)
x11-libs/cairo-1.8.6-r1 (X? x11-libs/libXft)
x11-libs/openmotif-2.3.1.1 (xft? x11-libs/libXft)
x11-libs/pango-1.22.4 (X? x11-libs/libXft)
x11-libs/qt-3.3.8b-r1 (x11-libs/libXft)
x11-libs/vte-0.17.4-r3 (x11-libs/libXft)
x11-misc/googleearth-5.0.11337.1968_beta (x86? x11-libs/libXft)
x11-terms/gnome-terminal-2.24.2-r1 (x11-libs/libXft)
x11-terms/xterm-242 (x11-libs/libXft)
x11-wm/icewm-1.2.37 (x11-libs/libXft)

Even when I usually use some of them, I think that it's not as terrible don't have cleartype support for them :-/
Comment 8 Rémi Cardona gentoo-dev 2009-03-27 07:51:00 UTC
(In reply to comment #6)
> Obviously. He has better understanding of what it takes to provide good
> packages.

> People also disagree about GUIs being helpful.  If Gentoo would drop all X11
> software from Portage because "the devs" prefer the CLI would you object?
> Because you're doing something similar here :P

You can put as many smileys as you want, but both comments are very offensive. In fact, your entire last reply is very rude. You won't win me over that way.

I'm putting a lot of work into Gentoo and X in general and I _resent_ the way you're spinning this.

I've given you my reasons why I won't be patching Xtf. Nothing is preventing you from keeping this patch in a local overlay. If the lib _ever_ sees a new release (which I doubt), you can always update the ebuild and patch you've posted here so that people can find them.

That will be all on the topic for now.