Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 253145 - x11-terms/xterm-2.3.7 - LC_ALL=sr_RS.UTF-8 uxterm Warning: locale not supported by Xlib, locale set to C
Summary: x11-terms/xterm-2.3.7 - LC_ALL=sr_RS.UTF-8 uxterm Warning: locale not support...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL: http://bugs.freedesktop.org/show_bug....
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-30 15:45 UTC by Hans Meier
Modified: 2009-09-24 08:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans Meier 2008-12-30 15:45:39 UTC
If I start with

LC_ALL=sr_RS.UTF-8 uxterm
Warning: locale not supported by Xlib, locale set to C

LC_ALL=hr_HR.UTF-8 uxterm
All is good

Reproducible: Always



Expected Results:  
Support for sr_RS.UTF-8

emerge --info
Portage 2.1.6.4 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r1, 2.6.28-0 x86_64)
=================================================================
System uname: Linux-2.6.28-0-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5000+-with-glibc2.2.5
Timestamp of tree: Tue, 30 Dec 2008 13:45:02 +0000
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.1
sys-apps/sandbox:    1.3.2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.1/env /usr/kde/4.1/share/config /usr/kde/4.1/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/X11 /etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/localtime /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/rc.d /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d /etc/wget"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache collision-protect distlocks fixpackages parallel parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirror.switch.ch/mirror/gentoo/ ftp://gentoo.inode.at/source/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo/"
LANG="en_GB.UTF8"
LDFLAGS="-Wl,-O1"
LINGUAS="sr sr@Latn hr bs de en en_US en_GB"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 7zip X X509 a52 aac aalib accessibility acl acpi ada additions alsa amd64 amr amrnb amrwb arts autoipd bash-completion berkdb bidi big-tables binfilter bluetooth bzip2 cairo caps cdda cddb cdinstall cdio cdparanoia cdr cgraph cli colordiff cpudetection cracklib crm114 crypt css cups cxx dar64 dbus dedicated divx djvu dri dspam dvd dvdnav dvdr dvdread dvi eds emboss enca encode esd espeak exif extensions extra extra-algorithms extraengine fam fbsplash festival ffmpeg firefox flac flexresp2 fluidsynth foomaticdb fortran gadu gammu gcrypt gd gdbm geoip gif gimp gimpprint git gnokii gnutella gpm grammar graphviz groupwise grub gsm gstreamer gtk gucharmap h323 hal hpn html httpd ical iconv icu id3tag idea ilbc imagemagick inquisitio ip27 ipfilter irda isdnlog jabber jack jack-tmpfs java javascript jpeg jpeg2k kde kdeenablefinal kdexdeltas kerberos keyring kpoll krb4 lame lcms ldap libnotify libsamplerate libsexy libwww live lm_sensors loop-aes lzo mad matroska max-idx-128 mbox md5sum md5sum-external mdnsresponder-compat meanwhile midi mikmod mjpeg mmx mmxext mng mod_irc mod_muc mod_pubsub mono motif mozembed mp2 mp3 mp4live mpeg mplayer mudflap multicall multilib multiuser musepack mysql nas ncurses nemesi network network-cron nls nptl nptlonly ntfs ntlm nvidia nvtv obex ocr ogg openct opengl openmp oss pam passwordsave pcre pdf perfprofiling perl php physfs pidgin png pnm pop3d portaudio posix postfix postgres ppds pppd prediction prelude projectx pronounce pvr python qq qt-static qt3 qt3support qt4 quicktime radio rar rdesktop react readline realmedia reflection rtsp ruby samba sasl scanner sdk sdl sdl-image sensord server session sftp sguil shout silc slang smartcard smp sms snmp snortsam speex spell spl srt sse sse2 ssl stream subversion svg sysfs t1lib tcl tcpd teletext themes theora thesaurus threadsafe tiff tk tools tordns transcode truetype twolame type1 unicode usb user-homedirs v4l2 vcd vcdx vda vhosts video videos visibility vlm vorbis vorbis-psy wavpack web wideband wma wmf wmp wxwindows x264 xanim xattr xext xft xine xml xorg xpm xv xvid xvmc yahoo zephyr zlib zoran zrtp zvbi" ALSA_CARDS="snd-hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="sr sr@Latn hr bs de en en_US en_GB" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Rémi Cardona gentoo-dev 2009-01-03 11:20:01 UTC
(In reply to comment #0)
> If I start with
> 
> LC_ALL=sr_RS.UTF-8 uxterm
> Warning: locale not supported by Xlib, locale set to C

Isn't it "sr_SR" you want instead?

Thanks
Comment 2 Hans Meier 2009-01-03 18:24:49 UTC
"sr_SR" is not valid

Look in

/usr/share/i18n/SUPPORTED

There is

sr_ME UTF-8
sr_RS UTF-8
sr_RS@latin UTF-8
Comment 3 Rémi Cardona gentoo-dev 2009-01-04 17:55:54 UTC
Hum, indeed. Upstream already knows about it.

I'll poke them.

Thanks
Comment 4 Samuli Suominen gentoo-dev 2009-05-06 09:15:28 UTC
Quoting upstream bug, since it's quite informative:


Thanks - corrected patch pushed to git master for next libX11 release:

commit da95ecbbdcacc483cd0b5fd7db1fb2e2543341bd
Author: Milos Komarcevic <miloskomarcevic@netscape.net>
Date:   Mon Mar 16 17:43:26 2009 -0700

    Bug 11456: Serbian locale updates (sr_RS and sr_ME)

    X.Org Bug #11456 <http://bugs.freedesktop.org/show_bug.cgi?id=11456>
    Patch #23937 <http://bugs.freedesktop.org/attachment.cgi?id=23937>

    Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Comment 5 Samuli Suominen gentoo-dev 2009-09-24 08:21:40 UTC
*xterm-248 (24 Sep 2009)

  24 Sep 2009; Samuli Suominen <ssuominen@gentoo.org> +xterm-248.ebuild:
  Version bump.

*libX11-1.2.2 (06 Aug 2009)

  06 Aug 2009; Rémi Cardona <remi@gentoo.org> +libX11-1.2.2.ebuild:
  bump to 1.2.2

If it's still a issue with these numbers, please reopen. Thanks!