Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 253106 - net-fs/mount-cifs - QA Notice: Files built without respecting LDFLAGS have been detected
Summary: net-fs/mount-cifs - QA Notice: Files built without respecting LDFLAGS have be...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo's SAMBA Team
URL:
Whiteboard:
Keywords:
: 332521 (view as bug list)
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2008-12-30 10:18 UTC by Lars Wendler (Polynomial-C)
Modified: 2011-05-23 16:22 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
mount-cifs-3.0.30.ebuild.diff (mount-cifs-3.0.30.ebuild.diff,649 bytes, patch)
2008-12-30 10:19 UTC, Lars Wendler (Polynomial-C)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2008-12-30 10:18:14 UTC
>>> Completed installing mount-cifs-3.0.30 into /var/tmp/portage/net-fs/mount-cifs-3.0.30/image/

strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment
   usr/bin/umount.cifs
   usr/bin/mount.cifs
ecompressdir: bzip2 -9 /usr/share/man

 * QA Notice: Files built without respecting LDFLAGS have been detected
 *  Please include the following list of files in your report:
 * /usr/bin/umount.cifs
 * /usr/bin/mount.cifs


Reproducible: Always

Steps to Reproduce:
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2008-12-30 10:19:50 UTC
Created attachment 176852 [details, diff]
mount-cifs-3.0.30.ebuild.diff

How about this fix?
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2008-12-30 10:20:42 UTC
Reassigning to samba herd.
Comment 3 Roman v. Gemmeren 2009-03-18 08:39:53 UTC
quite old bug, but tested & working on amd64 here.
Comment 4 Doktor Notor 2010-03-20 20:35:40 UTC
This package should be removed whenever the split samba stuff hits stable, you get this w/ net-fs/samba-client which is (unlike this) updated upstream, not manually grabbed from tarballs.
Comment 5 Markos Chandras (RETIRED) gentoo-dev 2010-08-10 17:26:39 UTC
Is this still valid? I am not that familiar with samba packages
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2010-08-10 18:34:27 UTC
AFAIK, >=samba-3.4.0 doesn't need this package anymore.
Comment 7 Lars Wendler (Polynomial-C) gentoo-dev 2010-08-12 19:30:24 UTC
*** Bug 332521 has been marked as a duplicate of this bug. ***
Comment 8 Víctor Ostorga (RETIRED) gentoo-dev 2011-05-23 16:22:10 UTC
Reported fixed

  11 Apr 2011; Christoph Mende <angelos@gentoo.org> mount-cifs-3.0.30.ebuild:
  QA: Respect LDFLAGS, added missing die