Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 251030 - Patch to compile media-sound/lilypond-2.11.65 with GCC 4.4
Summary: Patch to compile media-sound/lilypond-2.11.65 with GCC 4.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Scheme Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2008-12-15 14:54 UTC by Daniel J.
Modified: 2009-01-05 18:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Lilypond patch for GCC 4.4 (lilypond-2.11.65-gcc44.patch,3.02 KB, patch)
2008-12-15 14:55 UTC, Daniel J.
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel J. 2008-12-15 14:54:44 UTC
The following patch is necessary to compile Lilypond 2.11.65 on GCC 4.4
Comment 1 Daniel J. 2008-12-15 14:55:28 UTC
Created attachment 175342 [details, diff]
Lilypond patch for GCC 4.4
Comment 2 Daniel J. 2008-12-15 16:31:10 UTC
This has also been submitted upstream.  I will post the bug URL when it is accepted.
Comment 4 Daniel J. 2008-12-30 14:53:17 UTC
This patch did not make it into upstream's 2.12.0 release but will be included in 2.12.1, coming soon.
Comment 5 Daniel J. 2009-01-05 17:45:23 UTC
Lilypond 2.12.1 has been released and incorporates this fix.
Comment 6 Marijn Schouten (RETIRED) gentoo-dev 2009-01-05 18:36:11 UTC
Thanks. I've just added 2.12.1.