Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 249898 - Stable net-analyzer/nethogs-0.6.1_pre2 (was: net-analyzer/nethogs-0.6.0 fails to compile with gcc 4.3 and glibc 2.8)
Summary: Stable net-analyzer/nethogs-0.6.1_pre2 (was: net-analyzer/nethogs-0.6.0 fails...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: gcc-4.3 glibc-2.8
  Show dependency tree
 
Reported: 2008-12-05 09:06 UTC by Pavel Procopiuc
Modified: 2008-12-10 22:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
add missing include header for qsort() (nethogs-0.6.0-gcc4-header.diff,306 bytes, patch)
2008-12-05 09:07 UTC, Pavel Procopiuc
Details | Diff
net-analyzer/nethogs-0.6.0.ebuild (nethogs-0.6.0.ebuild,1002 bytes, text/plain)
2008-12-05 09:07 UTC, Pavel Procopiuc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Procopiuc 2008-12-05 09:06:41 UTC
I'm not really sure about the whole gcc4, but current nethogs in portage does not compile with gcc-4.3.2 due to the missing header inclusion for qsort(). I'm attaching patch and updated ebuild

Reproducible: Always
Comment 1 Pavel Procopiuc 2008-12-05 09:07:26 UTC
Created attachment 174301 [details, diff]
add missing include header for qsort()
Comment 2 Pavel Procopiuc 2008-12-05 09:07:51 UTC
Created attachment 174302 [details]
net-analyzer/nethogs-0.6.0.ebuild
Comment 3 Samuli Suominen gentoo-dev 2008-12-05 10:09:20 UTC
I've added nethogs-0.6.1_pre2 with GCC 4.3 and GLIBC 2.8 patch into tree. Please test and mark stable.
Comment 4 Pavel Procopiuc 2008-12-06 22:34:07 UTC
Works here
Comment 5 Markus Meier gentoo-dev 2008-12-10 22:44:28 UTC
amd64/x86 stable, all arches done.