Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 248883 - kde-misc/kdirstat-2.5.3-r1 + kde-4.1 - kdirstatmain.cpp:(.text+0x62): undefined reference to `KAboutData::KAboutData(char const*, char const*, char const*, char const*, int, char const*, char const*, char const*, char const*)'
Summary: kde-misc/kdirstat-2.5.3-r1 + kde-4.1 - kdirstatmain.cpp:(.text+0x62): undefin...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal with 1 vote (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 268335 277576 (view as bug list)
Depends on:
Blocks: kde3-on-kde4
  Show dependency tree
 
Reported: 2008-11-26 12:30 UTC by Lars
Modified: 2010-04-08 20:41 UTC (History)
16 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
complete build log (build.log,657.29 KB, text/plain)
2008-11-26 12:32 UTC, Lars
Details
ebuild environment file (environment,170.69 KB, text/plain)
2008-11-26 12:34 UTC, Lars
Details
My build log (build.log,933.20 KB, text/plain)
2009-08-27 07:24 UTC, Alexey Shildyakov
Details
Fixed ebuild for 2.5.3 (kdirstat-2.5.3.ebuild,652 bytes, text/plain)
2009-10-30 21:57 UTC, A Schenck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars 2008-11-26 12:30:58 UTC
Can't compile kdirstat-2.5.3-r1 on kde-4.1 desktop due to undefined references.

The problem appeared, after I uninstalled all kde related stuff, to get rid of kde-testing ebuilds, and reinstalled it again from portage tree. Of course I did 
emerge -uND @system @world
emerge --depclean
revdep-rebuild
before trying to compile kdirstat.

emerge --info
WARNING: repository at /usr/local/portage is missing a repo_name entry
 * Overlay eclasses override eclasses from PORTDIR:  
 *
 *   '/usr/portage/local/layman/vmware/eclass/vmware.eclass'
 *   '/usr/portage/local/layman/vmware/eclass/vmware-mod.eclass'
 *
 * It is best to avoid overriding eclasses from PORTDIR because it will   
 * trigger invalidation of cached ebuild metadata that is distributed with
 * the portage tree. If you must override eclasses from PORTDIR then you  
 * are advised to add FEATURES="metadata-transfer" to /etc/make.conf and to  
 * run `emerge --regen` after each time that you run `emerge --sync`. Set 
 * PORTAGE_ECLASS_WARNING_ENABLE="0" in /etc/make.conf if you would like to  
 * disable this warning.  
Portage 2.2_rc14 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.6.1-r0,
2.6.26-gentoo-r2_LM0.13 x86_64)
================================================================= 
System uname:
Linux-2.6.26-gentoo-r2_LM0.13-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7250_@_2.00GHz-with-glibc2.2.5
Timestamp of tree: Tue, 25 Nov 2008 11:15:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632)
[enabled] 
app-shells/bash: 3.2_p33   
dev-java/java-config: 1.3.7, 2.1.6   
dev-lang/python: 2.5.2-r7  
dev-python/pycrypto: 2.0.1-r6  
dev-util/cmake:  2.6.2 
sys-apps/baselayout: 1.12.11.1 
sys-apps/sandbox:1.2.18.1-r2 
sys-devel/autoconf:  2.13, 2.61-r2   
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1  
sys-devel/binutils:  2.18-r3   
sys-devel/gcc-config: 1.4.0-r4 
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3 
ACCEPT_KEYWORDS="amd64" 
CBUILD="x86_64-pc-linux-gnu"   
CFLAGS="-O2 -march=nocona -pipe" 
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config
/usr/kde/3.5/shutdown /usr/share/config" 
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/
/etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo
/etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=nocona -pipe" 
DISTDIR="/usr/portage/distfiles"   
FEATURES="ccache collision-protect distcc distlocks parallel-fetch
preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"  
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/linux/distributions/gentoo"  
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"  
LDFLAGS=""  
LINGUAS="de en"   
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages" 
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress
--force --whole-file --delete --stats --timeout=180 --exclude=/distfiles
--exclude=/local --exclude=/packages"   
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise
/usr/portage/local/layman/java-overlay /usr/portage/local/layman/vmware
/usr/portage/local/layman/xen /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"   
USE="7zip X X509 a52 aac aalib acl acpi addbookmarks additions addressbook
alias alisp alsa amd64 amr amrnb amrwb apache2 archive async asyncns atm
audiofile automount autoreplace avahi bash-completion berkdb bittorrent
bluetooth branding bzip2 cairo caps cdaudio cdda cddb cli connectionstatus
contactnotes cracklib crypt cscope css cups daap dbus dc1394 dell device-mapper
dga dia directfb disk-partition djbfft djvu dmx dnd dri dts dv dvb dvd dvdr
dvdread dxr3 dynamic emacs emovix encode eolconv escreen etwin exif expat
extras fam fame fat fbcon fbcondecor fbsplash ffmpeg fftw finger firefox flac
fontconfig fortran fpx ftp gadu gcj gcrypt gd gdbm ggi gif gimp glitz gmp
gnokii gnutls gopher gpm graphics graphviz groupwise gs gtk hal hardened hdri
hfs highlight history hpn htmlhandbook humanities hyperestraier ical iconv icu
id3tag idea idn ieee1394 ifp imagemagick imlib inkjar inotify ipod ipv6 ipw4965
irc irmc isdnlog jabber jadetex java java5 java6 javascript jbig jce jfsjingle
joystick jpeg jpeg2k jsapi kde kdm kipi kpathsea lame laptop latex lcms libcaca
libnotify libsamplerate live lm_sensors logitech-mouse loop-aes lzo mad madwifi
marble matroska mbrola md5sum mdnsresponder-compat messenger midi mjpeg mmap
mmx mng modplug mono mozdevelop mozdom mozilla mp3 mp4 mpeg mtp mudflap mule
multiuser musepack musicbrainz nas ncurses netboot network network-cron njb nls
nntp nowlistening nptl nptlonly nsplugin nss ntfs nuv nvidia odbc offensive ogg
openexr opengl openmp oss pam paste64 pcmcia pcre pdf perl plasma plotutils pmu
png policykit postscript ppds pppd pth pulseaudio python qt3 qt3support qt4
quicktime quotas readline reflection reiser4 reiserfs replytolist
restrict-javascript rtsp ruby samba sametime scanner science scim script sdl
sdl-image sensord session shout skey skins slang slit slp smi smpsms sndfile
sound soundex speex spell spl spoof-source sqlite sse sse2 ssl ssse3
startup-notification statistics stream svg swat swig sysfs syslog tcl tcpd
texteffect themes theora threads tiff tk toolbar toolkit-scroll-bars translator
truetype unicode usb utempter v4l v4l2 vcd vdr vim-pager vim-syntax vim-with-x
visualization vlm vorbis wavpack webpresence wifi winbind winpopup wmf
wxwindows x264 xcb xcomposite xemacsxetex xforms xfs xine xinerama xml
xmldoclet xmp xorg xosd xpm xscreensaver xulrunner xv xvid xvmc yahoo zeroconf
zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci
emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m
maestro3   trident usb-audio via82xx via82xx-modem ymfpci"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file
hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug
rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic
authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm
authz_default authz_groupfile authz_host authz_owner authz_user autoindex
cachedav dav_fs dav_lock deflate dir disk_cache env expires ext_filter
file_cache filter headers include info log_config logio mem_cache mime
mime_magic negotiation rewrite setenvif speling status unique_id userdir
usertrack vhost_alias" CAMERAS="adc65 agfa_cl20 aox barbie canon casio_qv
clicksmart310 digigr8  digita dimagev dimera3500 directory enigma13 fuji
gsmart300 hp215 iclick  jamcam jd11 kodak_dc120 kodak_dc210 kodak_dc240
kodak_dc3200 kodak_ez200  konica konica_qm150 largan lg_gsm mars mustek
panasonic_coolshot  panasonic_dc1000 panasonic_dc1580 panasonic_l859 pccam300
pccam600  polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ptp2 ricoh ricoh_g3 
samsung sierra sipix_blink sipix_blink2 sipix_web2 smal sonix sony_dscf1 
sony_dscf55 soundvision spca50x sq905 stv0674 stv0680 sx330z template 
toshiba_pdrm11" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse joystick
synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780
lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" USERLAND="GNU"
VIDEO_CARDS="dummy fbdev nv vesa nvidia v4l"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK,
PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Lars 2008-11-26 12:32:44 UTC
Created attachment 173431 [details]
complete build log
Comment 2 Lars 2008-11-26 12:34:16 UTC
Created attachment 173432 [details]
ebuild environment file
Comment 3 Lars 2008-11-26 18:24:09 UTC
I had similar problems with kdesvn-0.14.4/1.0.1/1.0.4 (Bug 248875) and openoffice-2.4.0 (Bug 248924).
Comment 4 Lars 2008-11-27 08:07:25 UTC
I was able to compile kdirstat, kdesvn (and openoffice-3 after applying a patch, see bug 238539 comment 28) by temporarily uninstalling kdelibs:4.1 and
kdepimlibs:4.1 (see Bug 238539 comment 9, comment 25):
emerge -Cav kdelibs:4.1 kdepimlibs:4.1
emerge -av kdirstat kdesvn openoffice
emerge -1av kdelibs:4.1 kdepimlibs:4.1
Comment 5 Romik 2009-01-21 04:20:54 UTC
> emerge -Cav kdelibs:4.1 kdepimlibs:4.1
> emerge -av kdirstat kdesvn openoffice
> emerge -1av kdelibs:4.1 kdepimlibs:4.1

OMG!

mv /etc/env.d/*kdepaths-4* /root/
env-update; source /etc/profile
emerge -av kdirstat kdesvn openoffice e.t.c
mv /root/*kdepaths-4* /etc/env.d/
env-update; source /etc/profile
works ?

I can not verify, sorry...

Comment 6 Lars 2009-03-09 10:43:00 UTC
(In reply to comment #5)
 
> mv /etc/env.d/*kdepaths-4* /root/
> env-update; source /etc/profile
> emerge -av kdirstat kdesvn openoffice e.t.c
> mv /root/*kdepaths-4* /etc/env.d/
> env-update; source /etc/profile
> works ?
> 
Meanwhile I upgraded to kde-4.2. I did not install KDE-4 with kdeprefix so I do not have /etc/env.d/*kdepaths-4* entries. I moved /etc/env.d/*kdepaths instead, but emerging kdirstat still did not work.  
Again I had to remove kdelibs first.
Comment 7 Lori 2009-07-09 11:41:08 UTC
I am running KDE 4.2.4 and can't compile kdirstat either. I do have several other KDE 3 packages on my system which work fine.
Comment 8 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-08-09 21:53:38 UTC
*** Bug 277576 has been marked as a duplicate of this bug. ***
Comment 9 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-08-09 21:53:45 UTC
*** Bug 268335 has been marked as a duplicate of this bug. ***
Comment 10 Alexey Shildyakov 2009-08-27 07:24:03 UTC
Created attachment 202377 [details]
My build log

I didn't update system for 2 month. Before using KDE-4.2.4. Then update system and the bug presents.
Comment 11 Hector Martin 2009-10-05 14:25:06 UTC
I get this too with KDE 4.3.1. This looks similar to bug 244694.
Comment 12 David Zaslavsky 2009-10-11 09:18:33 UTC
I'm getting the same problem with KDE 4.3.2 on ~amd64. The undefined references I'm seeing appear to be the same ones in the build logs that are already attached (I checked the first ~50 and they match up)

emerge --info:

Portage 2.1.6.13 (default/linux/amd64/10.0/desktop, gcc-4.4.1, glibc-2.10.1-r0, 2.6.30-gentoo-r6 x86_64)
=================================================================                                       
System uname: Linux-2.6.30-gentoo-r6-x86_64-AMD_Phenom-tm-_II_X4_955_Processor-with-gentoo-2.0.1        
Timestamp of tree: Sun, 11 Oct 2009 00:20:01 +0000                                                      
app-shells/bash:     4.0_p33                                                                            
dev-java/java-config: 2.1.9-r1                                                                          
dev-lang/python:     2.4.4-r13, 2.5.4-r3, 2.6.3, 3.1.1-r1                                               
dev-python/pycrypto: 2.0.1-r8                                                                           
dev-util/cmake:      2.6.4-r3                                                                           
sys-apps/baselayout: 2.0.1                                                                              
sys-apps/openrc:     0.5.1                                                                              
sys-apps/sandbox:    2.1                                                                                
sys-devel/autoconf:  2.13, 2.63-r1                                                                      
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11                                                   
sys-devel/binutils:  2.19.1-r1                                                                          
sys-devel/gcc-config: 1.4.1                                                                             
sys-devel/libtool:   2.2.6a                                                                             
virtual/os-headers:  2.6.30-r1                                                                          
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                          
CBUILD="x86_64-pc-linux-gnu"                                                                            
CFLAGS="-march=amdfam10 -O2 -pipe"                                                                      
CHOST="x86_64-pc-linux-gnu"                                                                             
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"                      
CXXFLAGS="-march=amdfam10 -O2 -pipe"                                                                                                                     
DISTDIR="/usr/portage/distfiles"                                                                                                                         
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                           
GENTOO_MIRRORS="http://mirror.mcs.anl.gov/pub/gentoo/ ftp://mirror.mcs.anl.gov/pub/gentoo/ http://mirrors.cs.wmich.edu/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo "                                                                                                                                             
LDFLAGS="-Wl,-O1"                                                                                                                                        
MAKEOPTS="-j5"                                                                                                                                           
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/custom"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apache2 bash-completion berkdb branding bzip2 cairo cddb cdparanoia cdr cli consolekit cracklib crypt dbus doc dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg firefox flac fortran gdbm gif git gpm gstreamer hal iconv idn imagemagick imap ipv6 isdnlog jadetex java java6 javascript jpeg jpeg2k kde kpathsea latex lcms ldap libnotify logrotate mad maildir mikmod mime mmx mng modules mp3 mp4 mpeg mudflap multilib mysql ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openmp pam pcmcia pcre pdf perl phonon php png posix ppds pppd python qt3support qt4 quicktime readline reflection samba sdl session smp spell spl sql sse sse2 ssl startup-notification subversion svg svn svnserve sysfs tcpd threads thunar tiff timidity truetype unicode usb vorbis wmf x264 xattr xcomposite xine xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 13 Christopher Hogan 2009-10-15 08:16:25 UTC
(In reply to comment #11)
> I get this too with KDE 4.3.1. This looks similar to bug 244694.
> 

I can confirm this, I just don't know how to fix it. The following works:
emerge kdirstat
(emerge fails, but leaves the work directory)
cd /var/tmp/portage/kde-misc/kdirstat-2.5.3-r1/work/kdirstat-2.5.3
sed -i -e '1,$s/all_libraries \$KDE_LDFLAGS/KDE_LDFLAGS \$all_libraries/' configure
ebuild /usr/portage/kde-misc/kdirstat/kdirstat-2.5.3-r1.ebuild configure
ebuild /usr/portage/kde-misc/kdirstat/kdirstat-2.5.3-r1.ebuild compile
ebuild /usr/portage/kde-misc/kdirstat/kdirstat-2.5.3-r1.ebuild install
ebuild /usr/portage/kde-misc/kdirstat/kdirstat-2.5.3-r1.ebuild qmerge

The ebuild erases the configure script that comes with the package and it looks like the new configure script is generated in the same function that runs configure. I assume the configure.in file can be patched. However, I'm not sure where KDE_LDFLAGS and all_libraries come from.

As a side note, I did contact Stefan Hundhammer. A version without KDE dependencies is in the early planning stages.

Comment 14 Jesse Adelman 2009-10-18 22:37:59 UTC
Argh. I wish I'd looked at this bug before nicely asking Mr. Hundhammer via e-mail about KDirStat and QT4 myself just now, duplicating the e-mail in comment #13. Sorry, sir, for the Gentoo spam. :/
Comment 15 A Schenck 2009-10-30 21:57:37 UTC
Created attachment 208801 [details]
Fixed ebuild for 2.5.3

After reading what other people had figured out with editing the configure script I swam around in autotools for a little while until I figured out that it could be fixed by editing the acinclude.m4 file in the admin directory.  After doing so and preparing several patches I remembered something from the how to fix autotools failures page (http://www.gentoo.org/proj/en/qa/autofailure.xml) about kde ebuilds and the admin directory, so I followed those directions and everything works nicely.

Remarkably simple fix to the annoying autotools problems.
Comment 16 Samuli Suominen gentoo-dev 2009-11-12 11:35:25 UTC
gone
Comment 17 Richard Freeman gentoo-dev 2009-11-12 14:20:06 UTC
Note that if somebody hears that upstream has released a non-kde version of this app I'll be happy to maintain it outside of the kde herd - a bit premature to do that now.  Just email me or assign me a bug when this is ready to go back into the tree.
Comment 18 A Schenck 2010-04-08 20:41:15 UTC
Added fixed ebuild as kdirstst-2.5.3-r2 on kde-sunset overlay.