Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 248788 - app-editors/gedit-2.24.2 fails to build due to eautoreconf on a libtool-1 system
Summary: app-editors/gedit-2.24.2 fails to build due to eautoreconf on a libtool-1 system
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-11-25 14:13 UTC by Ivan Iraci
Modified: 2008-11-29 20:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Working gedit-2.24.2 ebuild (gedit-2.24.2.ebuild,2.06 KB, text/plain)
2008-11-25 14:14 UTC, Ivan Iraci
Details
emerge --info (emerge.info,11.00 KB, text/plain)
2008-11-26 21:40 UTC, Marco Leogrande
Details
build.log from failed compilation (build.log,25.52 KB, text/plain)
2008-11-26 21:41 UTC, Marco Leogrande
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Iraci 2008-11-25 14:13:51 UTC
gedit-2.24.2 doesn't build because of the damn libtool problem, as of many other ebuilds (there are a few bug reports around here, moreover I just fixed fftw-3.2 ebuild and I suspect there are many other I'll have to fix during this 'emerge -u world'). I'm in ~amd64. I am going to attach a working ebuild.

Reproducible: Always

Steps to Reproduce:
1. emerge gedit
2. kaboom
Comment 1 Ivan Iraci 2008-11-25 14:14:57 UTC
Created attachment 173347 [details]
Working gedit-2.24.2 ebuild

This ebuild works as expected
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-11-25 17:23:29 UTC
please don't complain about using ~arch ebuild on a arch system kthxbye
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-11-25 17:25:38 UTC
err sorry, misread.

Please post emerge --info and build.log. I have ~amd64 and it built just fine when I bumped it.

Also please post patch against ebuilds not full ebuilds.
Comment 4 Marco Leogrande 2008-11-26 21:39:03 UTC
I'm having the very same problem of the OP, although I'm on ~x86. I'll attach emerge --info and build.log shortly.
I can confirm that, using the updated ebuild provided in this bug, gedit compiles perfectly.
Comment 5 Marco Leogrande 2008-11-26 21:40:54 UTC
Created attachment 173529 [details]
emerge --info
Comment 6 Marco Leogrande 2008-11-26 21:41:51 UTC
Created attachment 173530 [details]
build.log from failed compilation
Comment 7 Rafał Mużyło 2008-11-27 01:03:54 UTC
I eventually had to download the sources to figure it out
(I really hate to do it), but the problem is actually quite simple.

gedit was makedist'd with libtool 2.
Now, the problem hits only <libtool-2 systems.
For <libtool-2, AC_CONFIG_MACRO_DIR had no meaning,
so the libtool macro went straight to aclocal.m4.
For libtool-2 series, that macro is a hint for libtoolize
where to put libtool macro, so in this case, libtool macros went into
m4/ dir.

When libtoolize was run on a <libtool-2 system, ltmain.sh script
was overwritten, but the macros in m4/ dir were untouched.

The effect: conflict between new macros and old script.
So the fix: 'rm m4/lt* m4/libtool.m4' is indeed the correct one.
Comment 8 Gilles Dartiguelongue gentoo-dev 2008-11-27 07:58:10 UTC
thanks for the description, that what led to the rewrite of the summary already. Please consider we are just missing time to fix this issue and this is why it's still open.
Comment 9 Gilles Dartiguelongue gentoo-dev 2008-11-27 07:59:33 UTC
oh and btw guys, you should switch to libtool-2 it's way better than 1 and it would have avoided you this pain :p
Comment 10 Ivan Iraci 2008-11-27 09:56:28 UTC
(In reply to comment #9)

> oh and btw guys, you should switch to libtool-2 it's way better than 1 and it
> would have avoided you this pain :p

No way. The only reason to upgrade a tool such as libtool is that you miss some important feature which blocks the build process. This is not really the case.

Comment 11 Andrew Cowie 2008-11-29 10:39:15 UTC
So I guess this bug explains why this kicked in now; somewhere between gedit 2.24.1 and 2.24.2, I was required to upgrade libtool from 1.5* to 2.2* in order to be able to build it.

This was most distressing.

I've upgraded libtool now, and been through the `emerge -1 @preserved-rebuild` cycle which, mercifully, was only 7 packages or so. Hooray for Portage 2.2.

AfC
Comment 12 Gilles Dartiguelongue gentoo-dev 2008-11-29 20:11:27 UTC
fixed without a bump, thanks for reporting.
Comment 13 Gilles Dartiguelongue gentoo-dev 2008-11-29 20:11:38 UTC
grmbl, fixed.