Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 248657 - dev-libs/gmime-2.2.23 fails parallel install with mono bindings enabled
Summary: dev-libs/gmime-2.2.23 fails parallel install with mono bindings enabled
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Net-Mail Packages
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords:
: 250019 252426 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-11-24 16:49 UTC by onip
Modified: 2009-01-26 00:13 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
complete build.log (build.log,144.42 KB, text/plain)
2008-11-24 16:50 UTC, onip
Details
gacutil-output.txt (gacutil-output.txt,15.50 KB, text/plain)
2008-11-27 23:45 UTC, Gilles Dartiguelongue
Details
gacutil -l output (gacout.log,18.10 KB, text/plain)
2008-11-27 23:46 UTC, onip
Details
gacutil -l (gacutil.output.txt,18.87 KB, text/plain)
2008-12-25 15:55 UTC, Roman Karshiev
Details
Fix parallel install (0001-Fix-parallel-install-by-using-install-data-hook-rath.patch,1.13 KB, text/plain)
2009-01-12 23:43 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description onip 2008-11-24 16:49:32 UTC
uppgrading to new stable dev-libs/gmime fails during install. the only error I was able to find is about missing gtkdoc-rebase

-- Installing ./html/index.sgml
which: no gtkdoc-rebase in (/usr/local/sbin:/sbin:/usr/sbin:/usr/lib/portage/bin:/usr/local/bin:/bin:/usr/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.2:/opt/sun-jdk-1.4.2.16/bin:/opt/sun-jdk-1.4.2.16/jre/bin:/opt/sun-jdk-1.4.2.16/jre/javaws:/usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/qt/3/bin)
make[3]: [install-data-local] Error 1 (ignored)

note that USE doc is disabled system wide

Reproducible: Always

Steps to Reproduce:




# emerge --info
Portage 2.1.4.5 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r9 i686)
=================================================================
System uname: 2.6.25-gentoo-r9 i686 Intel(R) Pentium(R) 4 CPU 2.50GHz
Timestamp of tree: Mon, 24 Nov 2008 14:00:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.4.6-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -mmmx -msse -msse2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -mmmx -msse -msse2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg distlocks fixpackages parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -mmmx -msse -msse2 -pipe -fomit-frame-pointer"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ http://gentoo.mirror.dkm.cz/pub/gentoo/ http://mirror.jamit.de/gentoo/"
LANG="it_IT.UTF-8"
LC_ALL="it_IT.UTF-8"
LDFLAGS="-Wl,-z,now -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--enable-new-dtags"
LINGUAS="it"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/science /usr/portage/local/layman/sunrise /usr/portage/local/layman/gechi /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acpi alsa apache2 audiofile berkdb bluetooth branding bzip2 cairo cddb cdparanoia cdr cli cracklib crypt cups curl dbus dga directfb dri dts dvb dvd dvdr dvdread eds emboss encode evo exif fam fbcon ffmpeg firefox flac fortran ftp gdbm gif gnome gnome-keyring gpm gstreamer gtk gtk2 gtkhtml hal iconv imagemagick imlib ipod isdnlog java jikes jpeg jpeg2k lame lcms ldap libnotify mad midi mikmod mmx mng mono mp3 mpeg mtp mudflap nautilus ncurses nls nptl nptlonly offensive ogg openal opengl openmp pam pcre pdf perl png ppds pppd python quicktime readline reflection ruby samba sdl session sndfile spell spl sse sse2 ssl startup-notification svg sysfs tcpd theora threads tiff truetype unicode usb v4l vcd vorbis wavpack win32codecs wmf x264 x86 xine xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 onip 2008-11-24 16:50:28 UTC
Created attachment 173243 [details]
complete build.log

adding build.log
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-11-27 22:56:42 UTC
Actually this is a mono error, check the following excerpt:

make[2]: Nothing to be done for `install-exec-am'.
/usr/bin/gacutil /i gmime-sharp.dll /f /package gmime-sharp /root /var/tmp/portage/dev-libs/gmime-2.2.23/image//usr/lib
test -z "/usr/share/gapi-2.0" || /bin/mkdir -p "/var/tmp/portage/dev-libs/gmime-2.2.23/image//usr/share/gapi-2.0"
 /usr/bin/install -c -m 644 'gmime-api.xml' '/var/tmp/portage/dev-libs/gmime-2.2.23/image//usr/share/gapi-2.0/gmime-api.xml'
test -z "/usr/lib/pkgconfig" || /bin/mkdir -p "/var/tmp/portage/dev-libs/gmime-2.2.23/image//usr/lib/pkgconfig"
 /usr/bin/install -c -m 644 'gmime-sharp.pc' '/var/tmp/portage/dev-libs/gmime-2.2.23/image//usr/lib/pkgconfig/gmime-sharp.pc'
Failure adding assembly gmime-sharp.dll to the cache: Strong name cannot be verified for delay-signed assembly
make[2]: *** [install-data-local] Error 1


gtkdoc-rebase error is ignored as it's written just on the next line you quoted.
Adding dotnet to get some hints about what's going on.
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2008-11-27 23:41:09 UTC
> gtkdoc-rebase error is ignored as it's written just on the next line you
> quoted.
> Adding dotnet to get some hints about what's going on.

What does gacutil -l say?

Comment 4 Gilles Dartiguelongue gentoo-dev 2008-11-27 23:45:18 UTC
Created attachment 173619 [details]
gacutil-output.txt

here is what it gives me.
Comment 5 onip 2008-11-27 23:46:22 UTC
Created attachment 173621 [details]
gacutil -l output

$ gacutil -l > gacout.log
Comment 6 Gilles Dartiguelongue gentoo-dev 2008-12-07 00:35:26 UTC
*** Bug 250019 has been marked as a duplicate of this bug. ***
Comment 7 Gilles Dartiguelongue gentoo-dev 2008-12-25 11:22:01 UTC
*** Bug 252426 has been marked as a duplicate of this bug. ***
Comment 8 Roman Karshiev 2008-12-25 15:54:16 UTC
Same error.

 /bin/install -c 'gmime-config' '/var/tmp/portage/dev-libs/gmime-2.2.23/image//usr/bin/gmime-config'
 /bin/install -c -m 644 'gmimeConf.sh' '/var/tmp/portage/dev-libs/gmime-2.2.23/image//usr/lib/gmimeConf.sh'
 /bin/install -c -m 644 'gmime-2.0.pc' '/var/tmp/portage/dev-libs/gmime-2.2.23/image//usr/lib/pkgconfig/gmime-2.0.pc'
make[2]: Leaving directory `/var/tmp/portage/dev-libs/gmime-2.2.23/work/gmime-2.2.23'
make[1]: Leaving directory `/var/tmp/portage/dev-libs/gmime-2.2.23/work/gmime-2.2.23'
make: *** [install-recursive] Error 1
 * 
 * ERROR: dev-libs/gmime-2.2.23 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_install
 *             environment, line 2608:  Called die
 * The specific snippet of code:
 *       emake GACUTIL_FLAGS="/root '${D}/usr/$(get_libdir)' /gacdir /usr/$(get_libdir) /package ${PN}" DESTDIR="${D}" install || die "installation failed";
 *  The die message:
 *   installation failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-libs/gmime-2.2.23/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/gmime-2.2.23/temp/environment'.
Comment 9 Roman Karshiev 2008-12-25 15:55:56 UTC
Created attachment 176356 [details]
gacutil -l
Comment 10 Peter Alfredsen (RETIRED) gentoo-dev 2008-12-25 16:17:01 UTC
http://developer.momonga-linux.org/viewvc/trunk/pkgs/gmime/gmime-2.2.22-gacutils.patch
Gilles and I talked about this on IRC. Adding the above link here so we don't forget. That patch is supposed to fix this problem. Hasn't been tested with versions of mono less than 2.0.1.
Comment 11 aj2r 2008-12-28 12:31:52 UTC
(In reply to comment #10)
> http://developer.momonga-linux.org/viewvc/trunk/pkgs/gmime/gmime-2.2.22-gacutils.patch
> Gilles and I talked about this on IRC. Adding the above link here so we don't
> forget. That patch is supposed to fix this problem. Hasn't been tested with
> versions of mono less than 2.0.1.
> 

This patch doesn't work for me, mono-2.0.1-r1. The same error persists
Comment 12 Thomas Beutin 2009-01-01 18:13:28 UTC
same error here when i try to install dev-libs/gmime-2.2.23; mono is 2.0.1-r1
Comment 13 Peter Alfredsen (RETIRED) gentoo-dev 2009-01-01 20:51:23 UTC
(In reply to comment #12)
> same error here when i try to install dev-libs/gmime-2.2.23; mono is 2.0.1-r1
> 
I've added this as an ebuild to the dotnet overlay (layman -a dotnet). It builds for me. Take care to only install this from the overlay, unless you like experimental packages.
Comment 14 Nick Brooker 2009-01-10 01:53:00 UTC
I had a similar problem and it seems gmime, when you turn on the mono flag, needs gtk-doc as a dependancy which has gtkdoc-rebase in it.

Then I get..

/usr/bin/gacutil /i gmime-sharp.dll /f /package gmime-sharp /root /var/tmp/portage/dev-libs/gmime-2.2.23/image//usr/lib
Failure adding assembly gmime-sharp.dll to the cache: Strong name cannot be verified for delay-signed assembly

Which is what others are seeing as well.

Comment 15 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-12 23:43:23 UTC
Created attachment 178302 [details]
Fix parallel install

This is an error in the mono/Makefile.am rules for install. I'll report upstream, please apply the attached patch or (as a workaround, and thus without closing this bug!) add a -j1 to emake install.
Comment 16 Billy DeVincentis 2009-01-17 19:52:27 UTC
I have tried modifying the ebuild as per your instructions but I still can't emerge this. Same error during installation phase. Could you please create an attachment with the modified ebuild. Possibly an error on my part putting in the -j1 option. Thank you.
Comment 17 Christian Häßler 2009-01-22 16:46:14 UTC
I'm using mono-2.0.1-r1

i've inserted -j1 but get this error. Is -j1 on the right place?

emake GACUTIL_FLAGS="/root '${D}/usr/$(get_libdir)' /gacdir /usr/$(get_libdir) /package ${PN}" DESTDIR="${D}" -j1 install || die "installation failed";
Comment 18 Peter Alfredsen (RETIRED) gentoo-dev 2009-01-26 00:13:57 UTC
Hope you don't mind, the bug got in the way of me going somewhere with other stuff. I tried to ping you on IRC.

+  26 Jan 2009; Peter Alfredsen <loki_val@gentoo.org>
+  +files/gmime-2.2.23-sign-assembly.patch, +files/gmime-sharp.snk,
+  gmime-2.2.23.ebuild:
+  Non-maintainer-commit: Fix bug 248657. Import signing key from upstream,
+  fix assemblyinfo.cs and Makefile.am to actually sign the assembly.
+