Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 247991 - net-libs/cvm: fails with forced --as-needed
Summary: net-libs/cvm: fails with forced --as-needed
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Robin Johnson
URL: http://www.gentoo.org/proj/en/qa/asne...
Whiteboard:
Keywords:
Depends on:
Blocks: as-needed
  Show dependency tree
 
Reported: 2008-11-21 17:03 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2010-06-29 21:41 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---
robbat2: Bugday+


Attachments
Build log (net-libs:cvm-0.82:20081121-143658.log,11.30 KB, text/plain)
2008-11-21 17:04 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-11-21 17:03:42 UTC
I'm reporting this bug because the package in summary fails to build when forcing --as-needed on through spec files (check out http://blog.flameeyes.eu/2008/11/14/problems-and-mitigation-strategies-for-as-needed for details).

Check the attached build log.

Thanks,
Diego
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-11-21 17:04:22 UTC
Created attachment 172709 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2010-06-29 21:41:15 UTC
This seems to be fixed in 0.96, builds fine here with forced asneeded and after staring half an hour the weird Makefile it has, the link order seems proper there as well.

Please reopen if you can still reproduce with 0.96.