Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 247698 - app-office/openoffice-3.0.0 - {standard input}:1013: Error: invalid character (0x16) in operand 1
Summary: app-office/openoffice-3.0.0 - {standard input}:1013: Error: invalid character...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Office Team
Depends on:
Reported: 2008-11-20 12:44 UTC by Michael P. Soulier
Modified: 2008-12-26 10:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

ebuild environment file (environment,222.30 KB, text/plain)
2008-11-20 12:45 UTC, Michael P. Soulier
gzipped build log (build.log.gz,627.25 KB, application/octet-stream)
2008-11-20 16:12 UTC, Michael P. Soulier

Note You need to log in before you can comment on or make changes to this bug.
Description Michael P. Soulier 2008-11-20 12:44:41 UTC
I ran emerge app-office/openoffice and it failed to build.

Reproducible: Always

Steps to Reproduce:
Emerge openoffice.

Actual Results:  
 * Messages for package app-office/openoffice-3.0.0:

 *  It is important to note that is a very fragile  
 *  build when it comes to CFLAGS.  A number of flags have already 
 *  been filtered out.  If you experience difficulty merging this  
 *  package and use agressive CFLAGS, lower the CFLAGS and try to  
 *  merge again. Also note that building OOo takes a lot of time and 
 *  hardware ressources: 4-6 GB free diskspace and 256 MB RAM are 
 *  the minimum requirements. If you have less, use openoffice-bin 
 *  instead. 
 *  Also if you experience a build break, please make sure to retry 
 *  with MAKEOPTS=-j1 before filing a bug. 
 *  To get a localized build, set the according LINGUAS variable(s). 
 *  You are building with java-support disabled, this results in some 
 *  of the functionality being disabled. 
 *  If something you need does not work for you, rebuild with 
 *  java in your USE-flags. 
 * ERROR: app-office/openoffice-3.0.0 failed.
 * Call stack:
 *     , line   49:  Called src_compile
 *             environment, line 5415:  Called die
 * The specific snippet of code:
 *       make || die "Build failed"
 *  The die message:
 *   Build failed
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-office/openoffice-3.0.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/openoffice-3.0.0/temp/environment'.
 * GNU info directory index is up-to-date.

Expected Results:  
It should have built properly.
Comment 1 Michael P. Soulier 2008-11-20 12:45:45 UTC
Created attachment 172464 [details]
ebuild environment file
Comment 2 Michael P. Soulier 2008-11-20 16:12:46 UTC
Created attachment 172530 [details]
gzipped build log
Comment 3 Michael P. Soulier 2008-11-20 16:44:39 UTC
Running processes: 2                                                            
Making: ../../../                        
Making: ../../../                    
Making: ../../../              
Making: ../../../                          
Making: ../../../                               
Making: ../../../                            
Making: ../../../                          
Making: ../../../                               
Making: ../../../                               
Making: ../../../                             
{standard input}: Assembler messages:                                           
{standard input}:1013: Error: invalid character (0x16) in operand 1             
{standard input}:9931: Error: suffix or operands invalid for `push'             
{standard input}:9931: Error: junk at end of line, first unrecognized           
character is `%'                                                                
dmake:  Error code 1, while making                                              
Running processes: 1                                 
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2008-11-21 01:02:59 UTC
Please post your `emerge --info' too.
Comment 5 Michael P. Soulier 2008-11-21 01:18:19 UTC
(In reply to comment #4)
> Please post your `emerge --info' too.

msoulier@anton:~$ emerge --info
Portage (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r8 i686)
System uname: 2.6.25-gentoo-r8 i686 AMD Athlon(tm) XP 1700+
Timestamp of tree: Thu, 06 Nov 2008 22:07:01 +0000
app-shells/bash:     3.2_p33
dev-lang/python:     2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.4.6-r1
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-O2 -march=athlon-xp -pipe"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X acl acpi aim alsa bash-completion berkdb branding bzip2 cli cracklib crypt dri dvd dvdr dvdread encode exif ffmpeg firefox fontconfig gdbm gif gnuplot gphoto2 gpm gtk iconv imap ipod ipv6 isdnlog jpeg midi mp3 mpeg mplayer msn mudflap ncurses nls nptl nptlonly ogg openmp pam pcre pdf perl png pppd python quicktime readline reflection session spl ssl svg sysfs tcpd tiff tk truetype unicode usb win32codecs x86 xorg xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Comment 6 Michael P. Soulier 2008-11-21 01:23:40 UTC
> Reproducible: Always

This is in error. To confirm I ran it again, and changed nothing. Someone on the gentoo-users mailing list said that they had problems building openoffice when they had limited memory. I have 1Gig but I killed firefox in any case since it is quite the hog. 

It just finished successfully. Seems to work fine so far.

Perhaps ebuilds need to have a free memory prerequisite. I remember a similar problem in my first gentoo experience being unable to compile gcc due to limited memory. 
Comment 7 Andreas Proschofsky (RETIRED) gentoo-dev 2008-12-26 10:31:48 UTC
(In reply to comment #6)
> > Reproducible: Always
> Perhaps ebuilds need to have a free memory prerequisite. I remember a similar
> problem in my first gentoo experience being unable to compile gcc due to
> limited memory. 

Well we actually already check for available memory. The problem is that the free memory might change during the build process. And that's a problem I really don't see a solution too. So closing, if someone has an idea for a fix, please reopen