Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 247098 - dev-python/gtkmozembed-python - xulrunner-1.9 support patch
Summary: dev-python/gtkmozembed-python - xulrunner-1.9 support patch
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: EBUILD
: 223265 247615 247616 247643 (view as bug list)
Depends on:
Blocks: xul-1.9
  Show dependency tree
 
Reported: 2008-11-16 17:26 UTC by Dmitri Bogomolov
Modified: 2008-11-29 23:46 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild for dev-python/gtkmozembed-python (gtkmozembed-python-2.19.1-r1.ebuild,1.34 KB, text/plain)
2008-11-16 17:27 UTC, Dmitri Bogomolov
Details
adapted xulrunner-1.9 patch (gtkmozembed-python-2.19.1-xulrunner-1.9.patch,7.38 KB, patch)
2008-11-16 17:28 UTC, Dmitri Bogomolov
Details | Diff
patch from #223265 (libtool-2.patch,220 bytes, patch)
2008-11-16 17:30 UTC, Dmitri Bogomolov
Details | Diff
working patch (gtkmozembed-python-2.19.1-r1.ebuild,1.25 KB, patch)
2008-11-19 14:05 UTC, Dmitri Bogomolov
Details | Diff
working ebuild (gtkmozembed-python-2.19.1-use-1.9.patch,4.05 KB, text/plain)
2008-11-19 14:06 UTC, Dmitri Bogomolov
Details
gtkmozembed-python-2.19.1-r10.ebuild.patch (gtkmozembed-python-2.19.1-r10.ebuild.patch,556 bytes, patch)
2008-11-19 23:48 UTC, Lars Wendler (Polynomial-C)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitri Bogomolov 2008-11-16 17:26:07 UTC
Patches are taken from http://bugs.gentoo.org/show_bug.cgi?id=223265 and 	slightly changed. I expected it will work, but configure says:
The following modules will be built:


The following modules will NOT be built:

gtkhtml2
egg.trayicon
egg.recent
gtkmozembed
gtkspell
gdl
gda
gksu2
gksu
gksu.ui

Reproducible: Always
Comment 1 Dmitri Bogomolov 2008-11-16 17:27:52 UTC
Created attachment 172002 [details]
ebuild for dev-python/gtkmozembed-python
Comment 2 Dmitri Bogomolov 2008-11-16 17:28:49 UTC
Created attachment 172003 [details, diff]
adapted xulrunner-1.9 patch
Comment 3 Dmitri Bogomolov 2008-11-16 17:30:03 UTC
Created attachment 172004 [details, diff]
patch from #223265
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-11-16 20:41:40 UTC
if you don't read the patch, you have no chance of making this work...

Please also note that we tend to make xulrunner-1.9 only ebuild and xulrunner-1.8/firefox/whatever separate.
Comment 5 Daniel Gryniewicz (RETIRED) gentoo-dev 2008-11-17 15:37:59 UTC
The gtkmozembed-python in the tree builds against xulrunner 1.9.
Comment 6 Dmitri Bogomolov 2008-11-18 13:36:07 UTC
(In reply to comment #5)
> The gtkmozembed-python in the tree builds against xulrunner 1.9.
> 

I just did emerge --sync and don't see gtkmozembed-python that builds against xulrunner-1.9.

dev-python/gtkmozembed-python-2.19.1.ebuild:

RDEPEND="xulrunner? ( =net-libs/xulrunner-1.8* )
        !xulrunner? ( firefox? ( =www-client/mozilla-firefox-2* ) )
        !xulrunner? ( !firefox? ( seamonkey? ( =www-client/seamonkey-1* ) ) )"
DEPEND="${RDEPEND}"
Comment 7 Daniel Gryniewicz (RETIRED) gentoo-dev 2008-11-18 16:59:13 UTC
Ah, my bad.  I had just made a local modification, and missed that.

Just change the dep to 1.9 and change the configure to 1.9 and it works fine.
Comment 8 Dmitri Bogomolov 2008-11-19 14:05:04 UTC
Created attachment 172370 [details, diff]
working patch
Comment 9 Dmitri Bogomolov 2008-11-19 14:06:36 UTC
Created attachment 172371 [details]
working ebuild
Comment 10 Dmitri Bogomolov 2008-11-19 14:11:41 UTC
> Just change the dep to 1.9 and change the configure to 1.9 and it works fine.
> 

You right. I just attached ebuild & patch, on which checked that out.
Comment 11 Daniel Gryniewicz (RETIRED) gentoo-dev 2008-11-19 16:12:28 UTC
Reopening to fix
Comment 12 Daniel Gryniewicz (RETIRED) gentoo-dev 2008-11-19 16:13:01 UTC
I added 2.19.1-r10 that deps on 1.9.  This is inline with epiphany and others.
Comment 13 Walter Meinl 2008-11-19 18:54:17 UTC
(In reply to comment #12)
> I added 2.19.1-r10 that deps on 1.9.  This is inline with epiphany and others.
> 

but this breaks during configure
configure: error: --with-gtkmozembed argument must be either 'mozilla', 'firefox', or 'xulrunner'

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-python/gtkmozembed-python-2.19.1-r10/work/gnome-python-extras-2.19.1/config.log
 * 
 * ERROR: dev-python/gtkmozembed-python-2.19.1-r10 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3724:  Called gnome2_src_compile
 *             environment, line 2904:  Called gnome2_src_configure
 *             environment, line 2918:  Called econf '--disable-allbindings' '--enable-gtkmozembed' '--with-gtkmozembed=xulrunner-1.9' '--disable-gtk-doc'
 *               ebuild.sh, line  525:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *  The die message:
 *   econf failed
 
Comment 14 Gilles Dartiguelongue gentoo-dev 2008-11-19 20:07:05 UTC
*** Bug 247616 has been marked as a duplicate of this bug. ***
Comment 15 Gilles Dartiguelongue gentoo-dev 2008-11-19 20:08:28 UTC
*** Bug 247615 has been marked as a duplicate of this bug. ***
Comment 16 Lars Wendler (Polynomial-C) gentoo-dev 2008-11-19 22:20:02 UTC
(In reply to comment #13)
> (In reply to comment #12)
> > I added 2.19.1-r10 that deps on 1.9.  This is inline with epiphany and others.
> > 
> 
> but this breaks during configure
> configure: error: --with-gtkmozembed argument must be either 'mozilla',
> 'firefox', or 'xulrunner'
> 
> !!! Please attach the following file when seeking support:
> !!!
> /var/tmp/portage/dev-python/gtkmozembed-python-2.19.1-r10/work/gnome-python-extras-2.19.1/config.log
>  * 
>  * ERROR: dev-python/gtkmozembed-python-2.19.1-r10 failed.
>  * Call stack:
>  *               ebuild.sh, line   49:  Called src_compile
>  *             environment, line 3724:  Called gnome2_src_compile
>  *             environment, line 2904:  Called gnome2_src_configure
>  *             environment, line 2918:  Called econf '--disable-allbindings'
> '--enable-gtkmozembed' '--with-gtkmozembed=xulrunner-1.9' '--disable-gtk-doc'
>  *               ebuild.sh, line  525:  Called die
>  * The specific snippet of code:
>  *                      die "econf failed"
>  *  The die message:
>  *   econf failed
> 
> 

I get the same error with gtkmozembed-python-2.19.1-r10. Please reopen this bug.
Comment 17 Lars Wendler (Polynomial-C) gentoo-dev 2008-11-19 23:45:25 UTC
*** Bug 247643 has been marked as a duplicate of this bug. ***
Comment 18 Lars Wendler (Polynomial-C) gentoo-dev 2008-11-19 23:46:57 UTC
Reopening since the ebuild fails to compile with "-firefox -seamonkey xulrunner" USE flags
Comment 19 Lars Wendler (Polynomial-C) gentoo-dev 2008-11-19 23:48:09 UTC
Created attachment 172421 [details, diff]
gtkmozembed-python-2.19.1-r10.ebuild.patch

This patch fixes the above mentioned problem for me...
Comment 20 Daniel Gryniewicz (RETIRED) gentoo-dev 2008-11-19 23:56:46 UTC
Fixed.  Sorry about that.
Comment 21 Walter Meinl 2008-11-20 07:34:32 UTC
(In reply to comment #19)
> Created an attachment (id=172421) [edit]
> gtkmozembed-python-2.19.1-r10.ebuild.patch
> 
> This patch fixes the above mentioned problem for me...
> 

Confirm that this builds, but gtkmozembed.so is linked again against old xulrunner, you can see with
ldd /usr/lib/python2.5/site-packages/gtk-2.0/gtkmozembed.so or in the respective gtkmozembed.la file.
Comment 22 Andrew "Drew" Freiberger 2008-11-20 19:41:23 UTC
> Confirm that this builds, but gtkmozembed.so is linked again against old
> xulrunner, you can see with
> ldd /usr/lib/python2.5/site-packages/gtk-2.0/gtkmozembed.so or in the
> respective gtkmozembed.la file.

I verified that this is indeed true in my case as well.  The configure script may need updated to handle paths for the --with-gtkmozembed flag.
Comment 23 Gilles Dartiguelongue gentoo-dev 2008-11-29 23:46:30 UTC
*** Bug 223265 has been marked as a duplicate of this bug. ***