Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 246194 - Live CD freeze on Thinkpad 600X - RAMDISK: incomplete write (-28 != 32768) 83888608
Summary: Live CD freeze on Thinkpad 600X - RAMDISK: incomplete write (-28 != 32768) 83...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: LiveCD/DVD (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-09 18:56 UTC by Oliver Böhm
Modified: 2011-05-25 11:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Böhm 2008-11-09 18:56:22 UTC
I have a IBM Thinkpad 600X (Pentium-III, 256 MB) where at the moment Xubuntu 8.04 is installed. Now I want to install Gentoo and followed the instruction on the homepage. But when I install from the Live CD 2008.0-r1 boot starts normal but freeze after a short time with a

...
RAMDISK: Compressed image found at block 0
RAMDISK: incomplete write (-28 != 32768) 83888608
crc error
UDF-fs: No partition found (1)
...
VFS Cannot open root device "ram0" or unknown-block(1,0)
...
Kernel panic - not syncing: VFS: Unable to mount root fs on unknow-block(1,0)

The rest of the messages seems to be normal (except: ...unable to open rtc device (rtc0). I tried it also with a 2nd CD to exclude a problem with the CD - same result. I tried also the kernel options acpi=off noapic nolapic ide=nodma - same result.
I

Reproducible: Always

Steps to Reproduce:
1.boot the Life CD on a Thinkpad 600X
2.
3.

Actual Results:  
it freezes with a kernel panic
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2008-11-10 15:53:04 UTC
1) Did you also check the downloaded image's digest before you went and burned another CD?
2) From what (exact) URL did you download the CD image?
Comment 2 Oliver Böhm 2008-11-10 20:36:45 UTC
(In reply to comment #1)
> 1) Did you also check the downloaded image's digest before you went and burned
> another CD?

no, but I booted the CD also on another notebook (T41), and this notebook booted from it

> 2) From what (exact) URL did you download the CD image?

from two different (German) mirrors (de-mirror.org and the other one I forgot)
Comment 3 Andrew Gaffney (RETIRED) gentoo-dev 2008-11-12 14:20:04 UTC
256MB of RAM isn't very much these days. Also, there was a problem on the 2008.0 LiveCDs with the initramfs being *massive*. I don't recall if that was fixed in -r1.

Boot the CD up on another machine and check the size of /mnt/cdrom/isolinux/gentoo.igz. If it's more than a few MB, that's the problem. You can try using the minimal CD instead.
Comment 4 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-05-25 11:58:00 UTC
Closing as we don't provide livecds any more.