Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 245795 - x11-libs/gtk+-2.12.11 - ../libtool: line 6426: cd: __LIBGL_PATH__: No such file or directory
Summary: x11-libs/gtk+-2.12.11 - ../libtool: line 6426: cd: __LIBGL_PATH__: No such fi...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-06 09:56 UTC by Viktor .A Sychow
Modified: 2009-07-28 15:28 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Full gtk+ build log (build.log,163.78 KB, text/plain)
2008-11-06 09:57 UTC, Viktor .A Sychow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Viktor .A Sychow 2008-11-06 09:56:10 UTC
After massive system update, gtk+ library and gtk+ and dependent stuff fails compilation.

 

Reproducible: Always

Steps to Reproduce:
1. emerge -uD --update world (with latest portage tree version)
.

Actual Results:  
Simply start the system update process.
gtk+ build fails, with libtool error.


Expected Results:  
Update process terminated on gtk+,cairo && pango with error:
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -DG_LOG_DOMAIN=\"Gdk\" -DGDK_COMPILATION -I.. -I../gdk -I../gdk-pixbuf -DGDK_PIXBUF_DISABLE_DEPRECATED -DG_DISABLE_CAST_CHECKS -pthread -D_REENTRANT -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/include/cairo -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/include/pixman-1 -O2 -march=k8 -pipe -Wall -MT gdkenumtypes.lo -MD -MP -MF .deps/gdkenumtypes.Tpo -c gdkenumtypes.c  -fPIC -DPIC -o .libs/gdkenumtypes.o
/bin/sh ../libtool --mode=link x86_64-pc-linux-gnu-gcc  -O2 -march=k8 -pipe -Wall   -o libgdk-x11-2.0.la  -version-info 1200:11:1200 -export-dynamic -rpath /usr/lib64  -export-symbols-regex "^[^_].*"  gdk.lo gdkcairo.lo gdkcolor.lo gdkcursor.lo gdkdisplay.lo gdkdnd.lo gdkdraw.lo gdkevents.lo gdkfont.lo gdkgc.lo gdkglobals.lo gdkkeys.lo gdkkeyuni.lo gdkimage.lo gdkdisplaymanager.lo gdkpango.lo gdkpixbuf-drawable.lo gdkpixbuf-render.lo gdkpixmap.lo gdkpolyreg-generic.lo gdkrgb.lo gdkrectangle.lo gdkregion-generic.lo gdkscreen.lo gdkselection.lo gdkvisual.lo gdkwindow.lo gdkenumtypes.lo x11/libgdk-x11.la -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lfontconfig -lXext -lXrender -lX11 -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lXfixes -lm ../gdk-pixbuf/libgdk_pixbuf-2.0.la 
../libtool: line 6426: cd: __LIBGL_PATH__: No such file or directory
libtool: link: warning: cannot determine absolute directory name of `__LIBGL_PATH__'
grep: __LIBGL_PATH__/libGL.la: No such file or directory
/bin/sed: can't read __LIBGL_PATH__/libGL.la: No such file or directory
libtool: link: `__LIBGL_PATH__/libGL.la' is not a valid libtool archive
make[4]: *** [libgdk-x11-2.0.la] Error 1
make[4]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.12.11/work/gtk+-2.12.11/gdk'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.12.11/work/gtk+-2.12.11/gdk'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.12.11/work/gtk+-2.12.11/gdk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.12.11/work/gtk+-2.12.11'
make: *** [all] Error 2
ERROR: x11-libs/gtk+-2.12.11 failed.
Call stack:
         ebuild.sh, line   49:  Called src_compile
         environment, line 2936:  Called die
The specific snippet of code:
       emake || die "compile failed"
       The die message:
      compile failed
  If you need support, post the topmost build error, and the call stack if relevant.
 A complete build log is located at '/var/tmp/portage/x11-libs/gtk+-2.12.11/temp/build.log'.
 The ebuild environment file is located at '/var/tmp/portage/x11-libs/gtk+-2.12.11/temp/environment'.
 


Portage 2.1.4.5 (default-linux/amd64/2007.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.27.4-generic x86_64)
=================================================================
System uname: 2.6.27.4-generic x86_64 Intel(R) Core(TM)2 Duo CPU E4600 @ 2.40GHz
Timestamp of tree: Wed, 05 Nov 2008 01:30:01 +0000
app-shells/bash:     3.2_p33
dev-lang/python:     2.4.4-r6, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.4.6-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.16.1-r3, 2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -march=k8 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O3 -march=k8 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig binpkg buildpkg ccache distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="ru_RU.UTF-8"
LC_ALL="ru_RU.UTF-8"
LINGUAS="ru"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 arts bitmap-fonts cairo cdr cli cracklib crypt cups dbus dvd dvdr dvdread eds emboss encode esd evo fam firefox gdbm gif gpm gstreamer gtk hal iconv isdnlog ithreads jpeg kde kerberos ldap libg++ mad midi mikmod mmx mp3 mpeg mudflap multislot multitarget ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl svg tiff truetype truetype-fonts type1-fonts unicode vorbis xml xorg xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" USERLAND="GNU" VIDEO_CARDS="apm dummy fbdev mach64 nv r128 radeon vesa vga ark chips cirrus cyrix epson glint i128 i810 mga neomagic rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Viktor .A Sychow 2008-11-06 09:57:29 UTC
Created attachment 170888 [details]
Full gtk+ build log
Comment 2 Viktor .A Sychow 2008-11-07 04:30:57 UTC
(In reply to comment #1)
> Created an attachment (id=170888) [edit]
> Full gtk+ build log
> 

This is a libtool bug.
I have 2 identical systems with same software on them.
First system updated successfully, second with this bug.
Comment 3 Rafał Mużyło 2008-11-10 19:54:46 UTC
I'd say it's more likely to be an effect of an 'eselect opengl' problem.
Maybe you've emerged something, while it was set to an invalid value
and that value stayed in one of la files.
Comment 4 Viktor .A Sychow 2008-11-11 02:31:40 UTC
(In reply to comment #3)
> I'd say it's more likely to be an effect of an 'eselect opengl' problem.
> Maybe you've emerged something, while it was set to an invalid value
> and that value stayed in one of la files.
> 

I've been selected NVIDIA OpenGL profile, before system upgrade.

satan ~ # eselect opengl list
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11
satan ~ #

I've checked all libGL*.la files, and I not found __LIBGL_PATH__ in them.
Comment 5 andy 2008-12-05 03:19:11 UTC
I had this problem ( am using nvidia drivers ) but I was all like.. 

# grep __LIBGL_PATH__ `ls /usr/lib/*.la`

and noticed that it showed up in /usr/lib/libcairo.la

All I had to do is search and replace __LIBGL_PATH__ with the full  path of the folder that nvidia's libGL.la was installed to
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2008-12-09 01:27:00 UTC
*** Bug 250116 has been marked as a duplicate of this bug. ***
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-03-22 17:11:39 UTC
for me this is either an eselect opengl problem or a nvidia problem.
Comment 8 Rémi Cardona gentoo-dev 2009-07-28 15:28:15 UTC
Probably a busted libGL.la from nvidia. Newer versions don't have those problems and rebuilding cairo should fix the issue.

Thanks