Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 245707 - Please stabilise sci-mathematics/octave-3.0.3 and sci-mathematics/octave-forge-2006.03.17-r1
Summary: Please stabilise sci-mathematics/octave-3.0.3 and sci-mathematics/octave-forg...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Science Mathematics related packages
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 245715 261568
Blocks: gcc-4.3-stable 263872
  Show dependency tree
 
Reported: 2008-11-05 17:57 UTC by Christian Faulhammer (RETIRED)
Modified: 2014-12-27 16:54 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
sci-libs:umfpack-5.2.0:20090307-152300.log (sci-libs:umfpack-5.2.0:20090307-152300.log,248.49 KB, text/plain)
2009-03-12 22:58 UTC, Markus Meier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Faulhammer (RETIRED) gentoo-dev 2008-11-05 17:57:09 UTC
This is for GCC 4.3 stabilisation.  Please add arches as you see fit. Thanks.
Comment 1 Markus Dittrich (RETIRED) gentoo-dev 2008-11-06 13:52:24 UTC
The next octave that should go stable is octave-3.*. However,
since octave-3.* depends on a lot of new packages (mostly
sparse-matrix support) that don't yet have stable versions this
will probably take some time.

Best,
Markus
Comment 2 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-01-27 22:58:03 UTC
(In reply to comment #1)
> The next octave that should go stable is octave-3.*. However,
> since octave-3.* depends on a lot of new packages (mostly
> sparse-matrix support) that don't yet have stable versions this
> will probably take some time.
> 
> Best,
> Markus
> 

status? whats the list of packages?
Comment 3 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-02-06 22:10:05 UTC
well, the list on amd64 is simply octave-3.0.3 and:
sci-mathematics/glpk-4.29

Other arches, YMMV. please stable all that is needed for gcc-4.3 effort

Keywords: alpha amd64 ppc x86 
Keywords: ppc64 sparc 
Comment 4 Tobias Klausmann gentoo-dev 2009-02-08 15:56:18 UTC
Stabilised those on alpha:

media-libs/qhull-2003.1-r1
sci-libs/camd-2.2.0
sci-libs/ccolamd-2.7.1
sci-libs/ufconfig-3.1.0
sci-libs/colamd-2.7.1
sci-libs/metis-4.0.1-r1
sci-libs/amd-2.2.0
sci-libs/cholmod-1.6.0-r1
sci-libs/cxsparse-2.2.1
sci-libs/umfpack-5.2.0
sci-mathematics/glpk-4.35
sci-mathematics/octave-3.0.3

Skipped octave-forge since it isn't keyworded on alpha at all.

Comment 5 Brent Baude (RETIRED) gentoo-dev 2009-03-02 21:11:45 UTC
I am getting segfaults with test suite.
Comment 6 Markus Meier gentoo-dev 2009-03-07 15:20:46 UTC
sci-libs/amd-2.2.0 test suite fails on x86, see bug #261568.
Comment 7 Markus Meier gentoo-dev 2009-03-12 22:58:34 UTC
Created attachment 184858 [details]
sci-libs:umfpack-5.2.0:20090307-152300.log

umfpack fails some tests (nonfatal) here on amd64/x86, but x86 has much more output than amd64, here's the amd64 output:
make[2]: Entering directory `/var/tmp/portage/sci-libs/umfpack-5.2.0/work/UMFPACK/Demo'
x [0] = 1
x [1] = 2
x [2] = 3
x [3] = 4
x [4] = 5
Test umfpack_simple PASSED.
--- Testing umfpack_di_demo ---
1523c1523
< Total time:  0.00 seconds (CPU time),  0.00 seconds (wallclock time)
---
> Total time:  0.01 seconds (CPU time),  0.00 seconds (wallclock time)
Test `umfpack_di_demo' FAILED!!!
--- Testing umfpack_dl_demo ---
1523c1523
< Total time:  0.00 seconds (CPU time),  0.00 seconds (wallclock time)
---
> Total time:  0.01 seconds (CPU time),  0.01 seconds (wallclock time)
Test `umfpack_dl_demo' FAILED!!!
--- Testing umfpack_zi_demo ---
1523c1523
< Total time:  0.00 seconds (CPU time),  0.00 seconds (wallclock time)
---
> Total time:  0.00 seconds (CPU time),  0.01 seconds (wallclock time)
Test `umfpack_zi_demo' FAILED!!!
--- Testing umfpack_zl_demo ---
1523c1523
< Total time:  0.00 seconds (CPU time),  0.01 seconds (wallclock time)
---
> Total time:  0.00 seconds (CPU time),  0.00 seconds (wallclock time)
Test `umfpack_zl_demo' FAILED!!!
*** ERROR: 4/5 tests failed!!!
Please check the failures before reporting
make[2]: Leaving directory `/var/tmp/portage/sci-libs/umfpack-5.2.0/work/UMFPACK/Demo'
make[1]: Leaving directory `/var/tmp/portage/sci-libs/umfpack-5.2.0/work/UMFPACK/Demo'
make[1]: Entering directory `/var/tmp/portage/sci-libs/umfpack-5.2.0/work/UMFPACK'
make[1]: Nothing to be done for `check-am'.
make[1]: Leaving directory `/var/tmp/portage/sci-libs/umfpack-5.2.0/work/UMFPACK'

x86 is attached.
Comment 8 Roeland Douma 2009-03-15 22:37:39 UTC
AMD64: Here everything compiles fine. Also my old matlab code seems to work fine and produces sane output.

Portage 2.1.6.7 (default/linux/amd64/2008.0/no-multilib, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.25-gentoo-r7 x86_64)
=================================================================                                                   
System uname: Linux-2.6.25-gentoo-r7-x86_64-AMD_Turion-tm-_64_Mobile_Technology_MT-28-with-glibc2.2.5               
Timestamp of tree: Sun, 15 Mar 2009 15:45:02 +0000                                                                  
app-shells/bash:     3.2_p39                                                                                        
dev-java/java-config: 1.3.7-r1, 2.1.7                                                                               
dev-lang/python:     2.4.4-r13, 2.5.2-r7                                                                            
dev-python/pycrypto: 2.0.1-r6                                                                                       
dev-util/cmake:      2.6.2-r1                                                                                       
sys-apps/baselayout: 1.12.11.1                                                                                      
sys-apps/sandbox:    1.2.18.1-r2                                                                                    
sys-devel/autoconf:  2.13, 2.63                                                                                     
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2                                                                
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -msse3 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=k8 -msse3 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks fixpackages multilib-strict parallel-fetch protect-owned sandbox sfperms strict test unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://gentoo.tiscali.nl/ ftp://gentoo.tiscali.nl/pub/mirror/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="en nl"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/ftd4linux /usr/overlay"
SYNC="rsync://rsync.tiscali.nl/gentoo-portage"
USE="X aac acpi admin alsa amd64 ao apache2 bash-completion bzip2 cairo calendar cli cracklib crypt cups curl cvs dbus dri escreen ffmpeg flac fontconfig fortran ftp gd gdbm gif hal highlight history hybrid-auth iconv isdnlog jpeg jpeg2k kde latex midi mmx mp3 mplayer mudflap mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp oss par pcre perl png posix pppd python qt3 qt3support readline reflection session spl sse sse2 ssl subversion sysfs tcpd threads tiff truetype unicode unrar unzip vim-syntax vorbis webdav-neon xine xml xmlreader xmlrpc xmlwriter xorg xpm xv zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouseevdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en nl" USERLAND="GNU" VIDEO_CARDS="sis"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 9 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-03-23 03:48:21 UTC
looks good for me too on amd64. 

amd64 stable on both in summary (and deps).
Comment 10 Ferris McCormick (RETIRED) gentoo-dev 2009-03-27 12:12:20 UTC
Does it matter that octave-3.0.3 and octave-forge-2006.03.17-r1 cannot both be installed?  Apparently, octave-3.0.3 supplies octave-forge.
Comment 11 Ferris McCormick (RETIRED) gentoo-dev 2009-03-27 13:25:19 UTC
Sparc is done, I think.  We do not see any test failures with umfpack.  Our comments are pretty much the same as Comment 4 above except we already have qhull.  I also skipped octave-forge because if you have this version of octave, you can't install it, and since now octave-3.0.3 is stable and you use it, portage will give you grief when it tries to upgrade octave.
Comment 12 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-03-27 18:44:43 UTC
(In reply to comment #11)
> Sparc is done, I think.  We do not see any test failures with umfpack.  Our
> comments are pretty much the same as Comment 4 above except we already have
> qhull.  I also skipped octave-forge because if you have this version of octave,
> you can't install it, and since now octave-3.0.3 is stable and you use it,
> portage will give you grief when it tries to upgrade octave.
> 

I assumed that the user would pick one or the other. As I am not familar with this package, I decided to stab both on amd64. Please let me know if I am wrong here.
Comment 13 Ferris McCormick (RETIRED) gentoo-dev 2009-03-27 20:27:37 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > Sparc is done, I think.  We do not see any test failures with umfpack.  Our
> > comments are pretty much the same as Comment 4 above except we already have
> > qhull.  I also skipped octave-forge because if you have this version of octave,
> > you can't install it, and since now octave-3.0.3 is stable and you use it,
> > portage will give you grief when it tries to upgrade octave.
> > 
> 
> I assumed that the user would pick one or the other. As I am not familar with
> this package, I decided to stab both on amd64. Please let me know if I am wrong
> here.
> 

Beats me.  I'm not familiar with it either.  I'll probably follow your lead for sparc.
Comment 14 Ferris McCormick (RETIRED) gentoo-dev 2009-03-27 22:59:27 UTC
Also octave-forge-2006.03.17-r1 stable on sparc, following Jeremy's reasoning in Comment 12.  Note, however, if this is installed, you will not be able to upgrade to octave-3.0.3.  And if octave-3.0.3 is installed, you will not be able to install any version of octave-forge at all because of the RDEPEND:
!sci-mathematics/octave-forge

But it is set up so that you could run with this version of octave-forge but no octave.
Comment 15 MaratIK 2009-04-07 08:51:42 UTC
Cannot build on amd64 with enabled USE-option "sparse"
See bug#262892
Comment 16 Markus Meier gentoo-dev 2009-04-20 20:02:52 UTC
x86 stable
Comment 17 nixnut (RETIRED) gentoo-dev 2009-09-27 13:43:06 UTC
ppc stable
Comment 18 Jeroen Roovers gentoo-dev 2009-10-12 20:07:52 UTC
Despite the huge QA problems that seemingly never got fixed, stable for HPPA.
Comment 19 Justin Lecher gentoo-dev 2010-06-23 11:10:11 UTC
superseeded by bug 318649.