Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 244510 - app-office/openoffice-3.0.0 - cannot run some apps due to problems with libuno_sal.so
Summary: app-office/openoffice-3.0.0 - cannot run some apps due to problems with libun...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-26 20:11 UTC by Maciej Grela
Modified: 2008-12-29 08:35 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
paludis --info (paludisinfo.txt,10.02 KB, text/plain)
2008-11-05 03:58 UTC, YLD
Details
Paludis use.conf file (use.conf,4.58 KB, text/plain)
2008-11-05 04:02 UTC, YLD
Details
objdump -p /usr/lib/openoffice/ure/lib/libuno_sal.so.3 (libuno_sal.so.3.private_headers,2.92 KB, text/plain)
2008-12-22 15:30 UTC, David Tardon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Grela 2008-10-26 20:11:13 UTC
I`m having problems running any apps from openoffice-3.0.0 built from portage. When running oocalc, oowriter or any other OO program the following error appears:

thermal@idaho ~ $ unopkg
/usr/lib/openoffice/program/unopkg.bin: /usr/lib/openoffice/program/libuno_sal.so.3: version `UDK_3.8' not found (required by /usr/lib/openoffice/program/../basis-link/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3)
/usr/lib/openoffice/program/unopkg.bin: /usr/lib/openoffice/program/libuno_sal.so.3: version `UDK_3.8' not found (required by /usr/lib/openoffice/program/../basis-link/program/libtlli.so)
thermal@idaho ~ $ oowriter
/usr/lib/openoffice/program/soffice.bin: /usr/lib/openoffice/program/libuno_sal.so.3: version `UDK_3.8' not found (required by /usr/lib/openoffice/program/../basis-link/program/libsofficeapp.so)
/usr/lib/openoffice/program/soffice.bin: /usr/lib/openoffice/program/libuno_sal.so.3: version `UDK_3.8' not found (required by /usr/lib/openoffice/program/../basis-link/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3)
/usr/lib/openoffice/program/soffice.bin: /usr/lib/openoffice/program/libuno_sal.so.3: version `UDK_3.8' not found (required by /usr/lib/openoffice/program/../basis-link/program/libsvtli.so)
/usr/lib/openoffice/program/soffice.bin: /usr/lib/openoffice/program/libuno_sal.so.3: version `UDK_3.8' not found (required by /usr/lib/openoffice/program/../basis-link/program/libtlli.so)
/usr/lib/openoffice/program/soffice.bin: /usr/lib/openoffice/program/libuno_sal.so.3: version `UDK_3.8' not found (required by /usr/lib/openoffice/program/../basis-link/program/libsaxli.so)
thermal@idaho ~ $ oocalc
/usr/lib/openoffice/program/soffice.bin: /usr/lib/openoffice/program/libuno_sal.so.3: version `UDK_3.8' not found (required by /usr/lib/openoffice/program/../basis-link/program/libsofficeapp.so)
/usr/lib/openoffice/program/soffice.bin: /usr/lib/openoffice/program/libuno_sal.so.3: version `UDK_3.8' not found (required by /usr/lib/openoffice/program/../basis-link/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3)
/usr/lib/openoffice/program/soffice.bin: /usr/lib/openoffice/program/libuno_sal.so.3: version `UDK_3.8' not found (required by /usr/lib/openoffice/program/../basis-link/program/libsvtli.so)
/usr/lib/openoffice/program/soffice.bin: /usr/lib/openoffice/program/libuno_sal.so.3: version `UDK_3.8' not found (required by /usr/lib/openoffice/program/../basis-link/program/libtlli.so)
/usr/lib/openoffice/program/soffice.bin: /usr/lib/openoffice/program/libuno_sal.so.3: version `UDK_3.8' not found (required by /usr/lib/openoffice/program/../basis-link/program/libsaxli.so)

They all seem to be related to the liuno_sal.so library. Here is an objdump of this lib in my system:

thermal@idaho ~ $ objdump -x /usr/lib/openoffice/program/libuno_sal.so.3

/usr/lib/openoffice/program/libuno_sal.so.3:     file format elf32-i386
/usr/lib/openoffice/program/libuno_sal.so.3
architecture: i386, flags 0x00000150:
HAS_SYMS, DYNAMIC, D_PAGED
start address 0x4c053870

Program Header:
    LOAD off    0x00000000 vaddr 0x4c03c000 paddr 0x4c03c000 align 2**12
         filesz 0x001a4f6c memsz 0x001a4f6c flags r-x
    LOAD off    0x001a5e24 vaddr 0x4c1e1e24 paddr 0x4c1e1e24 align 2**12
         filesz 0x000120b0 memsz 0x00013ef8 flags rw-
 DYNAMIC off    0x001b76fc vaddr 0x4c1f36fc paddr 0x4c1f36fc align 2**2
         filesz 0x00000118 memsz 0x00000118 flags rw-
EH_FRAME off    0x001a2eb8 vaddr 0x4c1deeb8 paddr 0x4c1deeb8 align 2**2
         filesz 0x00000464 memsz 0x00000464 flags r--
   STACK off    0x00000000 vaddr 0x00000000 paddr 0x00000000 align 2**2
         filesz 0x00000000 memsz 0x00000000 flags rw-
   RELRO off    0x001a5e24 vaddr 0x4c1e1e24 paddr 0x4c1e1e24 align 2**0
         filesz 0x00011a5c memsz 0x00011a5c flags r--
PAX_FLAGS off    0x00000000 vaddr 0x4c03c000 paddr 0x4c03c000 align 2**2
         filesz 0x00000000 memsz 0x00000000 flags --- 2800

Dynamic Section:
  NEEDED      libcrypt.so.1
  NEEDED      libdl.so.2
  NEEDED      libpthread.so.0
  NEEDED      libstdc++.so.6
  NEEDED      libm.so.6
  NEEDED      libgcc_s.so.1
  NEEDED      libc.so.6
  SONAME      libuno_sal.so.3
  RPATH       $ORIGIN
  RUNPATH     $ORIGIN
  INIT        0x4c052c10
  FINI        0x4c080804
  GNU_HASH    0x4c03c114
  STRTAB      0x4c0409c4
  SYMTAB      0x4c03db74
  STRSZ       0x39db
  SYMENT      0x10
  PLTGOT      0x4c1f3874
  PLTRELSZ    0x618
  PLTREL      0x11
  JMPREL      0x4c0525f4
  RELA        0x4c044c80
  RELASZ      0xd974
  RELAENT     0xc
  VERDEF      0x4c04496c
  VERDEFNUM   0xb
  VERNEED     0x4c044ae0
  VERNEEDNUM  0x7
  VERSYM      0x4c0443a0
  RELACOUNT   0x1212
  CHECKSUM    0xcc34df1e
  0x6ffffdf5  0x48fe7e45

Version definitions:
1 0x01 0x0e30e673 libuno_sal.so.3
2 0x00 0x01297db0 UDK_3_0_0
3 0x00 0x09912641 UDK_3.1
        UDK_3_0_0
4 0x00 0x09912642 UDK_3.2
        UDK_3.1
5 0x00 0x09912643 UDK_3.3
        UDK_3.2
6 0x00 0x09912644 UDK_3.4
        UDK_3.3
7 0x00 0x09912645 UDK_3.5
        UDK_3.4
8 0x00 0x09912646 UDK_3.6
        UDK_3.5
9 0x00 0x09912647 UDK_3.7
        UDK_3.6
10 0x00 0x06e04eb0 PRIVATE_1.0
11 0x00 0x06e04eb1 PRIVATE_1.1
        PRIVATE_1.0

Version References:
  required from libcrypt.so.1:
    0x0d696910 0x00 29 GLIBC_2.0
  required from libgcc_s.so.1:
    0x0b792650 0x00 30 GCC_3.0
    0x0d696910 0x00 27 GLIBC_2.0
  required from libdl.so.2:
    0x0d696911 0x00 28 GLIBC_2.1
    0x0d696910 0x00 24 GLIBC_2.0
  required from libm.so.6:
    0x0d696910 0x00 22 GLIBC_2.0
  required from libstdc++.so.6:
    0x056bafd3 0x00 19 CXXABI_1.3
    0x08922974 0x00 14 GLIBCXX_3.4
  required from libpthread.so.0:
    0x0d696912 0x00 23 GLIBC_2.2
    0x09691973 0x00 20 GLIBC_2.3.3
    0x0d696911 0x00 18 GLIBC_2.1
    0x09691972 0x00 15 GLIBC_2.3.2
    0x0d696910 0x00 13 GLIBC_2.0
  required from libc.so.6:
    0x0d696913 0x00 26 GLIBC_2.3
    0x09691f72 0x00 25 GLIBC_2.1.2
    0x0d696912 0x00 21 GLIBC_2.2
    0x09691f73 0x00 17 GLIBC_2.1.3
    0x0d696911 0x00 16 GLIBC_2.1
    0x0d696910 0x00 12 GLIBC_2.0

Sections:
Idx Name          Size      VMA       LMA       File off  Algn
  0 .gnu.hash     00001a60  4c03c114  4c03c114  00000114  2**2
                  CONTENTS, ALLOC, LOAD, READONLY, DATA
  1 .dynsym       00002e50  4c03db74  4c03db74  00001b74  2**2
                  CONTENTS, ALLOC, LOAD, READONLY, DATA
  2 .dynstr       000039db  4c0409c4  4c0409c4  000049c4  2**0
                  CONTENTS, ALLOC, LOAD, READONLY, DATA
  3 .gnu.version  000005ca  4c0443a0  4c0443a0  000083a0  2**1
                  CONTENTS, ALLOC, LOAD, READONLY, DATA
  4 .gnu.version_d 00000174  4c04496c  4c04496c  0000896c  2**2
                  CONTENTS, ALLOC, LOAD, READONLY, DATA
  5 .gnu.version_r 000001a0  4c044ae0  4c044ae0  00008ae0  2**2
                  CONTENTS, ALLOC, LOAD, READONLY, DATA
  6 .rel.dyn      0000d974  4c044c80  4c044c80  00008c80  2**2
                  CONTENTS, ALLOC, LOAD, READONLY, DATA
  7 .rel.plt      00000618  4c0525f4  4c0525f4  000165f4  2**2
                  CONTENTS, ALLOC, LOAD, READONLY, DATA
  8 .init         00000017  4c052c10  4c052c10  00016c10  2**2
                  CONTENTS, ALLOC, LOAD, READONLY, CODE
  9 .plt          00000c40  4c052c28  4c052c28  00016c28  2**2
                  CONTENTS, ALLOC, LOAD, READONLY, CODE
 10 .text         0002cf94  4c053870  4c053870  00017870  2**4
                  CONTENTS, ALLOC, LOAD, READONLY, CODE
 11 .fini         0000001c  4c080804  4c080804  00044804  2**2
                  CONTENTS, ALLOC, LOAD, READONLY, CODE
 12 .rodata       0015e698  4c080820  4c080820  00044820  2**3
                  CONTENTS, ALLOC, LOAD, READONLY, DATA
 13 .eh_frame_hdr 00000464  4c1deeb8  4c1deeb8  001a2eb8  2**2
                  CONTENTS, ALLOC, LOAD, READONLY, DATA
 14 .eh_frame     000017ac  4c1df31c  4c1df31c  001a331c  2**2
                  CONTENTS, ALLOC, LOAD, READONLY, DATA
 15 .gcc_except_table 000004a4  4c1e0ac8  4c1e0ac8  001a4ac8  2**2
                  CONTENTS, ALLOC, LOAD, READONLY, DATA
 16 .ctors        00000020  4c1e1e24  4c1e1e24  001a5e24  2**2
                  CONTENTS, ALLOC, LOAD, DATA
 17 .dtors        00000010  4c1e1e44  4c1e1e44  001a5e44  2**2
                  CONTENTS, ALLOC, LOAD, DATA
 18 .jcr          00000004  4c1e1e54  4c1e1e54  001a5e54  2**2
                  CONTENTS, ALLOC, LOAD, DATA
 19 .data.rel.ro  000118a4  4c1e1e58  4c1e1e58  001a5e58  2**2
                  CONTENTS, ALLOC, LOAD, DATA
 20 .dynamic      00000118  4c1f36fc  4c1f36fc  001b76fc  2**2
                  CONTENTS, ALLOC, LOAD, DATA
 21 .got          00000060  4c1f3814  4c1f3814  001b7814  2**2
                  CONTENTS, ALLOC, LOAD, DATA
 22 .got.plt      00000318  4c1f3874  4c1f3874  001b7874  2**2
                  CONTENTS, ALLOC, LOAD, DATA
 23 .data         00000348  4c1f3b8c  4c1f3b8c  001b7b8c  2**2
                  CONTENTS, ALLOC, LOAD, DATA
 24 .bss          00001e44  4c1f3ed8  4c1f3ed8  001b7ed4  2**3
                  ALLOC
 25 .comment      00000c78  00000000  00000000  001b7ed4  2**0
                  CONTENTS, READONLY
 26 .gnu_debuglink 0000001c  00000000  00000000  001b8b4c  2**0
                  CONTENTS, READONLY
 27 .gnu.liblist  000000a0  00000000  00000000  001b8b68  2**2
                  CONTENTS, READONLY
 28 .gnu.libstr   0000006e  00000000  00000000  001b8c08  2**0
                  CONTENTS, READONLY
 29 .gnu.prelink_undo 00000574  00000000  00000000  001b8c78  2**2
                  CONTENTS, READONLY
SYMBOL TABLE:
no symbols

You can see, that only UDK_3.7 is defined and that is probably the cause of failure. Now how to fix this ?

Reproducible: Always




thermal@idaho ~ $ paludis --info
paludis 0.30.3
Paludis build information:
    Compiler:
        CXX:                   i686-pc-linux-gnu-g++ 4.3.2
        CXXFLAGS:              -O2 -march=pentium-m -pipe -ggdb
        LDFLAGS:               -Wl,--as-needed -Wl,-O1
        DATE:                  2008-10-25T14:23:52+0200

    Libraries:
        C++ Library:           GNU libstdc++ 20080827

    Reduced Privs:
        reduced_uid:           1000
        reduced_uid->name:     thermal
        reduced_uid->dir:      /home/thermal
        reduced_gid:           1000
        reduced_gid->name:     thermal

    Paths:
        DATADIR:               /usr/share
        LIBDIR:                /usr/lib
        LIBEXECDIR:            /usr/libexec
        SYSCONFDIR:            /etc
        PYTHONINSTALLDIR:      /usr/lib/python2.5/site-packages
        RUBYINSTALLDIR:

Environment:
    Format:                    paludis
    Config dir:                /etc/paludis
    World file:                /var/lib/portage/world

Repository installed-virtuals:
    format:                    installed_virtuals
    root:                      /

Repository virtuals:
    format:                    virtuals

Repository gentoo:
    format:                    ebuild
    location:                  /usr/portage-ro-new-version
    append_repository_name_to_write_cache: true
    binary_destination:        false
    binary_keywords:
    binary_uri_prefix:
    builddir:                  /var/tmp/paludis
    cache:                     /usr/portage/metadata/cache
    distdir:                   /usr/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /usr/portage/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    names_cache:               /var/empty
    newsdir:                   /usr/portage-ro-new-version/metadata/news
    profile_eapi:              0
    profiles:                  /usr/portage/profiles/default-linux/x86/2007.0/desktop
    securitydir:               /usr/portage-ro-new-version/metadata/glsa
    setsdir:                   /usr/portage/sets
    sync:                      rsync://rsync.gentoo.org/gentoo-portage
    sync_options:
    use_manifest:              use
    write_cache:               /var/empty

    Package information:
        app-admin/eselect-compiler: (none)
        app-shells/bash:       3.2_p39
        dev-java/java-config:  1.3.7 2.1.6-r1
        dev-lang/python:       2.5.2-r8
        dev-python/pycrypto:   (none)
        dev-util/ccache:       (none)
        dev-util/cmake:        2.6.2
        dev-util/confcache:    (none)
        sys-apps/baselayout:   2.0.0
        sys-apps/openrc:       0.3.0-r1
        sys-apps/sandbox:      1.2.18.1-r3
        sys-devel/autoconf:    2.13 2.63
        sys-devel/automake:    1.10.1-r1 1.4_p6 1.5 1.7.9-r1 1.8.5-r3 1.9.6-r2
        sys-devel/binutils:    2.18-r4
        sys-devel/gcc-config:  1.4.0-r4
        sys-devel/libtool:     2.2.6a
        virtual/os-headers:    2.6.27 (for sys-kernel/linux-headers::installed)

thermal@idaho ~ $ cat /etc/paludis/use.conf
# Notes:
# We don`t need tetex, using texlive instead
*/* -gnome -arts -eds -kerberos samba -esd -oss mmx sse sse2 -gpm -gstreamer syslog automount mailwrapper -fam gnutls idn -ldap ftp nfs a52 aac dv tga theora x264 xvid xvmc real speex jpeg2k flac exif tta nsplugin rtc caps quotas threads bash-completion vim-syntax kdehiddenvisibility visibility usb wifi bluetooth irda pcmcia xcomposite xinerama bzip2 lzo rar paludis curl -tetex dia jabber wmf ntp startup-notification -java ssh consolekit jce qt4 xcb xattr

# Needed for texlive
*/* kpathsea

# KDE 4
*/* kdeprefix inotify log

# Why do we need X for ?
app-text/texlive -X

*/* PALUDIS_HOOKS: eselect

*/* CAMERAS: -* ptp2 panasonic minolta samsung sonydscfl sonydscf55 fuji canon casio ricoh toshiba spca50x

*/* INPUT_DEVICES: -* evdev synaptics mouse keyboard

*/* LCD_DEVICES: -* hd44780 ncurses

*/* LINGUAS: -* pl

*/* VIDEO_CARDS: -* vesa radeon

sys-apps/paludis glsa qa

# Disable firefox because it tries to downgrade us
app-office/openoffice -java -firefox

# We are a dell laptop, so ...
sys-apps/hal laptop dell disk-partition acpi

net-im/psi extras

# RDesktop is quite essential to connect to windoze
kde-base/krdc rdesktop

# GUI ? Not needed for nmap
net-analyzer/nmap -gtk

# We don`t need transcode just for k3b ...
app-cdr/k3b -encode
Comment 1 YLD 2008-11-05 03:56:46 UTC
(In reply to comment #0)
The same errors here on AMD64. Can't run any tested Openoffice component.

Openoffice compiled with "cups dbus -debug eds gnome gstreamer gtk java kde ldap -mono nsplugin -odk opengl pam" flags.
Comment 2 YLD 2008-11-05 03:58:39 UTC
Created attachment 170766 [details]
paludis --info
Comment 3 YLD 2008-11-05 04:02:32 UTC
Created attachment 170767 [details]
Paludis use.conf file
Comment 4 Maciej Grela 2008-11-05 17:00:33 UTC
(In reply to comment #1)
> (In reply to comment #0)
> The same errors here on AMD64. Can't run any tested Openoffice component.
> 
> Openoffice compiled with "cups dbus -debug eds gnome gstreamer gtk java kde
> ldap -mono nsplugin -odk opengl pam" flags.
> 

I forgot to mention, I`m also using AMD64. Is is an arch specific issue ?
Comment 5 David Tardon 2008-12-22 15:29:23 UTC
There should be no /usr/lib/openoffice/program/libuno_sal.so.3--that library resides in /usr/lib/openoffice/ure/lib/ in OOo 3. It's most probably a left-over of older version.
Comment 6 David Tardon 2008-12-22 15:30:54 UTC
Created attachment 176156 [details]
objdump -p /usr/lib/openoffice/ure/lib/libuno_sal.so.3
Comment 7 YLD 2008-12-23 00:58:08 UTC
You're right.

I first uninstalled openoffice, then removed the remaining /usr/lib64/openoffice dir.

After reinstalling, Openoffice runs perfetly well, thanks a lot.

I don't know how and why this files where still there.

(In reply to comment #5)
> There should be no /usr/lib/openoffice/program/libuno_sal.so.3--that library
> resides in /usr/lib/openoffice/ure/lib/ in OOo 3. It's most probably a
> left-over of older version.
> 

Comment 8 Maciej Grela 2008-12-29 08:35:41 UTC
(In reply to comment #7)
> You're right.
> 
> I first uninstalled openoffice, then removed the remaining
> /usr/lib64/openoffice dir.
> 
> After reinstalling, Openoffice runs perfetly well, thanks a lot.
> 
> I don't know how and why this files where still there.
> 
> (In reply to comment #5)
> > There should be no /usr/lib/openoffice/program/libuno_sal.so.3--that library
> > resides in /usr/lib/openoffice/ure/lib/ in OOo 3. It's most probably a
> > left-over of older version.
> > 
> 

Removing the old openoffice-bin-2.4.1 package also fixed the problem for me. I think we can close.