Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 244430 - net-im/ekiga-2.0.12: gconf-related sandbox access violation
Summary: net-im/ekiga-2.0.12: gconf-related sandbox access violation
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: voip herd (OBSOLETE)
URL:
Whiteboard:
Keywords:
: 244432 (view as bug list)
Depends on:
Blocks: 243288
  Show dependency tree
 
Reported: 2008-10-26 09:45 UTC by Mathieu Z
Modified: 2008-11-09 01:22 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (ekiga-2.0.12.log,258.08 KB, text/plain)
2008-10-26 09:51 UTC, Mathieu Z
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu Z 2008-10-26 09:45:42 UTC
Failed to emerge with error:

...
 /usr/bin/install -c -m 644 'net.ekiga.instance.service' '/var/tmp/portage/net-im/ekiga-2.0.12/image//usr/share/dbus-1/services/net.ekiga.instance.service'
  /usr/bin/install -c -m 644 'net.ekiga.helper.service' '/var/tmp/portage/net-im/ekiga-2.0.12/image//usr/share/dbus-1/services/net.ekiga.helper.service'
  gconftool-2 --shutdown
  ACCESS DENIED  open_wr:   /root/.gconf/.testing.writeability
  ACCESS DENIED  unlink:    /root/.gconf/.testing.writeability

  (gconftool-2:24112): GConf-WARNING **: None of the resolved addresses are writable; saving configuration settings will not be possible
  make[2]: Leaving directory `/var/tmp/portage/net-im/ekiga-2.0.12/work/ekiga-2.0.12'
  make[1]: Leaving directory `/var/tmp/portage/net-im/ekiga-2.0.12/work/ekiga-2.0.12'
  >>> Completed installing ekiga-2.0.12 into /var/tmp/portage/net-im/ekiga-2.0.12/image/

  --------------------------- ACCESS VIOLATION SUMMARY ---------------------------
  LOG FILE = "/var/log/sandbox/sandbox-22903.log"

  open_wr:   /root/.gconf/.testing.writeability
  unlink:    /root/.gconf/.testing.writeability
  --------------------------------------------------------------------------------



Reproducible: Always

Steps to Reproduce:
1. emerge ekiga
2.
3.




$ emerge --info
Portage 2.2_rc12 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.26-gentoo-r1 i686)
=================================================================
System uname: Linux-2.6.26-gentoo-r1-i686-AMD_Athlon-tm-_XP_3000+-with-glibc2.0
Timestamp of tree: Fri, 24 Oct 2008 20:45:02 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en ja zh zh_CN zh_TW"
MAKEOPTS="-j2"
PKGDIR="/usr/portage//packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage/"
PORTDIR_OVERLAY="/usr/local/portage/layman/initng /usr/local/portage/layman/sunrise /usr/local/portage/layman/gentoo-taiwan /usr/local/portage/layman/gentoo-china /usr/local/portage/layman/science /usr/local/portage/layman/desktop-effects /usr/local/portage/layman/arcon-portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="3dnow X aac aalib acl acpi aim alsa apache2 audiofile avahi bash-completion bcmath berkdb blas bluetooth bzip2 cairo calendar cdb cdinstall cdparanoia cdr chasen cjk clamav cli cpudetection cracklib crypt cscope ctype cups curl curlwrapper dba dbus dbx dga dio directfb dri dts dv dvb dvd dvdr dvdread eds emacs emacs-w3 encode esd exif expat fam fastcgi fbcon ffmpeg fftw firefox flac flash foomaticdb fortran freetdsfreewnn ftp fuse gb gcj gd gdbm gif ginac glut gnome gnustep gnutls gphoto2 gpm gps gstreamer gtk gtkhtml hal howl httpd icc iconv icq idn ieee1394 imagemagick imap imlib immqt-bc innodb ipv6 isdnlog jabber jack java java5 javascript jikes joystick jpeg jpeg2k kde kdexdeltas kerberos krb4 lash latex lcms ldap lemi lesstif libcaca libedit libgda libnotify lyx m17n-lib mad midi mime ming mmx mmxext mng modplug motif mozdevelop mp3 mp4 mpeg mpi mplayer msn msql mssql mudflap mule musepack musicbrainz mysql mysqli ncurses neXt netboot nforce2 nis nls nptl nptlonly nsplugin odbc ofx ogg oggvorbis openal openexr opengl openmp osc oscar pam pcre pda pdf perl php plotutils png portaudio posix postgres ppds pppd python qt3 qt4 quicktime readline real recode reflection ruby samba scanner sdl session simplexml slang sndfile socket5 sockets speex spell spl sse sse2 ssl stream svg svga sysfs szip tcl tcltk tcpd theora threads tidy tiff timidity tk tokenizer truetype unicode upnp usb v4l v4l2 vcd vhosts videos vim-syntax vorbis wddx wifi win32codecs wma wmf wmp wxwindows x86 xcb xcomposite xforms xine xinerama xml xml2 xmlrpc xorg xosd xsl xulrunner xv xvid yahoo yaz zip zlib" ALSA_CARDS="intel8x0 intel8x0m" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache charset_lite dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" ELIBC="glibc" INPUT_DEVICES="evdev joystick keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ja zh zh_CN zh_TW" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Mathieu Z 2008-10-26 09:51:03 UTC
Created attachment 169915 [details]
build log
Comment 2 Mathieu Z 2008-10-26 10:02:17 UTC
*** Bug 244432 has been marked as a duplicate of this bug. ***
Comment 3 John Youells 2008-10-26 14:55:12 UTC
I've been having the same problem since ekiga 2.0.12 hit the tree.

emerge --info 

Portage 2.2_rc12 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r4 i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r4-i686-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4400+-with-glibc2.0
Timestamp of tree: Sun, 26 Oct 2008 14:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r4
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -msse2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=athlon-xp -O2 -msse2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="autoaddcvs ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/nouveau /usr/local/portage/dev-lang /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa arts asf avahi berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus divx4linux dri dts dvd dvdr dvdread eds emboss encode esd evo fam firefox flac foomaticdb fortran gdbm gif glitz gnome gpm gstreamer gtk gtk2 hal iconv ipv6 isdnlog java jpeg kde kerberos ldap libnotify live mad matrox midi mikmod mmx mmxext mng mp3 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcre pdf perl pic png ppds pppd prebuilt python qt3 qt3support qt4 quicktime radeon readline real reflection rtc samba sdk sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcltk tcpd theora tiff tk truetype unicode usb vcd vorbis win32codecs wma wmfreal x86 xcomposite xml xorg xv xvid xvmc zlib" ALSA_CARDS="ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="radeon r200"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 4 Srinivasan R 2008-10-27 18:02:57 UTC
I too can't proceed with emerging gnome because of this bug. 

Here is my emerge --info

Portage 2.2_rc12 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r8 i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r8-i686-AMD_Turion-tm-_64_X2_Mobile_Technology_TL-52-with-glibc2.0
Timestamp of tree: Mon, 27 Oct 2008 17:04:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-lang/python:     2.4.4-r13, 2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r4
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="C"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo fam firefox fortran gdbm gif gnome gpm gstreamer gtk hal iconv ipv6 isdnlog jpeg kde kerberos ldap libnotify mad midi mikmod mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis win32codecs x86 xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

Comment 5 John Youells 2008-10-27 19:13:15 UTC
Ekiga will compile if 'USE="-gnome" emerge ekiga' so that the build includes the not-gnome patch: 
Index: ekiga-2.0.11/lib/gmconf/gmconf-glib.c
===================================================================
--- ekiga-2.0.11.orig/lib/gmconf/gmconf-glib.c
+++ ekiga-2.0.11/lib/gmconf/gmconf-glib.c
@@ -1473,7 +1473,7 @@ gm_conf_destroy (const gchar *namespac)
 }
 
 gboolean 
-gm_conf_is_key_writable (gchar *key)
+gm_conf_is_key_writable (const gchar *key)
 {
   g_return_val_if_fail (key != NULL, FALSE);
  

With USE="-gnome" the build doesn't try to write to the .gconf directory in /root

Comment 6 Srinivasan R 2008-10-27 19:50:43 UTC
(In reply to comment #5)
> With USE="-gnome" the build doesn't try to write to the .gconf directory in
> /root
> 

Great. Works perfectly. Thanks.
Comment 7 John Youells 2008-10-27 22:23:36 UTC
(In reply to comment #5)
> Ekiga will compile if 'USE="-gnome" emerge ekiga' so that the build includes
> the not-gnome patch: 
> Index: ekiga-2.0.11/lib/gmconf/gmconf-glib.c
> ===================================================================
> --- ekiga-2.0.11.orig/lib/gmconf/gmconf-glib.c
> +++ ekiga-2.0.11/lib/gmconf/gmconf-glib.c
> @@ -1473,7 +1473,7 @@ gm_conf_destroy (const gchar *namespac)
>  }
> 
>  gboolean 
> -gm_conf_is_key_writable (gchar *key)
> +gm_conf_is_key_writable (const gchar *key)
>  {
>    g_return_val_if_fail (key != NULL, FALSE);
> 
> 
> With USE="-gnome" the build doesn't try to write to the .gconf directory in
> /root
> 

I don't think that's the right fix but it seems to get it installed
The schemas can be installed latter from the command line, if I'm reading earlier reports of similar bugs with ekiga correctly.


Comment 8 Gilles Dartiguelongue gentoo-dev 2008-11-09 01:22:47 UTC
fixed without a bump.