Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 243628 - app-misc/cw: CC variable not respected
Summary: app-misc/cw: CC variable not respected
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Shell Tools Herd Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2008-10-24 00:34 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-04-10 03:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
cw-1.0.15.ebuild patch (cw-1.0.15.ebuild.patch,574 bytes, patch)
2009-04-07 09:16 UTC, Timothy Redaelli (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-10-24 00:34:38 UTC
I'm filing this bug (from a template, mind you) because the ebuild I'm reporting it against failed to build once I removed my /usr/bin/{gcc,cc,c++,c99} binaries. This means that the ebuild is relying on gcc or cc as compiler, while it should use "$(tc-getCC)" so that user choices are respected, and cross-compiling works as intended.

This usually comes down to one of these tasks:

- use emake CC="$(tc-getCC)" for building, to ovewrite make's CC variable (defaults to "cc", some upstream rewrites it);
- the above plus replacing explicit "gcc" (or similar) calls with $(CC) so that the variable is actually respected;
- tc-export CC in src_compile before eventual econf.

For C++, you'd have to replace CC with CXX everywhere above, of course.

If your package is a special case on this, please let me know.

Thanks,
Diego
Comment 1 bob5972 2009-04-05 19:14:47 UTC
It seems to work fine for me.

If I remove all the gcc's in my path (/usr/bin/gcc and /usr/i686-pc-linux-gnu/gcc-bin/4.3.3/gcc ) and then set CC="/usr/bin/i686-pc-linux-gnu-gcc-4.1.2" then it builds fine, and uses that compiler.
Comment 2 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-07 03:03:23 UTC
(In reply to comment #1)
> It seems to work fine for me.
> 
> If I remove all the gcc's in my path (/usr/bin/gcc and
> /usr/i686-pc-linux-gnu/gcc-bin/4.3.3/gcc ) and then set
> CC="/usr/bin/i686-pc-linux-gnu-gcc-4.1.2" then it builds fine, and uses that
> compiler.
> 

Thanks. I also want to note that before configure: 

%% grep CC Makefile.in 
CC=@CC@

after configure:

%% grep CC Makefile
CC=gcc

So, I think this bug is an error too.

Comment 3 Timothy Redaelli (RETIRED) gentoo-dev 2009-04-07 09:16:31 UTC
Please don't close the bugs without verify it!
Comment 4 Timothy Redaelli (RETIRED) gentoo-dev 2009-04-07 09:16:47 UTC
Created attachment 187541 [details, diff]
cw-1.0.15.ebuild patch
Comment 5 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-10 03:43:13 UTC
(In reply to comment #3)
> Please don't close the bugs without verify it!
> 

sry, didn't understand it.

thx for the patch. fixed...no bump