Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 243368 - gnome-base/libgnomeui doesn't build due to missing installation of gtkfilesystem.h from >gtk+-2.12
Summary: gnome-base/libgnomeui doesn't build due to missing installation of gtkfilesys...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 245926 246075 (view as bug list)
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-10-23 11:50 UTC by Justin Lecher
Modified: 2009-02-16 00:43 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/gnome-base/libgnomeui-2.22.1/temp/build.log (build.log,245.56 KB, text/plain)
2008-10-23 11:51 UTC, Justin Lecher
Details
emerge.info (emerge.info,16.19 KB, text/plain)
2008-10-23 11:51 UTC, Justin Lecher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Lecher gentoo-dev 2008-10-23 11:50:37 UTC
When trying to build gnome-base/libgnomeui following error ocurs

 gtkfilesystemgnomevfs.lo -MD -MP -MF .deps/gtkfilesystemgnomevfs.Tpo -c gtkfilesystemgnomevfs.c  -fPIC -DPIC -o .libs/gtkfilesystemgnomevfs.o
In file included from gtkfilesystemgnomevfs.c:40:
gtkfilesystemgnomevfs.h:26:31: error: gtk/gtkfilesystem.h: No such file or directory
In file included from gtkfilesystemgnomevfs.c:40:
gtkfilesystemgnomevfs.h:37: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
gtkfilesystemgnomevfs.c:179: error: expected specifier-qualifier-list before ‘GtkFileInfoType’
gtkfilesystemgnomevfs.c:215: error: expected ‘)’ before ‘*’ token


<SNIP>

<SNAP>

gtkfilesystemgio.c:1648: error: expected ‘)’ before ‘*’ token
gtkfilesystemgio.c:1697: error: expected ‘)’ before ‘*’ token
gtkfilesystemgio.c:1745: error: expected ‘)’ before ‘*’ token
gtkfilesystemgio.c:1765: error: expected ‘)’ before ‘*’ token
gtkfilesystemgio.c:1794: error: expected ‘)’ before ‘*’ token
gtkfilesystemgio.c:1840: error: expected ‘)’ before ‘*’ token
gtkfilesystemgio.c:1877: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
gtkfilesystemgio.c:1908: error: expected ‘)’ before ‘*’ token
gtkfilesystemgio.c:1927: error: expected ‘)’ before ‘*’ token
gtkfilesystemgio.c:1937: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
gtkfilesystemgio.c:1958: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
make[2]: *** [gtkfilesystemgio.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-base/libgnomeui-2.22.1/work/libgnomeui-2.22.1/file-chooser'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/libgnomeui-2.22.1/work/libgnomeui-2.22.1'
make: *** [all] Error 2
 * 
 * ERROR: gnome-base/libgnomeui-2.22.1 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_compile
 * environment, line 2667:  Called gnome2_src_compile
 * environment, line 2058:  Called die
 * The specific snippet of code:
 * emake || die "compile failure"

This results out of missing gtk/gtkfilesystem.h, which isn't install from gtk+. As far as I found out this belongs to >gtk+-2.12.
Comment 1 Justin Lecher gentoo-dev 2008-10-23 11:51:24 UTC
Created attachment 169558 [details]
/var/tmp/portage/gnome-base/libgnomeui-2.22.1/temp/build.log

build.log
Comment 2 Justin Lecher gentoo-dev 2008-10-23 11:51:57 UTC
Created attachment 169560 [details]
emerge.info

emerge.info
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-10-23 19:43:20 UTC
the ebuilds specify that you need gtk+-2.11.5 minimum, the closest revision in portage is 2.12.8, what version do you have ?
Comment 4 Justin Lecher gentoo-dev 2008-10-24 07:14:37 UTC
I need >=x11-libs/gtk+-2.14.0 as a dep of gegl. The current installed version is x11-libs/gtk+-2.14.4, but the issue occur with every version >2.14.
Comment 5 Mart Raudsepp gentoo-dev 2008-10-24 08:14:53 UTC
If you mix stable and testing and have gtk+-2.14 locally keyworded in /etc/portage/package.keywords, you need to have libgnomeui-2.24.* there as well.
We can't do anything about that, this is by design for moving the filesystem stuff completely into GIO/gtk+ - gtk+ itself now provides what libgnomeui-2.22 did (remote VFS support backend for gtkfilechooser), and libgnomeui-2.24 simply doesn't ship that component anymore as gtk+-2.14 takes care of it.
Comment 6 Justin Lecher gentoo-dev 2008-10-27 09:38:56 UTC
You could set an DEPEND="<x11-libs/gtk+-2.x" in gnome-base/libgnomeui-2.22.1, so that one runs in the position I am not knowing whats going on. I will unmask libgnomeui. Thnaks for help,
Close the BUG with the resolution you think.
Comment 7 Mart Raudsepp gentoo-dev 2008-10-27 10:40:02 UTC
I'm afraid such a blocker could cause migration pain, though might be worth investigating
Comment 8 Rémi Cardona gentoo-dev 2008-11-07 07:27:51 UTC
*** Bug 245926 has been marked as a duplicate of this bug. ***
Comment 9 Gilles Dartiguelongue gentoo-dev 2008-11-08 23:36:18 UTC
*** Bug 246075 has been marked as a duplicate of this bug. ***
Comment 10 Marco Squarcina 2009-02-16 00:43:05 UTC
As requested by Diego, I'm CCing him