Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 243152 - media-video/totem-2.24.2 fails to compile can't open codegen.py
Summary: media-video/totem-2.24.2 fails to compile can't open codegen.py
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-10-21 22:31 UTC by Mike Weissman
Modified: 2011-03-15 14:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Weissman 2008-10-21 22:31:44 UTC
When attempting to compile media-video/totem-2.24.2 build fails on:

Making all in python
make[3]: Entering directory `/var/tmp/portage/media-video/totem-2.24.2/work/totem-2.24                   .2/bindings/python'
( cd . && /usr/bin/python /usr/lib/python2.5/site-packages/gtk-2.0/codegen/codegen.py                    \
                --register /usr/share/pygtk/2.0/defs/gtk-types.defs \
                --override totem.override \
                --prefix pytotem totem.defs ) > totem.c
/usr/bin/python: can't open file '/usr/lib/python2.5/site-packages/gtk-2.0/codegen/codegen.py': [Errno 2] No such file or directory
make[3]: *** [totem.c] Error 2
make[3]: Leaving directory `/var/tmp/portage/media-video/totem-2.24.2/work/totem-2.24.2/bindings/python'

i have tried re-compiling dev-python/pygobject, but still spawned the same error.

The configure script seems to find it just fine:

checking for pygtk codegen... /usr/bin/python /usr/lib/python2.5/site-packages/gtk-2.0/codegen/codegen.py





Reproducible: Always

Steps to Reproduce:
1.emerge =media-video/totem-2.24.2
2.
3.




Portage 2.2_rc12 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.24-gentoo-r8 i686)
=================================================================
System uname: Linux-2.6.24-gentoo-r8-i686-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-glibc2.0
Timestamp of tree: Tue, 21 Oct 2008 13:34:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r13, 2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2  -pipe -fomit-frame-pointer -g -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer -g -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-v --with-bdeps=y"
FEATURES="ccache collision-protect distlocks metadata-transfer nostrip parallel-fetch preserve-libs protect-owned sandbox sfperms strict test unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ "
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/mike/myebuilds"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa apache2 avi bash-completion bluetooth branding bzip2 cairo cdr cli compat cracklib crypt cups dbcpalsa dbus dri dvd dvdr dvdread emboss encode evo fam firefox firfox ftp gd gdbm gif gnome gpm gstreamer gtk hal hddtemp iconv intel isdnlog java java5 java6 javamail jbdc jboss jpeg ldap libnotify libwww logitech mad mailwrapper midi mikmod mp3 mpeg mudflap mysql ncurses nls nptl nptlonly ntp nvidia odbc ogg opengl openmp pam pcre pdf perl png postgres ppds pppd python qt3support quicktime rar readline reflection sdl session spell spl ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vim vim-completion vim-syntax vim-with-x vorbis win32codecs x86 xml xorg xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="proxy_http actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias proxy" APACHE2_MPMS="prefork" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Mike Auty gentoo-dev 2008-10-21 23:29:26 UTC
Hmmm, I haven't been able to recreate this, so it looks like something unusual in your setup.

Could you please check the file permissions on the file (paste the output of "ls -la /usr/lib/python2.5/site-packages/gtk-2.0/codegen/codegen.py") and also please check that it still exists after the installation has failed (the same command again, right after the failure)?  Thanks...  5:)
Comment 2 Mike Weissman 2008-10-22 15:34:50 UTC
(In reply to comment #1)
Interestingly enough:

# ls -la /usr/lib/python2.5/site-packages/gtk-2.0/codegen/codegen.py
ls: cannot access /usr/lib/python2.5/site-packages/gtk-2.0/codegen/codegen.py: No such file or directory

# qfile codegen.py
dev-python/pygobject (/usr/share/pygobject/2.0/codegen/codegen.py)

# ls -la /usr/share/pygobject/2.0/codegen/codegen.py
-rw-r--r-- 1 root root 69400 Oct 22 11:10 /usr/share/pygobject/2.0/codegen/codegen.py


Shouldn't the configure script die, because it can't find 'codegen.py'? 

        AC_MSG_CHECKING([for pygtk codegen])
        PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
    AC_MSG_RESULT([$PYGTK_CODEGEN])

Let me know if you need any other info,

-Mike
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-10-22 20:56:43 UTC
could you also list the versions of pygtk/pygobject
Comment 4 Mike Weissman 2008-10-22 21:04:31 UTC
(In reply to comment #3)
> could you also list the versions of pygtk/pygobject
> 

[ebuild   R   ] dev-python/pygobject-2.15.4  USE="X -debug -doc -examples -libffi" 0 kB
[ebuild   R   ] dev-python/pygtk-2.13.0  USE="X -doc -examples" 0 kB 

-Mike
Comment 5 Gilles Dartiguelongue gentoo-dev 2008-10-22 21:17:27 UTC
Here is your problem, it should be elsewhere.

$ qfile codegen.py
dev-python/pygobject (/usr/lib64/python2.5/site-packages/gtk-2.0/codegen/codegen.py)

do you ever merged pygobject from another overlay or before it enters the tree ?
could you try re-emerging it and see if codegen.py ends up in the right folder ?
Comment 6 Mike Weissman 2008-10-22 21:38:42 UTC
(In reply to comment #5)
> Here is your problem, it should be elsewhere.
> 
> $ qfile codegen.py
> dev-python/pygobject
> (/usr/lib64/python2.5/site-packages/gtk-2.0/codegen/codegen.py)
> 
> do you ever merged pygobject from another overlay or before it enters the tree
> ?
> could you try re-emerging it and see if codegen.py ends up in the right folder
> ?
> 
Ah crap, you are right, i just noticed i was missing the codegen patch for pygobject.

re-merging with the patch, fixes this issue.  Sorry for the trouble. 
Comment 7 Gilles Dartiguelongue gentoo-dev 2008-10-22 21:44:27 UTC
no problem
Comment 8 Johannes Ruthmair 2011-03-15 14:21:34 UTC
same problem here during istallation/upgrade of dev-python/libgnomeprint-python-2.32.0 with a missing codegen.py . Cant reproduce the problem (why codegen.py wasnt instlled, because i never used any python ebuild except the offical) but solved it with reemerging dev-python/pygobject-2.26.0-r1 .