Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 243000 - media-sound/beast-0.7.1-r1 collision with media-gfx/nip2-7.14.4
Summary: media-sound/beast-0.7.1-r1 collision with media-gfx/nip2-7.14.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-21 06:38 UTC by Joost Ruis
Modified: 2008-11-02 14:59 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joost Ruis 2008-10-21 06:38:10 UTC
* package media-sound/beast-0.7.1-r1 NOT merged
 *
 * Detected file collision(s):
 *
 *  /usr/share/mime/generic-icons
 *  /usr/share/mime/treemagic
 *  /usr/share/mime/globs2
 *  /usr/share/mime/types
 *  /usr/share/mime/icons
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * media-gfx/nip2-7.14.4
 *  /usr/share/mime/generic-icons
 *  /usr/share/mime/globs2
 *  /usr/share/mime/icons
 *  /usr/share/mime/treemagic
 *  /usr/share/mime/types
 *
 * Package 'media-sound/beast-0.7.1-r1' NOT merged due to file
 * collisions. If necessary, refer to your elog messages for the whole
 * content of the above message.



Reproducible: Always
Comment 1 Mike Auty (RETIRED) gentoo-dev 2008-10-21 09:17:31 UTC
Hmmm, thanks for that.  I'm not sure either of those should be writing those files.  I think they're automatically generated after a mime update.  I've CCed the maintaining herds of both packages...
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-10-21 12:47:58 UTC
indeed, both should not touch these files, they are automatically generated.

Simplest solution: pass --disable-mime-update (or similar) or remove the files in src_install.
Comment 3 Markus Meier gentoo-dev 2008-10-25 12:12:06 UTC
media-gfx/nip2 is fixed in cvs, reassigning to sound herd and remove graphics herd.
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2008-11-02 14:59:45 UTC
+  02 Nov 2008; Peter Alfredsen <loki_val@gentoo.org>
+  +files/beast-0.7.1-gcc43.patch, beast-0.7.1-r1.ebuild:
+  Fix bug 240616 (gcc-4.3), thanks to Francisco José Cañizares Santofimia
+  <telefrancisco@gmail.com> and bug 243000 (update-mime-database collision).
+