Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 242868 - media-gfx/eog-2.24.0 fails to build with USE="doc"
Summary: media-gfx/eog-2.24.0 fails to build with USE="doc"
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-10-20 09:40 UTC by Helmut Jarausch
Modified: 2008-12-14 21:56 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log, environment (Logs.tar.bz2,31.80 KB, application/octet-stream)
2008-10-20 10:13 UTC, Helmut Jarausch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Jarausch 2008-10-20 09:40:19 UTC
emerging media-gfx/eog  (2.24.0)
fails with the following link error
# .libs/eog-scan.o: In function `main':
# eog-scan.c:(.text+0x23aa): undefined reference to `eog_exif_details_get_type'


Reproducible: Always
Comment 1 Mike Auty gentoo-dev 2008-10-20 09:46:11 UTC
Hi Helmut, please include the output of "emerge --info" and a more complete build failure log.  Thanks...  5:)
Comment 2 Helmut Jarausch 2008-10-20 10:13:46 UTC
Created attachment 169170 [details]
build log, environment
Comment 3 Helmut Jarausch 2008-10-20 10:16:38 UTC
emerge --info  gives

Portage 2.2_rc12 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.26-gentoo-r1 i686)
=================================================================
System uname: Linux-2.6.26-gentoo-r1-i686-Pentium_III_-Coppermine-with-glibc2.0
Timestamp of tree: Mon, 20 Oct 2008 05:45:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/NX/etc /usr/NX/home /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ "
LDFLAGS="-Wl,-O1"
LINGUAS="en de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.informatik.RWTH-Aachen.de/gentoo-portage"
USE="X acl alsa atm berkdb bzip2 cairo cdr cli cracklib crypt cups doc dri dvd fortran gdbm gif gimp gnome gpm gtk iconv ipv6 isdnlog jpeg kde lcms midi mmx mudflap ncurses nls nptl nptlonly opengl openmp pam pcre pdf perl png pppd python qt qt4 readline reflection session spl sqlite sqlite3 sse ssl svg sysfs tcl tcpd tetex tiff tk unicode x86 xorg xulrunner zlib" ALSA_CARDS="ens1371" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 4 Gilles Dartiguelongue gentoo-dev 2008-10-20 20:09:54 UTC
I built it without exif support fine here.


from your log :
ibglib-2.0.so -lpython2.5 -pthread
/usr/lib/python2.5/config/libpython2.5.a(posixmodule.o): In function `posix_tmpnam':
(.text+0x934): warning: the use of `tmpnam_r' is dangerous, better use `mkstemp'
/usr/lib/python2.5/config/libpython2.5.a(posixmodule.o): In function `posix_tempnam':
(.text+0xa44): warning: the use of `tempnam' is dangerous, better use `mkstemp'
.libs/eog-scan.o: In function `main':
eog-scan.c:(.text+0x23aa): undefined reference to `eog_exif_details_get_type'
collect2: ld returned 1 exit status
Linking of scanner failed: 
make[3]: *** [scan-build.stamp] Error 1
make[3]: Leaving directory `/var/tmp/portage/media-gfx/eog-2.24.0/work/eog-2.24.0/doc/reference'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-gfx/eog-2.24.0/work/eog-2.24.0/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-gfx/eog-2.24.0/work/eog-2.24.0'
make: *** [all] Error 2

Looks like you problem is due to USE="doc", could you disable it and try to build it again ?

Also please do not attach compressed logs, it makes it more painful for devs to review bugs.
Comment 5 Derk W te Bokkel 2008-10-22 13:30:08 UTC
I had this failure also.

But if doc and exif are selected it build fine. Looks like doc nad exif need to be selected together to deal with that call to exif ""eog-scan.c:(.text+0x23aa): undefined reference to `eog_exif_details_get_type' "" 
perhaps somewhere inside the doc build module?
Comment 6 Helmut Jarausch 2008-10-22 15:12:24 UTC
(In reply to comment #5)

Confirmed: If I use doc (standard here) and exif use flags, it builds
just fine.


Comment 7 Gilles Dartiguelongue gentoo-dev 2008-10-23 21:47:43 UTC
fixed in 2.24.1 bump. Please reopen if it's not the case.
Comment 8 Kirikaza 2008-11-22 13:18:19 UTC
(In reply to comment #7)
> fixed in 2.24.1 bump. Please reopen if it's not the case.

I don't know how to REOPEN a bug and I hope you'll get my answer.

media-gfx/eog-2.24.1 USE="dbus doc%* python -debug -exif -lcms -xmp%"
fails with the same link error, because the global flag "doc" is set in my make.conf.
Comment 9 Mart Raudsepp gentoo-dev 2008-11-28 01:29:57 UTC
(In reply to comment #7)
> fixed in 2.24.1 bump. Please reopen if it's not the case.

You are sed'ing Makefile, but that doesn't exist in src_unpack phase yet, so it just spits a line of error and doesn't change anything
Comment 10 Gilles Dartiguelongue gentoo-dev 2008-12-14 21:56:10 UTC
fixed properly this time (hopefully, if not, you know what to do :))