Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 242050 - dev-php5/ffmpeg-php-0.5.3 uses the old img_convert api from ffmpeg
Summary: dev-php5/ffmpeg-php-0.5.3 uses the old img_convert api from ffmpeg
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: PHP Bugs
URL:
Whiteboard:
Keywords:
: 242798 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-10-14 13:57 UTC by Alexis Ballier
Modified: 2008-12-11 20:35 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexis Ballier gentoo-dev 2008-10-14 13:57:11 UTC
It has been deprecated for a while and is removed when enabling swscaler in ffmpeg, it uses it uncoditionally and has been our ~arch for more than a year:

*ffmpeg-0.4.9_p20070616-r1 (26 Jun 2007)

  26 Jun 2007; Luca Barbato <lu_zero@gentoo.org>
  +ffmpeg-0.4.9_p20070616-r1.ebuild:
  Enable swscaler


with ffmpeg 0.4.9_p20081014 it is completely gone and causes build failures rather than runtime symbol lookup errors.
Comment 1 Christian Hoffmann (RETIRED) gentoo-dev 2008-10-14 15:09:12 UTC
Quoting upstream [1]:
"ffmpeg-php is not compatible with ffmpeg's swscaler. Enabling swscaler in ffmpeg disables the img_convert functions that ffmpeg-php needs to do its thing. Ffmpeg must be configured and compiled without the '--enable-swscale' flag."

I'll certainly won't try to fix that myself, I attempted a similar ->swscale migration once and miserably failed w/ lots of memleaks (probably not really related to my work).
So, unless someone wants to patch this (anyone from media-video? if not, just remove yourself from CC again), feel free to hardmask this for now (we might also consider removing it, but upstream's opinion might change, so hardmasking sounds like the best option for now).

[1] http://ffmpeg-php.sourceforge.net/
Comment 2 Alexis Ballier gentoo-dev 2008-10-20 13:52:58 UTC
*** Bug 242798 has been marked as a duplicate of this bug. ***
Comment 3 wayne 2008-12-09 21:39:57 UTC
is ffmpeg.php still under development? 
Comment 4 Samuli Suominen gentoo-dev 2008-12-10 23:44:11 UTC
And because of this, CCing treecleaners. You have 30 days to fix your package, new ffmpeg is with swscaler is going stable.
Comment 5 Samuli Suominen gentoo-dev 2008-12-11 10:02:28 UTC
   11 Dec 2008; <ssuominen@gentoo.org> package.mask:
+  Mask dev-php5/ffmpeg-php for removal in 30 days by treecleaners and media
+  because it doesn't build wrt #242050.
+
Comment 6 wayne 2008-12-11 18:43:19 UTC
Do not remove ffmpeg-php at least 12 projects are based on ffmpeg-php. A new version of drupal, VidiScript, phpmotion, etc. Someone will fix ffmpeg-php to keep their project going. If ffmpeg-php is not fixed by spring I will put a bounty on it to encourage someone to fix it. 
Comment 7 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-11 18:50:46 UTC
So, someone should put bug 250636 in the tree and be done with this mess, eh?
Comment 8 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-11 19:35:28 UTC
(In reply to comment #7)
> So, someone should put bug 250636 in the tree and be done with this mess, eh?
> 

I should add that it will only solve "this mess" if it compiles against ffmpeg 0.4.9_p20081014 otherwise it is a moot point. 
Comment 9 Samuli Suominen gentoo-dev 2008-12-11 20:31:45 UTC
0.5.3 removed from tree, replaced by 0.6.0. Unmasked.
Comment 10 Samuli Suominen gentoo-dev 2008-12-11 20:35:14 UTC
+  11 Dec 2008; <ssuominen@gentoo.org> package.mask:
+  Unmask dev-php5/ffmpeg-php thanks to b3hzat at gmail.com wrt #250636.