Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 241590 - gnome-base/gnome-mount-0.6: disable nautilus extension compilation as it doesn't work with recent gnome
Summary: gnome-base/gnome-mount-0.6: disable nautilus extension compilation as it does...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 244220 (view as bug list)
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-10-12 13:00 UTC by Pacho Ramos
Modified: 2008-11-27 22:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gnome-mount-extensions.patch (gnome-mount-extensions.patch,1.06 KB, patch)
2008-10-12 13:00 UTC, Pacho Ramos
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2008-10-12 13:00:33 UTC
Attached patch fixes this

Thanks

Reproducible: Always
Comment 1 Pacho Ramos gentoo-dev 2008-10-12 13:00:49 UTC
Created attachment 168168 [details, diff]
gnome-mount-extensions.patch
Comment 2 Pacho Ramos gentoo-dev 2008-10-12 13:08:16 UTC
Comment on attachment 168168 [details, diff]
gnome-mount-extensions.patch

I have just checked that, after installing it in extensions-2.0 causes nautilus to crash:
nautilus: symbol lookup error: /usr/lib64/nautilus/extensions-2.0/libgnome-mount.so: undefined symbol: nautilus_file_info_get_drive

Then, I think that the best solution is simply not installing nautilus extension until gnome-mount-0.8 hits the tree (I haven't tried 0.7) as 0.6 seems a bit old
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-10-12 19:33:57 UTC
more recent gnome-mount are not an option as they hard depend on policykit.
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-11-01 11:06:47 UTC
*** Bug 244220 has been marked as a duplicate of this bug. ***
Comment 5 Pacho Ramos gentoo-dev 2008-11-01 16:07:21 UTC
Are you sure policykit is really required by gnome-mount-0.8? I have just tried to manually make the version bump in my local overlay and it seems to work fine even with my system without no policykit at all

Thanks
Comment 6 Gilles Dartiguelongue gentoo-dev 2008-11-27 22:37:48 UTC
obsoleted by bug #218077 closure. Adding to tracker's list to have somewhere to look it for when stabilization comes.