Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 241528 - x11-libs/vte-0.17.4 tries to link to libffi which is not available on ppc
Summary: x11-libs/vte-0.17.4 tries to link to libffi which is not available on ppc
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-10-12 09:18 UTC by Laurent G.
Modified: 2008-10-20 20:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge log as requested (x11-libs:vte-0.17.4:20081017-202328.log.bz2,10.94 KB, application/octet-stream)
2008-10-17 20:36 UTC, Laurent G.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent G. 2008-10-12 09:18:35 UTC
vte-0.16.14 went ok but vte-0.17.4 won't.


Reproducible: Always
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-10-12 10:55:08 UTC
please provide emerge --info and build.log.
Comment 2 Laurent G. 2008-10-17 20:36:27 UTC
Created attachment 168844 [details]
emerge log as requested

# emerge --info                                     
Portage 2.2_rc12 (default/linux/powerpc/ppc32/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.26-gentoo-r1-l0 ppc)
=================================================================                                                
System uname: Linux-2.6.26-gentoo-r1-l0-ppc-7447A,_altivec_supported-with-glibc2.0                               
Timestamp of tree: Fri, 17 Oct 2008 19:00:01 +0000                                                               
distcc 2.18.3 powerpc-unknown-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]                       
ccache version 2.4 [enabled]                                                                                     
app-shells/bash:     3.2_p39                                                                                     
dev-java/java-config: 1.3.7, 2.1.6-r1                                                                            
dev-lang/python:     2.5.2-r8                                                                                    
dev-util/ccache:     2.4-r8                                                                                      
dev-util/cmake:      2.6.2                                                                                       
sys-apps/baselayout: 2.0.0                                                                                       
sys-apps/openrc:     0.3.0-r1                                                                                    
sys-apps/sandbox:    1.2.18.1-r3                                                                                 
sys-devel/autoconf:  2.13, 2.63                                                                                  
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1                                         
sys-devel/binutils:  2.18-r3                                                                                     
sys-devel/gcc-config: 1.4.0-r4                                                                                   
sys-devel/libtool:   2.2.6a                                                                                      
virtual/os-headers:  2.6.26                                                                                      
ACCEPT_KEYWORDS="ppc ~ppc"                                                                                       
CBUILD="powerpc-unknown-linux-gnu"                                                                               
CFLAGS="-mcpu=7400 -O2 -pipe -fno-strict-aliasing -maltivec -mabi=altivec"                                       
CHOST="powerpc-unknown-linux-gnu"                                                                                
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config"                                                                                                 
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"                                                                                                            
CXXFLAGS="-mcpu=7400 -O2 -pipe -fno-strict-aliasing -maltivec -mabi=altivec"                                                         
DISTDIR="/in_n_outs/distfiles"                                                                                                       
FEATURES="ccache distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"              
GENTOO_MIRRORS="http://mirror.uni-c.dk/pub/gentoo/ ftp://trumpetti.atm.tut.fi/gentoo/ ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/ ftp://ftp.heanet.ie/pub/gentoo/ ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo http://mirror.gentoo.no/ "                                                                                                                                
LANG="C"                                                                                                                             
LC_ALL="C"                                                                                                                           
LDFLAGS="-Wl,-O1"                                                                                                                    
LINGUAS="fr fr_FR"                                                                                                                   
MAKEOPTS="-j2"                                                                                                                       
PKGDIR="/in_n_outs/packages"                                                                                                         
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                                            
PORTAGE_TMPDIR="/var/tmp"                                                                                                            
PORTDIR="/usr/portage"                                                                                                               
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage/layman/kdesvn-portage"                                                        
SYNC="rsync://rsync.gentoo.org/gentoo-portage"                                                                                       
USE="X Xaw3d a52 acl alsa altivec apache2 berkdb branding bzip2 cdr cli cracklib crypt cscope cups dba dri dvd encode fbcon flac flash fortran gb gcj gd gdbm gnome gpm gtk2 iconv ipv6 isdnlog java jikes jpeg kde kdehiddenvisibility midi mng mozdevelop mozsvg mudflap ncurses nls nptl nptlonly nsplugin objc oggvorbis opengl openmp pam pcre pdf pdflib perl png povray ppc ppds pppd python qt readline reflection samba scanner session speex spell spl ssl svg sysfs tcpd tetex theora threads tiff tk udev unicode usb wmf xine xinerama xml2 xorg xosd xulrunner zlib" ALSA_CARDS="snd-aoa" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" USERLAND="GNU" VIDEO_CARDS="ati fbdev radeon fglrx"                                                                                               
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-10-19 10:55:59 UTC
it appears vte sources do not include ffi references whatsoever so I guess this comes from an errorneous libtool or pkgconfig file. Please grep through /usr/lib/pkgconfig and /usr/lib for .pc and .la files containing references to ffi and post the result here.
Comment 4 Laurent G. 2008-10-19 13:21:48 UTC
I guess you've given the clue. And I was bouncing on this with gnome-python-desktop.
The problem might not be finished as 

# grep -r ffi /usr/lib/pkgconfig
/usr/lib/pkgconfig/pygobject-2.0.pc:Libs: -L${libdir} -lffi

even though :
eix pygobject
[I] dev-python/pygobject
     Available versions:  (2)  2.12.3 2.14.0 2.14.1 2.14.2
        {X debug doc examples libffi}
     Installed versions:  2.14.2(2)(13:02:29 06/21/08)(-debug -doc -examples -libffi)

The compile must go on. I'll give the results at the end.
Thanks again.
Comment 5 Laurent G. 2008-10-19 13:50:10 UTC
I confirm : after getting rid, by hand, of "-lffi" in pygobject.pc vte, gnome-terminal, gnome-python-desktop emerged ok.
Is this a bug in pygobject that should be addressed or can I changed this bug to FIXED ?
Comment 6 Gilles Dartiguelongue gentoo-dev 2008-10-19 15:07:33 UTC
could you try rebuilding pygobject ? either latest 2.14 or 2.15.4 ? it looks like pygobject would not be respecting configure switch in which case we'd have to fix it.
Comment 7 Laurent G. 2008-10-20 20:40:40 UTC
It is ok now, with 2.15.4. Thanks again.