Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 241224 - startkde-3.5.10-r3 does not set KDEDIRS
Summary: startkde-3.5.10-r3 does not set KDEDIRS
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on: 237718
Blocks:
  Show dependency tree
 
Reported: 2008-10-11 03:18 UTC by Markus Strobl
Modified: 2008-10-12 01:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Strobl 2008-10-11 03:18:45 UTC
I have KDE3.5 and KDE4 installed in parallel. When logged into KDE3.5, the KDEDIRS environment variable is set to /usr:/usr/local:/usr/kde/4.2. This causes various problems such as no entries in kcontrol and kinfocenter. 

Looking in /usr/kde/3.5/bin/startkde I notice the setting of KDEDIRS is commented out. 

In /usr/kde/4.2/bin/startkde KDEDIRS is set.

If I uncomment the setting of KDEDIRS in /usr/kde/3.5/bin/startkde, everything seems to work correctly. 

Reproducible: Always

Actual Results:  
kcontrol window has no entries
kinfocenter empty
Oxygen icon theme from 4.X gets defaulted in KDE3.5, but many icons don't work.
Probably other problems as well...
Comment 1 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2008-10-11 18:15:17 UTC
This is a feature introduced to fix bug 237718.
Comment 2 Markus Strobl 2008-10-12 01:08:11 UTC
After reading bug 237718 it looks like my problem is caused by the startkde script in KDE4.2 setting KDEDIRS, when startkde in KDE3.5 does not. As ong as netiehr set KDEDIRS everything should work fine.

Since KDE4.2 is from an overlay and thus unsupported I'm OK with closing this bug.