Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 240690 - dev-python/wxpython-2.8.8.1 fails to compile /w python-2.6
Summary: dev-python/wxpython-2.8.8.1 fails to compile /w python-2.6
Status: RESOLVED DUPLICATE of bug 219238
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo wxWidgets Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-09 13:55 UTC by Sönke N. Greimann
Modified: 2009-05-18 12:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sönke N. Greimann 2008-10-09 13:55:37 UTC
Trying to upgrade to Python 2.6 using python-updater, wxpython is so far the only package left that won't emerge using the new python. Python 2.5.2-r8 is also installed, but 2.6 has been selected using eselect-python-20080830

Reproducible: always

Steps to reproduce:
1. emerge python-2.6
2. emerge wxpython-2.8.8.1

Expected results: wxpython should compile
Actual results: see below

"(...)
copying wxPython/lib/mixins/rubberband.py -> build-gtk2.unicode/lib.linux-i686-2.6/wxPython/lib/mixins
copying wxPython/lib/mixins/__init__.py -> build-gtk2.unicode/lib.linux-i686-2.6/wxPython/lib/mixins
creating build-gtk2.unicode/lib.linux-i686-2.6/wxPython/tools
copying wxPython/tools/img2img.py -> build-gtk2.unicode/lib.linux-i686-2.6/wxPython/tools
copying wxPython/tools/helpviewer.py -> build-gtk2.unicode/lib.linux-i686-2.6/wxPython/tools
copying wxPython/tools/img2png.py -> build-gtk2.unicode/lib.linux-i686-2.6/wxPython/tools
copying wxPython/tools/img2xpm.py -> build-gtk2.unicode/lib.linux-i686-2.6/wxPython/tools
copying wxPython/tools/dbg.py -> build-gtk2.unicode/lib.linux-i686-2.6/wxPython/tools
copying wxPython/tools/img2py.py -> build-gtk2.unicode/lib.linux-i686-2.6/wxPython/tools
copying wxPython/tools/__init__.py -> build-gtk2.unicode/lib.linux-i686-2.6/wxPython/tools
package init file 'wx/tools/XRCed/plugins/__init__.py' not found (or not a regular file)
running build_ext
building '_core_' extension
creating build-gtk2.unicode/temp.linux-i686-2.6
creating build-gtk2.unicode/temp.linux-i686-2.6/src
creating build-gtk2.unicode/temp.linux-i686-2.6/src/gtk
Traceback (most recent call last):
  File "setup.py", line 1024, in <module>
    **other_kw
  File "/usr/lib/python2.6/distutils/core.py", line 152, in setup
    dist.run_commands()
  File "/usr/lib/python2.6/distutils/dist.py", line 975, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python2.6/distutils/dist.py", line 995, in run_command
    cmd_obj.run()
  File "/usr/lib/python2.6/distutils/command/build.py", line 134, in run
    self.run_command(cmd_name)
  File "/usr/lib/python2.6/distutils/cmd.py", line 333, in run_command
    self.distribution.run_command(command)
  File "/usr/lib/python2.6/distutils/dist.py", line 995, in run_command
    cmd_obj.run()
  File "/usr/lib/python2.6/distutils/command/build_ext.py", line 343, in run
    self.build_extensions()
  File "/usr/lib/python2.6/distutils/command/build_ext.py", line 469, in build_extensions
    self.build_extension(ext)
  File "/usr/lib/python2.6/distutils/command/build_ext.py", line 534, in build_extension
    depends=ext.depends)
  File "/usr/lib/python2.6/distutils/ccompiler.py", line 700, in compile
    lang=lang)
TypeError: _compile() got an unexpected keyword argument 'lang'
 *
 * ERROR: dev-python/wxpython-2.8.8.1 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_compile
 * environment, line 2742:  Called die
 * The specific snippet of code:
 * python setup.py ${mypyconf} build || die "setup.py build failed"
 * The die message:
 * setup.py build failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-python/wxpython-2.8.8.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/wxpython-2.8.8.1/temp/environment'.
 *

>>> Failed to emerge dev-python/wxpython-2.8.8.1, Log file:

>>>  '/var/tmp/portage/dev-python/wxpython-2.8.8.1/temp/build.log'

 * GNU info directory index is up-to-date."

emerge --info:

Portage 2.2_rc11 (default-linux/x86/2007.0/desktop, gcc-4.3.1, glibc-2.7-r2, 2.6.26-gentoo-r1 i686)
=================================================================
System uname: Linux-2.6.26-gentoo-r1-i686-AMD_Athlon-tm-_XP_3000+-with-gentoo-2.0.0
Timestamp of tree: Wed, 08 Oct 2008 22:15:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8, 2.6-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror ftp://ftp.uni-erlangen .de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo ftp://ftp.gentoo.mesh-solutions.com/gentoo ftp://pandemonium.tiscali.de/pub/gentoo ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.gentoo.org/gentoo-distfiles ftp://ftp.tu-clausthal.de/pub/linux/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdparanoia cdr cli cracklib crypt cups dbus dmi dri dvd dvdr dvdread emboss encode esd evo fam ffmpeg firefox flac fortran gdbm gif gnome gnutls gpm gstreamer gtk hal iconv ipv6 isdnlog java jpeg kerberos mad midi mikmod mmap mmx mmxext moznopango mp3 mpeg mudflap ncurses nforce2 nfs nls nptl nptlonly nsplugin nvidia odbc offensive ogg opengl openmp oss pam pcre pdf perl pidgin png pppd python qt3support qt4 quicktime readline real reflection reiserfs rtc samba sdl session spell spl sse ssl startup-notification svg tcpd thunderbird tiff truetype unicode usb v4l v4l2 vorbis win32codecs x86 xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="intel8x0 intel8x0m mpu401 usb-audio virmidi" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="joystick keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa v4l vga"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Ryan Hill (RETIRED) gentoo-dev 2008-10-09 19:02:32 UTC
see bug #219238.

python guys, does 2.6 distutils need to be patched?
Comment 2 Sönke N. Greimann 2008-10-09 20:07:38 UTC
(In reply to comment #1)

FTR, the workaround given in Bug #240149 was unsuccessful, even though the stated problem with the leading extra slash was manifest also after installing python-2.6.

I had a number of other packages fail to compile but all of those were able to manually install after the above mentioned workaround or by bumping the offending package to a newer testing version...

wxpython is the last culprit not installing for me, here.
Comment 3 Ryan Hill (RETIRED) gentoo-dev 2008-10-21 23:24:20 UTC

*** This bug has been marked as a duplicate of bug 219238 ***