Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 239973 - app-admin/syslog-ng-2.0.9: circular dependencies with fam flag
Summary: app-admin/syslog-ng-2.0.9: circular dependencies with fam flag
Status: RESOLVED DUPLICATE of bug 175808
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-05 13:36 UTC by Mikołaj Kąkol
Modified: 2008-10-05 15:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikołaj Kąkol 2008-10-05 13:36:32 UTC
When emerging app-admin/syslog-ng-2.0.9 with flag "fam" there is !!! Error: circular dependencies:

('ebuild', '/', 'app-admin/gamin-0.1.9-r1', 'merge') depends on
   ('ebuild', '/', 'dev-libs/glib-2.16.5', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.5', 'merge') depends on
   ('ebuild', '/', 'app-admin/gamin-0.1.9-r1', 'merge') (hard)


Reproducible: Always

Steps to Reproduce:
1. emerge syslog-ng -pv

Actual Results:  
# emerge syslog-ng -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[nomerge      ] app-admin/syslog-ng-2.0.9  USE="ipv6 tcpd -hardened (-selinux) -spoof-source -static" 
[nomerge      ]  dev-libs/glib-2.16.5  USE="fam -debug -hardened (-selinux) -xattr" 
[ebuild  N    ]   app-admin/gamin-0.1.9-r1  USE="python -debug" 
[ebuild  N    ]    dev-libs/glib-2.16.5  USE="fam -debug -hardened (-selinux) -xattr" 
!!! Error: circular dependencies:

('ebuild', '/', 'app-admin/gamin-0.1.9-r1', 'merge') depends on
   ('ebuild', '/', 'dev-libs/glib-2.16.5', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.5', 'merge') depends on
   ('ebuild', '/', 'app-admin/gamin-0.1.9-r1', 'merge') (hard)

!!! Note that circular dependencies can often be avoided by temporarily
!!! disabling USE flags that trigger optional dependencies.


Expected Results:  
USE="-fam"  emerge syslog-ng -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] dev-util/pkgconfig-0.23  USE="-hardened" 1,008 kB 
[ebuild  N    ] dev-libs/eventlog-0.2.7  316 kB 
[ebuild  N    ] dev-libs/glib-2.16.5  USE="-debug -fam -hardened (-selinux) -xattr" 4,464 kB 
[ebuild  N    ] app-admin/syslog-ng-2.0.9  USE="ipv6 tcpd -hardened (-selinux) -spoof-source -static" 370 kB 

Total: 4 packages (4 new), Size of downloads: 6,156 kB


localhost linux # emerge syslog-ng -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[nomerge      ] app-admin/syslog-ng-2.0.9  USE="ipv6 tcpd -hardened (-selinux) -spoof-source -static" 
[nomerge      ]  dev-libs/glib-2.16.5  USE="fam -debug -hardened (-selinux) -xattr" 
[ebuild  N    ]   app-admin/gamin-0.1.9-r1  USE="python -debug" 
[ebuild  N    ]    dev-libs/glib-2.16.5  USE="fam -debug -hardened (-selinux) -xattr" 
!!! Error: circular dependencies:

('ebuild', '/', 'app-admin/gamin-0.1.9-r1', 'merge') depends on
   ('ebuild', '/', 'dev-libs/glib-2.16.5', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.5', 'merge') depends on
   ('ebuild', '/', 'app-admin/gamin-0.1.9-r1', 'merge') (hard)

!!! Note that circular dependencies can often be avoided by temporarily
!!! disabling USE flags that trigger optional dependencies.
localhost linux # USE="-fam"  emerge syslog-ng -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] dev-util/pkgconfig-0.23  USE="-hardened" 1,008 kB 
[ebuild  N    ] dev-libs/eventlog-0.2.7  316 kB 
[ebuild  N    ] dev-libs/glib-2.16.5  USE="-debug -fam -hardened (-selinux) -xattr" 4,464 kB 
[ebuild  N    ] app-admin/syslog-ng-2.0.9  USE="ipv6 tcpd -hardened (-selinux) -spoof-source -static" 370 kB 

Total: 4 packages (4 new), Size of downloads: 6,156 kB
Comment 1 Zac Medico gentoo-dev 2008-10-05 15:19:17 UTC
Assuming that the dependencies are specified correctly, this is an issue that has the same solution as bug 175808.

*** This bug has been marked as a duplicate of bug 175808 ***