Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 239262 - python-updater always emerges dev-libs/boost
Summary: python-updater always emerges dev-libs/boost
Status: RESOLVED DUPLICATE of bug 232467
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-01 16:39 UTC by Kamil Kisiel
Modified: 2008-10-01 21:45 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kamil Kisiel 2008-10-01 16:39:24 UTC
It seems that python-updater will always re-emerge dev-libs/boost. This is especially apparent if you are doing a python-updater update that gets interrupted midway and you have to restart, boost will get re-emerged at the start even if it was already done in the previous run.

Reproducible: Always
Comment 1 Christophe LEFEBVRE 2008-10-01 18:22:20 UTC
Well, can you send us the result of "equery depends boost" ? Maybe, it's another package who needs boost. Can you give us also the version of python-updater you emerge ? How do you emerge python-updater ? By an "emerge python-updater" or by using some emerge options ?
Comment 2 Kamil Kisiel 2008-10-01 20:31:16 UTC
I don't mean to say that emerging python updater emerges boost. Rather that *running* python-updater does.

For completeness:
psicose tmp # equery depends boost
[ Searching for packages depending on boost... ]
sci-chemistry/openbabel-2.2.0 (dev-libs/boost)

I've reproduced this problem on a number of systems (with different configurations, but all with Boost installed) here when running python-updater.
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2008-10-01 21:45:18 UTC
This is a known issue. It is impossible for portage to determine which version these packages have been emerged with, so if they're installed, they will always be emerged. Not optimal, but the only way to not have random breakage. From "man python-updater":
       manual
           python-updater has a list of packages that are known to break
           by python upgrades but can't be determined by methods specified
           above. This check can be disabled if you're sure you've rebuilt
           the package once and it's OK now.
           Enabled by default.

use -dmanual to disable this unfortunate necessity.

*** This bug has been marked as a duplicate of bug 232467 ***