Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 238915 - [gnome-overlay] >=app-misc/tomboy-0.12.0 is required by gnome-base/gnome-2.24.0
Summary: [gnome-overlay] >=app-misc/tomboy-0.12.0 is required by gnome-base/gnome-2.24.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
: 241440 (view as bug list)
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-09-28 00:28 UTC by Maciej Piechotka
Modified: 2009-03-23 13:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
app-misc/tomboy-0.12.0.ebuild (tomboy-0.12.0.ebuild,1.59 KB, text/plain)
2008-09-28 00:58 UTC, Maciej Piechotka
Details
0001-Tomboy-0.12.0-version-bump.patch (0001-Tomboy-0.12.0-version-bump.patch,4.19 KB, patch)
2008-09-28 00:59 UTC, Maciej Piechotka
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Piechotka 2008-09-28 00:28:13 UTC
# emerge -avDuN world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=app-misc/tomboy-0.12.0".
(dependency required by "gnome-base/gnome-2.24.0" [ebuild])


 * GNU info directory index is up-to-date.



Reproducible: Always




Portage 2.2_rc11 (default/linux/x86/2008.0/developer, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.27-rc5-zen2 i686)
=================================================================
System uname: Linux-2.6.27-rc5-zen2-i686-Intel-R-_Celeron-R-_M_processor_1.50GHz-with-glibc2.0
Timestamp of tree: Sat, 27 Sep 2008 22:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=pentium-m -mfpmath=sse -pipe -momit-leaf-frame-pointer -ggdb -w -ftree-vectorize -ftree-loop-optimize -freorder-blocks-and-partition -fgcse-sm -fgcse-las -fgcse-after-reload -ftracer -maccumulate-outgoing-args"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-Os -march=pentium-m -mfpmath=sse -pipe -momit-leaf-frame-pointer -ggdb -w -ftree-vectorize -ftree-loop-optimize -freorder-blocks-and-partition -fgcse-sm -fgcse-las -fgcse-after-reload -ftracer -maccumulate-outgoing-args -fvisibility-inlines-hidden"
DISTDIR="/var/tmp/distfiles"
FEATURES="ccache collision-protect cvs digest distlocks multilib-strict parallel-fetch prelink preserve-libs protect-owned sandbox sfperms sign splitdebug stricter unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--add-needed -Wl,--as-needed -Wl,--hash-style=both -Wl,--sort-common"
LINGUAS="en_GB en_US pl"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/java-overlay /usr/portage/local/layman/vala-overlay /usr/portage/local/layman/gnome /usr/portage/local/layman/banshee-overlay /usr/portage/local/layman/x11 /usr/portage/local/layman/zen-overlay /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa applet attr avahi avalon bash-completion berkdb bittorrent boo browseplugin bzip2 c++ cairo calendar caps cddb cdparanoia cdr cli clisp context cracklib crypt cups curl curlwrappers cxx d daap dbus deskbar devhelp disk-partition djvu docbook dri dvd dvdnav dvdr dvdread eclipse eds emacs emboss encode eog epiphany esd evo evolution exif expat extra fam ffmpeg flac flash fortran fuse galago gconf gd gdbm gdl gedit gif gimp git glib glut gmail gmp gnome gnome-keyring gnutls gpm gsf gstreamer gtk guile hal iconv idle imap inherit-graph inotify ipod iproute2 ipv6 isdnlog jabber java java5 java6 jingle jpeg jpeg2k jython kerberos keyring kqemu laptop latex libburn libffi libgda libnotify libsexy logrotate lucene mad maildir mailwrapper mhash midi mikmod mmap mmx mono moonlight mozilla mp3 mpeg mudflap mule musicbrainz nautilus ncurses network networkmanager nls nntp no-old-linux nptl nptlonly nsplugin ntpl ogg oggvorbis openal opengl openmp pam pango pbm pccts pch pcre pda pdf perl png policykit pop postgres ppds pppd pulseaudio python qt3support quicktime raw readline reflection regex reiserfs resolvconf rhino ruby samba scanner science sdl session snmp soap soup sourceview spell spl sqlite sqlite3 sse sse2 ssh ssl startup-notification subversion svg symlink sysfs syslog tcpd tetex theora threads threadsafe tiff timidity totem tracker trayicon truetype unicode usb valgrind vim vorbis vte wifi win32codecs wxwindows x86 xattr xcb xforms xhtml xml xml2 xorg xsl xslt xulrunner xv zeroconf zlib" ALSA_CARDS="atiixp" ALSA_PCM_PLUGINS="null empty dmix dshare ioplug" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="panasonic" ELIBC="glibc" INPUT_DEVICES="evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en_US pl" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Maciej Piechotka 2008-09-28 00:58:48 UTC
Created attachment 166650 [details]
app-misc/tomboy-0.12.0.ebuild

The working ebuild (added dependency as it do not build with gnome-base/libgnomeprintui-2.18.2).
Comment 2 Maciej Piechotka 2008-09-28 00:59:39 UTC
Created attachment 166652 [details, diff]
0001-Tomboy-0.12.0-version-bump.patch

Patch created for git (by format-patch).
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-09-29 08:41:45 UTC
won't work with current status of gtk-sharp deps in the tree but will fix the meta to depend on 0.11.* in the meantime.
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-10-11 23:47:06 UTC
*** Bug 241440 has been marked as a duplicate of this bug. ***
Comment 5 Gilles Dartiguelongue gentoo-dev 2008-11-08 11:42:46 UTC
ugh, I fixed this a while ago already.