Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 238849 - x11-libs/cairo-1.8.0 depends on app-text/poppler gtk use flag
Summary: x11-libs/cairo-1.8.0 depends on app-text/poppler gtk use flag
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Doug Goldstein
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-09-27 11:10 UTC by Maciej Piechotka
Modified: 2008-11-02 00:34 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Piechotka 2008-09-27 11:10:05 UTC
x11-libs/cairo-1.8.0 depends on app-text/poppler gtk use flag, which has been moved to app-text/poppler-bindings

Reproducible: Always

Actual Results:  
 * 
 * ERROR: x11-libs/cairo-1.8.0 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called pkg_setup
 * cairo-1.8.0.ebuild, line   52:  Called built_with_use 'app-text/poppler' 'gtk'
 * eutils.eclass, line 1740:  Called die
 * The specific snippet of code:
 * die)   die "$PKG does not actually support the $1 USE flag!";;
 * The die message:
 * app-text/poppler-0.9.2 does not actually support the gtk USE flag!
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-libs/cairo-1.8.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/cairo-1.8.0/temp/die.env'.
 * 



# emerge --info
Portage 2.2_rc11 (default/linux/x86/2008.0/developer, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.27-rc5-zen2 i686)
=================================================================
System uname: Linux-2.6.27-rc5-zen2-i686-Intel-R-_Celeron-R-_M_processor_1.50GHz-with-glibc2.0
Timestamp of tree: Sat, 27 Sep 2008 02:05:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=pentium-m -mfpmath=sse -pipe -momit-leaf-frame-pointer -ggdb -w -ftree-vectorize -ftree-loop-optimize -freorder-blocks-and-partition -fgcse-sm -fgcse-las -fgcse-after-reload -ftracer -maccumulate-outgoing-args"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-Os -march=pentium-m -mfpmath=sse -pipe -momit-leaf-frame-pointer -ggdb -w -ftree-vectorize -ftree-loop-optimize -freorder-blocks-and-partition -fgcse-sm -fgcse-las -fgcse-after-reload -ftracer -maccumulate-outgoing-args -fvisibility-inlines-hidden"
DISTDIR="/var/tmp/distfiles"
FEATURES="ccache collision-protect cvs digest distlocks multilib-strict parallel-fetch prelink preserve-libs protect-owned sandbox sfperms sign splitdebug stricter unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--add-needed -Wl,--as-needed -Wl,--hash-style=both -Wl,--sort-common"
LINGUAS="en_GB en_US pl"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/java-overlay /usr/portage/local/layman/vala-overlay /usr/portage/local/layman/gnome /usr/portage/local/layman/banshee-overlay /usr/portage/local/layman/x11 /usr/portage/local/layman/zen-overlay /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa applet attr avahi avalon bash-completion berkdb bittorrent boo browseplugin bzip2 c++ cairo calendar caps cddb cdparanoia cdr cli clisp context cracklib crypt cups curl curlwrappers cxx d daap dbus deskbar devhelp disk-partition djvu docbook dri dvd dvdnav dvdr dvdread eclipse eds emacs emboss encode eog epiphany esd evo evolution exif expat extra fam ffmpeg flac flash fortran fuse galago gconf gd gdbm gdl gedit gif gimp git glib glut gmail gmp gnome gnome-keyring gnutls gpm gsf gstreamer gtk guile hal iconv idle imap inherit-graph inotify ipod iproute2 ipv6 isdnlog jabber java java5 java6 jingle jpeg jpeg2k jython kerberos keyring kqemu laptop latex libburn libffi libgda libnotify libsexy logrotate lucene mad maildir mailwrapper mhash midi mikmod mmap mmx mono moonlight mozilla mp3 mpeg mudflap mule musicbrainz nautilus ncurses network networkmanager nls nntp no-old-linux nptl nptlonly nsplugin ntpl ogg oggvorbis openal opengl openmp pam pango pbm pccts pch pcre pda pdf perl png policykit pop postgres ppds pppd pulseaudio python qt3support quicktime raw readline reflection regex reiserfs resolvconf rhino ruby samba scanner science sdl session snmp soap soup sourceview spell spl sqlite sqlite3 sse sse2 ssh ssl startup-notification subversion svg symlink sysfs syslog tcpd tetex theora threads threadsafe tiff timidity totem tracker trayicon truetype unicode usb valgrind vim vorbis vte wifi win32codecs wxwindows x86 xattr xcb xforms xhtml xml xml2 xorg xsl xslt xulrunner xv zeroconf zlib" ALSA_CARDS="atiixp" ALSA_PCM_PLUGINS="null empty dmix dshare ioplug" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="panasonic" ELIBC="glibc" INPUT_DEVICES="evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en_US pl" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

# eix 'poppler(|-bindings)$'
[I] app-text/poppler
     Available versions:  *0.6.1-r1 0.6.3-r1 (~)0.8.5 (~)0.8.7 {M}(~)0.9.2 {cjk doc jpeg zlib}
     Installed versions:  0.9.2(10:28:46 AM 09/27/2008)(jpeg zlib -cjk -doc)
     Homepage:            http://poppler.freedesktop.org/
     Description:         PDF rendering library based on the xpdf-3.0 code base

[I] app-text/poppler-bindings
     Available versions:  *0.6.1 0.6.3 (~)0.8.5 (~)0.8.7 {cairo gtk qt3 qt4 test}
     Installed versions:  0.8.7(11:58:10 AM 09/04/2008)(cairo gtk -qt3 -qt4 -test)
     Homepage:            http://poppler.freedesktop.org/
     Description:         rendering bindings for GUI toolkits for poppler

* dev-ruby/ruby-poppler
     Available versions:  (~)0.16.0 (~)0.16.0-r1
     Homepage:            http://ruby-gnome2.sourceforge.jp/
     Description:         Ruby poppler-glib bindings

Found 3 matches.
Comment 1 Denny Reeh 2008-09-27 11:19:00 UTC
same for me
Comment 2 Florian Scandella 2008-09-27 17:58:50 UTC
if i understand this ( https://bugs.freedesktop.org/show_bug.cgi?id=9131 ) correctly, poppler is only used for the test suite and should only be in DEPEND if test flag is enabled.
Comment 3 James 2008-09-27 21:07:17 UTC
removing the following lines allow it to build. Its also worth mentioning that the test workaround is pointless because it would just cause a circular dependency with cairo and gtk thus test is disabled in cairo 1.8.0.

pkg_setup() {
	if ! built_with_use app-text/poppler gtk ; then
		eerror 'poppler with gtk is required for the pdf backend'
		die 'poppler built without gtk support'
	fi
}


It was necessary to bump pango to 1.22.0 for it to compile against cairo 1.8.0

Comment 4 Gilles Dartiguelongue gentoo-dev 2008-09-29 08:54:30 UTC
circular dependencies in the case of tests is something that is not so rare and tests shouldn't be enabled for a first time install anyway.
Comment 5 Mart Raudsepp gentoo-dev 2008-11-02 00:34:15 UTC
cairo-1.8 has tests disabled (since some time ago committed on Doug's request) - they were never supposed to get re-enabled anyhow compared to 1.7.