Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 238840 - [gnome-overlay] Upgrade dev-python/pygtk-2.13.0 (& pygobject?)
Summary: [gnome-overlay] Upgrade dev-python/pygtk-2.13.0 (& pygobject?)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-09-27 07:48 UTC by Maciej Piechotka
Modified: 2008-09-27 21:39 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Piechotka 2008-09-27 07:48:31 UTC
dev-python/pygtk-2.13.0 has bug in gtk.gdk.threads_init() fixed in next versions

Reproducible: Always
Comment 1 Maciej Piechotka 2008-09-27 09:44:33 UTC
Changed servity and added to blocking as it breaks many apps.
Comment 2 Maciej Piechotka 2008-09-27 10:08:48 UTC
Simple copy of the pygobject ebuild from 2.15.2 to 2.15.4 do it's work.
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-09-27 17:56:55 UTC
2.15.4 has mutliple issues which is why I haven't commited it yet. Please help upstream fix its 64 bits issues.

http://bugzilla.gnome.org/show_bug.cgi?id=550317
Comment 4 Maciej Piechotka 2008-09-27 20:08:49 UTC
(In reply to comment #3)
> 2.15.4 has mutliple issues which is why I haven't commited it yet. Please help
> upstream fix its 64 bits issues.
> 
> http://bugzilla.gnome.org/show_bug.cgi?id=550317
> 

Only if you sponsor a new computer ;) - I have no access to >64-bit system.

Is it possible to keep 2.15.2 for x86-64 and for rest 2.15.4? 
Comment 5 Gilles Dartiguelongue gentoo-dev 2008-09-27 21:39:46 UTC
I've bumped in overlay and put a warning for the gio brokeness. It shouldn't be used yet so it should be safe for the tree.