Just a quick note to say that the dependencies in the 2.24.0 totem ebuild aren't the same as those of the configure script. The ones that I picked up on doing an upgrade were the following:
Requested 'gtk+-2.0 >= 2.13.0' but version of GTK+ is 2.12.12
Requested 'totem-plparser >= 2.23.91' but version of totem-plparser is 2.22.3
but there may be more. Let me know if you need any more information... 5:)
Fixed. Thanks for the report :)
For the record, I've checked the other deps, they look fine.